Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Подстановка значения с другого листа (формула) - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подстановка значения с другого листа (формула) (Формулы/Formulas)
Подстановка значения с другого листа (формула)
Cepega5 Дата: Понедельник, 01.10.2018, 22:48 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Добрый день! Прошу помочь с созданием формулы.

В приложенном файле нужно сделать следующее. Значение котировки акции, которое находится в столбце K на листе Котировки и обновляется автоматически при открытии файла, нужно подставить на лист 27.09 в столбец D. Сложность в том, что лист Котировки обновляется и компании (Башнефт, Акрон МосЭнерго) меняются местами.

В идеале как все должно работать. Я ввожу на рабочем листе "27.09" в столбец А название актива (например, Газпром). После этого актуальное значение из столбца K на листе "Котировки" автоматически подставляется в столбец D на листе "27.09".
К сообщению приложен файл: file.xlsx(47.3 Kb)
 
Ответить
СообщениеДобрый день! Прошу помочь с созданием формулы.

В приложенном файле нужно сделать следующее. Значение котировки акции, которое находится в столбце K на листе Котировки и обновляется автоматически при открытии файла, нужно подставить на лист 27.09 в столбец D. Сложность в том, что лист Котировки обновляется и компании (Башнефт, Акрон МосЭнерго) меняются местами.

В идеале как все должно работать. Я ввожу на рабочем листе "27.09" в столбец А название актива (например, Газпром). После этого актуальное значение из столбца K на листе "Котировки" автоматически подставляется в столбец D на листе "27.09".

Автор - Cepega5
Дата добавления - 01.10.2018 в 22:48
Светлый Дата: Понедельник, 01.10.2018, 23:34 | Сообщение № 2
Группа: Проверенные
Ранг: Ветеран
Сообщений: 749
Репутация: 199 ±
Замечаний: 0% ±

Excel 2010
Добрый вечер!
Код
=ЕСЛИОШИБКА(ВПР(A2;Котировки!C$2:K$206;9;);)
*Или чуть-чуть расширить:
Код
=ЕСЛИОШИБКА(ВПР(A2&"*";Котировки!C$2:K$206;9;);)


Программировать проще, чем писать стихи.

Сообщение отредактировал Светлый - Понедельник, 01.10.2018, 23:39
 
Ответить
СообщениеДобрый вечер!
Код
=ЕСЛИОШИБКА(ВПР(A2;Котировки!C$2:K$206;9;);)
*Или чуть-чуть расширить:
Код
=ЕСЛИОШИБКА(ВПР(A2&"*";Котировки!C$2:K$206;9;);)

Автор - Светлый
Дата добавления - 01.10.2018 в 23:34
_Boroda_ Дата: Понедельник, 01.10.2018, 23:36 | Сообщение № 3
Группа: Модераторы
Ранг: Местный житель
Сообщений: 13697
Репутация: 5585 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так нужно?
Код
=ЕСЛИОШИБКА(ВПР(СЖПРОБЕЛЫ(A2);Котировки!C$1:K$999;9;);)

Код
=ЕСЛИОШИБКА(ИНДЕКС(Котировки!K:K;ПОИСКПОЗ(СЖПРОБЕЛЫ(A2);Котировки!C$1:C$999;));)

Код
=ЕСЛИОШИБКА(ПРОСМОТР(;-1/(СЖПРОБЕЛЫ(A2)=Котировки!C$1:C$999);Котировки!K$1:K$999);)


Звездочку в таком виде
Цитата Светлый, 01.10.2018 в 23:34, в сообщении № 2 ()
(A2&"*";
нельзя - есть "Варьеган", "Квадра" и "Варьеган-п", "Квадра-п"
К сообщению приложен файл: file_1.xlsx(49.8 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак нужно?
Код
=ЕСЛИОШИБКА(ВПР(СЖПРОБЕЛЫ(A2);Котировки!C$1:K$999;9;);)

Код
=ЕСЛИОШИБКА(ИНДЕКС(Котировки!K:K;ПОИСКПОЗ(СЖПРОБЕЛЫ(A2);Котировки!C$1:C$999;));)

Код
=ЕСЛИОШИБКА(ПРОСМОТР(;-1/(СЖПРОБЕЛЫ(A2)=Котировки!C$1:C$999);Котировки!K$1:K$999);)


Звездочку в таком виде
Цитата Светлый, 01.10.2018 в 23:34, в сообщении № 2 ()
(A2&"*";
нельзя - есть "Варьеган", "Квадра" и "Варьеган-п", "Квадра-п"

Автор - _Boroda_
Дата добавления - 01.10.2018 в 23:36
Cepega5 Дата: Вторник, 02.10.2018, 10:39 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
К сообщению приложен файл: file_1.xlsx(49.8 Kb)


Спасибо большое! Да, это то, что нужно. Все работает!


Сообщение отредактировал Cepega5 - Вторник, 02.10.2018, 10:49
 
Ответить
Сообщение
К сообщению приложен файл: file_1.xlsx(49.8 Kb)


Спасибо большое! Да, это то, что нужно. Все работает!

Автор - Cepega5
Дата добавления - 02.10.2018 в 10:39
_Boroda_ Дата: Вторник, 02.10.2018, 10:42 | Сообщение № 5
Группа: Модераторы
Ранг: Местный житель
Сообщений: 13697
Репутация: 5585 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
А если поставить в столбце Д общий формат? Или числовой с двумя знаками после запятой
Если не поможет, то покажите в файле


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеА если поставить в столбце Д общий формат? Или числовой с двумя знаками после запятой
Если не поможет, то покажите в файле

Автор - _Boroda_
Дата добавления - 02.10.2018 в 10:42
Cepega5 Дата: Вторник, 02.10.2018, 10:49 | Сообщение № 6
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Уже все работает, спасибо, разобрался)

Излишнее цитирование удалено администрацией - это нарушение п.5j Правил форума
 
Ответить
СообщениеУже все работает, спасибо, разобрался)

Излишнее цитирование удалено администрацией - это нарушение п.5j Правил форума

Автор - Cepega5
Дата добавления - 02.10.2018 в 10:49
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подстановка значения с другого листа (формула) (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!