Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Как в одной ячейке сложить много чисел разделенных пробелом - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как в одной ячейке сложить много чисел разделенных пробелом (Формулы/Formulas)
Как в одной ячейке сложить много чисел разделенных пробелом
Gudvin Дата: Вторник, 02.10.2018, 13:47 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 20% ±

Excel 2010
Ситуация такая есть данные в одной ячейке 12 чисел пример (7 1 24 13 3 8 6 17 16 20 10 18
) разделенные пробелами между числами, есть где один пробел а где 2 пробела между числами надо сложить числа именно в ячейках где 12 чисел разделенные пробелом и вывести результат в соседнюю ячейку. Файл прикладываю
К сообщению приложен файл: 9901051.xls(27.0 Kb)
 
Ответить
СообщениеСитуация такая есть данные в одной ячейке 12 чисел пример (7 1 24 13 3 8 6 17 16 20 10 18
) разделенные пробелами между числами, есть где один пробел а где 2 пробела между числами надо сложить числа именно в ячейках где 12 чисел разделенные пробелом и вывести результат в соседнюю ячейку. Файл прикладываю

Автор - Gudvin
Дата добавления - 02.10.2018 в 13:47
_Boroda_ Дата: Вторник, 02.10.2018, 14:05 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 13697
Репутация: 5585 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так нужно?
Код
=СУММПРОИЗВ(--ПСТР(ПОДСТАВИТЬ(" "&СЖПРОБЕЛЫ(ПОДСТАВИТЬ(A1;СИМВОЛ(160);" "));" ";ПОВТОР(" ";99));СТРОКА($1:$12)*99;99))


*Там у Вас не пробелы, а неразрывные пробелы (символ 160)

Или в диспетчер имен (Контрл F3) формулу с именем сум_
Код
=ВЫЧИСЛИТЬ("="&ПОДСТАВИТЬ(СЖПРОБЕЛЫ(ПОДСТАВИТЬ(Лист1!$A1;СИМВОЛ(160);" "));" ";"+"))

и на листе формулу
Код
=сум_

Макросов в файле нет, но они должны быть разрешены

Файл перевложил

Или формула массива
Код
=СУММ(ЕСЛИОШИБКА(--ПСТР(ПОДСТАВИТЬ(A1;СИМВОЛ(160);ПОВТОР(" ";99));(СТРОКА($1:$99)-1)*99+1;99);))
К сообщению приложен файл: 9901051_2.xls(29.5 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак нужно?
Код
=СУММПРОИЗВ(--ПСТР(ПОДСТАВИТЬ(" "&СЖПРОБЕЛЫ(ПОДСТАВИТЬ(A1;СИМВОЛ(160);" "));" ";ПОВТОР(" ";99));СТРОКА($1:$12)*99;99))


*Там у Вас не пробелы, а неразрывные пробелы (символ 160)

Или в диспетчер имен (Контрл F3) формулу с именем сум_
Код
=ВЫЧИСЛИТЬ("="&ПОДСТАВИТЬ(СЖПРОБЕЛЫ(ПОДСТАВИТЬ(Лист1!$A1;СИМВОЛ(160);" "));" ";"+"))

и на листе формулу
Код
=сум_

Макросов в файле нет, но они должны быть разрешены

Файл перевложил

Или формула массива
Код
=СУММ(ЕСЛИОШИБКА(--ПСТР(ПОДСТАВИТЬ(A1;СИМВОЛ(160);ПОВТОР(" ";99));(СТРОКА($1:$99)-1)*99+1;99);))

Автор - _Boroda_
Дата добавления - 02.10.2018 в 14:05
sboy Дата: Вторник, 02.10.2018, 14:11 | Сообщение № 3
Группа: Друзья
Ранг: Старожил
Сообщений: 2238
Репутация: 634 ±
Замечаний: 0% ±

Excel 2010
Добрый день.
Вариант пользовательской функцией
[vba]
Код
Function Gudvin(t)
    With CreateObject("VBScript.RegExp")
        .Pattern = "\d+"
        .Global = True
        For i = 0 To .Execute(t).Count - 1
            Gudvin = Gudvin + Val(.Execute(t)(i))
        Next
    End With
End Function
[/vba]
К сообщению приложен файл: 2542528.xls(34.5 Kb)
 
Ответить
СообщениеДобрый день.
Вариант пользовательской функцией
[vba]
Код
Function Gudvin(t)
    With CreateObject("VBScript.RegExp")
        .Pattern = "\d+"
        .Global = True
        For i = 0 To .Execute(t).Count - 1
            Gudvin = Gudvin + Val(.Execute(t)(i))
        Next
    End With
End Function
[/vba]

Автор - sboy
Дата добавления - 02.10.2018 в 14:11
Gudvin Дата: Вторник, 02.10.2018, 14:13 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 20% ±

Excel 2010
Так нужно?

Да все так спасибо большое! Вы просто бог экселя!)
 
Ответить
Сообщение
Так нужно?

Да все так спасибо большое! Вы просто бог экселя!)

Автор - Gudvin
Дата добавления - 02.10.2018 в 14:13
Gudvin Дата: Вторник, 02.10.2018, 14:17 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 20% ±

Excel 2010
Добрый день.
Вариант пользовательской функцией

Добрый! И вам спасибо большое за ответ!
 
Ответить
Сообщение
Добрый день.
Вариант пользовательской функцией

Добрый! И вам спасибо большое за ответ!

Автор - Gudvin
Дата добавления - 02.10.2018 в 14:17
Светлый Дата: Среда, 03.10.2018, 06:32 | Сообщение № 6
Группа: Проверенные
Ранг: Ветеран
Сообщений: 749
Репутация: 199 ±
Замечаний: 0% ±

Excel 2010
Вставлю свои пять копеек. В первых кавычках копипаст СИМВОЛ(160):
Код
=СУММПРОИЗВ(--(0&СЖПРОБЕЛЫ(ПСТР(ПОДСТАВИТЬ(A1;" ";ПОВТОР(" ";99));СТОЛБЕЦ(A:Z)*99-98;99))))


Программировать проще, чем писать стихи.
 
Ответить
СообщениеВставлю свои пять копеек. В первых кавычках копипаст СИМВОЛ(160):
Код
=СУММПРОИЗВ(--(0&СЖПРОБЕЛЫ(ПСТР(ПОДСТАВИТЬ(A1;" ";ПОВТОР(" ";99));СТОЛБЕЦ(A:Z)*99-98;99))))

Автор - Светлый
Дата добавления - 03.10.2018 в 06:32
Gudvin Дата: Четверг, 04.10.2018, 15:12 | Сообщение № 7
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 20% ±

Excel 2010
Цитата Светлый, 03.10.2018 в 06:32, в сообщении № 6 ()
Вставлю свои пять копеек. В первых кавычках копипаст СИМВОЛ(160):

Спасибо за ответ.
 
Ответить
Сообщение
Цитата Светлый, 03.10.2018 в 06:32, в сообщении № 6 ()
Вставлю свои пять копеек. В первых кавычках копипаст СИМВОЛ(160):

Спасибо за ответ.

Автор - Gudvin
Дата добавления - 04.10.2018 в 15:12
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как в одной ячейке сложить много чисел разделенных пробелом (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!