Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Разделение символов - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Разделение символов (Формулы/Formulas)
Разделение символов
Qualcomm Дата: Пятница, 12.10.2018, 13:20 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 47
Репутация: 0 ±
Замечаний: 20% ±

Excel 2013
Помогите пожалуйста составить формулу, которая будет разделять цифры числа по ячейкам. Например 8534 нужно разделить отдельно по ячейкам 8 5 3 4 в разных ячейках. Например 758364 - 7 5 8 3 6 4, то есть что бы число разделялось отдельно по цифрам в разных ячейках, 7 в одной ячейке, 5 в следующей, 8 в следующей
К сообщению приложен файл: 3454966.xlsx(8.0 Kb)
 
Ответить
СообщениеПомогите пожалуйста составить формулу, которая будет разделять цифры числа по ячейкам. Например 8534 нужно разделить отдельно по ячейкам 8 5 3 4 в разных ячейках. Например 758364 - 7 5 8 3 6 4, то есть что бы число разделялось отдельно по цифрам в разных ячейках, 7 в одной ячейке, 5 в следующей, 8 в следующей

Автор - Qualcomm
Дата добавления - 12.10.2018 в 13:20
_Boroda_ Дата: Пятница, 12.10.2018, 13:29 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 13698
Репутация: 5587 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так нужно?
Код
=ПСТР($B4;СТОЛБЕЦ(A4);1)

Если нужны числовые цифры, то
Код
=ЕСЛИОШИБКА(--ПСТР($B4;СТОЛБЕЦ(A4);1);"")
К сообщению приложен файл: 3454966_1.xlsx(9.6 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак нужно?
Код
=ПСТР($B4;СТОЛБЕЦ(A4);1)

Если нужны числовые цифры, то
Код
=ЕСЛИОШИБКА(--ПСТР($B4;СТОЛБЕЦ(A4);1);"")

Автор - _Boroda_
Дата добавления - 12.10.2018 в 13:29
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Разделение символов (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!