Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Анализ выполнения плановых работ - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Анализ выполнения плановых работ (Формулы/Formulas)
Анализ выполнения плановых работ
ladchel1 Дата: Среда, 17.10.2018, 16:26 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 12
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Уважаемые знатоки EXCEL, помогите пожалуйста решить следующую задачу. В файле два листа. На листе "Выполненные ППР" два столбца: "Номер оборудования" и месяц в котором были выполнены плановые работы на данном оборудовании. На другом листе график выполнения плановых работ(номер оборудования и месяц). Нужно выявить, на каком оборудовании плановые работы были выполнены в соответствии с графиком, а на каком - нет. А так же выявить оборудование номера которого не значатся в графике. Очень надеюсь на вашу помощь. Своих мозгов не хватает.
К сообщению приложен файл: __--.xlsx(43.6 Kb)
 
Ответить
СообщениеУважаемые знатоки EXCEL, помогите пожалуйста решить следующую задачу. В файле два листа. На листе "Выполненные ППР" два столбца: "Номер оборудования" и месяц в котором были выполнены плановые работы на данном оборудовании. На другом листе график выполнения плановых работ(номер оборудования и месяц). Нужно выявить, на каком оборудовании плановые работы были выполнены в соответствии с графиком, а на каком - нет. А так же выявить оборудование номера которого не значатся в графике. Очень надеюсь на вашу помощь. Своих мозгов не хватает.

Автор - ladchel1
Дата добавления - 17.10.2018 в 16:26
Светлый Дата: Среда, 17.10.2018, 17:25 | Сообщение № 2
Группа: Проверенные
Ранг: Ветеран
Сообщений: 707
Репутация: 187 ±
Замечаний: 0% ±

Excel 2010
Примерно так:
Код
=СУММПРОИЗВ(--(A2&"#"&B2='График выполнения ППР'!A$2:A$2167&"#"&'График выполнения ППР'!B$2:B$2167))
Код
=СУММПРОИЗВ(--(A2='График выполнения ППР'!A$2:A$169))
Если есть совпадение, то число, иначе 0.
К сообщению приложен файл: -1.xlsx(96.2 Kb)


Программировать проще, чем писать стихи.
 
Ответить
СообщениеПримерно так:
Код
=СУММПРОИЗВ(--(A2&"#"&B2='График выполнения ППР'!A$2:A$2167&"#"&'График выполнения ППР'!B$2:B$2167))
Код
=СУММПРОИЗВ(--(A2='График выполнения ППР'!A$2:A$169))
Если есть совпадение, то число, иначе 0.

Автор - Светлый
Дата добавления - 17.10.2018 в 17:25
ladchel1 Дата: Четверг, 18.10.2018, 10:58 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 12
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Огромное спасибо Вам, выручили.
Пытаюсь понять как это работает, пока не дошло, но точно работает.
 
Ответить
СообщениеОгромное спасибо Вам, выручили.
Пытаюсь понять как это работает, пока не дошло, но точно работает.

Автор - ladchel1
Дата добавления - 18.10.2018 в 10:58
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Анализ выполнения плановых работ (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!