Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Соотвествие в ВПР искомого значения диапазону - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Соотвествие в ВПР искомого значения диапазону (Формулы/Formulas)
Соотвествие в ВПР искомого значения диапазону
meta Дата: Пятница, 19.10.2018, 09:38 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Добрый день! Подскажите пожалуйста почему в файле в приложении выпадает ошибка и как ее исправить, хотя выше точно такая же формула работает нормально. И можно ли использовать другие варианты формул, чтоб сократить возможность ошибок
К сообщению приложен файл: __.xls(66.5 Kb)
 
Ответить
СообщениеДобрый день! Подскажите пожалуйста почему в файле в приложении выпадает ошибка и как ее исправить, хотя выше точно такая же формула работает нормально. И можно ли использовать другие варианты формул, чтоб сократить возможность ошибок

Автор - meta
Дата добавления - 19.10.2018 в 09:38
Pelena Дата: Пятница, 19.10.2018, 09:46 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 13225
Репутация: 2909 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Для ВПР() с неточным поиском данные в первом столбце диапазона должны быть упорядочены по возрастанию, а у Вас - по убыванию.
Попробуйте так
Код
=ИНДЕКС($AA$5:$AA$12;ПОИСКПОЗ('план показатели'!Q3;$Z$5:$Z$12;-1))


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеДля ВПР() с неточным поиском данные в первом столбце диапазона должны быть упорядочены по возрастанию, а у Вас - по убыванию.
Попробуйте так
Код
=ИНДЕКС($AA$5:$AA$12;ПОИСКПОЗ('план показатели'!Q3;$Z$5:$Z$12;-1))

Автор - Pelena
Дата добавления - 19.10.2018 в 09:46
_Boroda_ Дата: Пятница, 19.10.2018, 10:02 | Сообщение № 3
Группа: Модераторы
Ранг: Местный житель
Сообщений: 13514
Репутация: 5529 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Дело в том, что для ВПР без четвертого аргумента значения для поиска должны быть отсортированы по возрастанию, а не по убыванию
Используйте, например, связку ИНДЕКС-ПОИСКПОЗ
И красные числа справа Вам вообще не нужны. Вот так посмотрите, формула сразу для всех значений в столбце М
Код
=ИНДЕКС(D$12:K$12;ПОИСКПОЗ('факт исполнения'!D5;D6:K6;-1^Ч(D6>E6)))
К сообщению приложен файл: -12-1.xls(69.0 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеДело в том, что для ВПР без четвертого аргумента значения для поиска должны быть отсортированы по возрастанию, а не по убыванию
Используйте, например, связку ИНДЕКС-ПОИСКПОЗ
И красные числа справа Вам вообще не нужны. Вот так посмотрите, формула сразу для всех значений в столбце М
Код
=ИНДЕКС(D$12:K$12;ПОИСКПОЗ('факт исполнения'!D5;D6:K6;-1^Ч(D6>E6)))

Автор - _Boroda_
Дата добавления - 19.10.2018 в 10:02
meta Дата: Пятница, 19.10.2018, 10:04 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Спасибо большое, что то не учла этот момент!
 
Ответить
СообщениеСпасибо большое, что то не учла этот момент!

Автор - meta
Дата добавления - 19.10.2018 в 10:04
meta Дата: Пятница, 19.10.2018, 10:07 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
_Boroda_, А это вообще шикарно!!!
 
Ответить
Сообщение_Boroda_, А это вообще шикарно!!!

Автор - meta
Дата добавления - 19.10.2018 в 10:07
meta Дата: Пятница, 19.10.2018, 13:02 | Сообщение № 6
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Еще вопросик а если искомое значение не входит в диапазон, то выдает ошибку . Как здесь быть?
 
Ответить
СообщениеЕще вопросик а если искомое значение не входит в диапазон, то выдает ошибку . Как здесь быть?

Автор - meta
Дата добавления - 19.10.2018 в 13:02
boa Дата: Пятница, 19.10.2018, 13:41 | Сообщение № 7
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 188
Репутация: 39 ±
Замечаний: 0% ±

2013, 365
meta,
Код
=IFERROR(INDEX(D$12:K$12,MATCH('факт исполнения'!D5,D6:K6,-1^N(D6>E6))),"")




Сообщение отредактировал boa - Пятница, 19.10.2018, 13:41
 
Ответить
Сообщениеmeta,
Код
=IFERROR(INDEX(D$12:K$12,MATCH('факт исполнения'!D5,D6:K6,-1^N(D6>E6))),"")

Автор - boa
Дата добавления - 19.10.2018 в 13:41
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Соотвествие в ВПР искомого значения диапазону (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!