Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Несколько условий при разных диапазонах чисел - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Несколько условий при разных диапазонах чисел (Формулы/Formulas)
Несколько условий при разных диапазонах чисел
Burlak Дата: Понедельник, 29.10.2018, 09:49 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Добрый день!

Вопрос такой.

Необходимо прописать формулу, чтобы два постоянных условия всегда оставались неизменными (или группа 1 или группа 2), а в зависимости от диапазонов чисел в определенной ячейке (если ячейка больше 0 к примеру и меньше или равна 10 в моём примере), ставилось определенное значение.

Условия постоянные - или группа 1 или группа 2
Условия переменные:

1. Если число в ячейке от 0 до 10 (включительно), то 10
2. Если число в ячейке от 10 до 20 (включительно), то 5
3. Если число в ячейке от 20 до 100 (включительно), то 2
К сообщению приложен файл: __1.xls(27.0 Kb)


Сообщение отредактировал Burlak - Понедельник, 29.10.2018, 10:12
 
Ответить
СообщениеДобрый день!

Вопрос такой.

Необходимо прописать формулу, чтобы два постоянных условия всегда оставались неизменными (или группа 1 или группа 2), а в зависимости от диапазонов чисел в определенной ячейке (если ячейка больше 0 к примеру и меньше или равна 10 в моём примере), ставилось определенное значение.

Условия постоянные - или группа 1 или группа 2
Условия переменные:

1. Если число в ячейке от 0 до 10 (включительно), то 10
2. Если число в ячейке от 10 до 20 (включительно), то 5
3. Если число в ячейке от 20 до 100 (включительно), то 2

Автор - Burlak
Дата добавления - 29.10.2018 в 09:49
sboy Дата: Понедельник, 29.10.2018, 10:26 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 2190
Репутация: 624 ±
Замечаний: 0% ±

Excel 2010
Добрый день.
Код
=ЕСЛИ(--ПРАВБ(A2)<3;ПРОСМОТР(B2;{0;10;20};{10;5;2});)

а группу не учел, добавлено
К сообщению приложен файл: _1-1-.xls(29.5 Kb)


Сообщение отредактировал sboy - Понедельник, 29.10.2018, 10:29
 
Ответить
СообщениеДобрый день.
Код
=ЕСЛИ(--ПРАВБ(A2)<3;ПРОСМОТР(B2;{0;10;20};{10;5;2});)

а группу не учел, добавлено

Автор - sboy
Дата добавления - 29.10.2018 в 10:26
_Boroda_ Дата: Понедельник, 29.10.2018, 10:28 | Сообщение № 3
Группа: Модераторы
Ранг: Местный житель
Сообщений: 13502
Репутация: 5526 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так нужно?
Код
=ЕСЛИ(--ПРАВБ(A2)<3;ВПР(B2;{0;10:10;5:20;2};2);)

Для произвольных названий
Код
=ЕСЛИ(СЧЁТ(1/(A2={"Группа 1":"Группа 2"}));ВПР(B2;{0;10:10;5:20;2};2);)
К сообщению приложен файл: _1-2-1.xls(31.0 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак нужно?
Код
=ЕСЛИ(--ПРАВБ(A2)<3;ВПР(B2;{0;10:10;5:20;2};2);)

Для произвольных названий
Код
=ЕСЛИ(СЧЁТ(1/(A2={"Группа 1":"Группа 2"}));ВПР(B2;{0;10:10;5:20;2};2);)

Автор - _Boroda_
Дата добавления - 29.10.2018 в 10:28
китин Дата: Понедельник, 29.10.2018, 10:28 | Сообщение № 4
Группа: Модераторы
Ранг: Участник клуба
Сообщений: 5103
Репутация: 809 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
1. Если число в ячейке от 0 до 10 (включительно), то 10
2. Если число в ячейке от 10 до 20 (включительно), то 5

а если ровно 10 то что выбирать? 10 или 5 ?


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщение
1. Если число в ячейке от 0 до 10 (включительно), то 10
2. Если число в ячейке от 10 до 20 (включительно), то 5

а если ровно 10 то что выбирать? 10 или 5 ?

Автор - китин
Дата добавления - 29.10.2018 в 10:28
Burlak Дата: Понедельник, 29.10.2018, 10:42 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Если ровно 10, то 10. А если больше 10 до 20 - 5.
 
Ответить
СообщениеЕсли ровно 10, то 10. А если больше 10 до 20 - 5.

Автор - Burlak
Дата добавления - 29.10.2018 в 10:42
_Boroda_ Дата: Понедельник, 29.10.2018, 11:41 | Сообщение № 6
Группа: Модераторы
Ранг: Местный житель
Сообщений: 13502
Репутация: 5526 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Вы выше формулы видели? Подходят?


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеВы выше формулы видели? Подходят?

Автор - _Boroda_
Дата добавления - 29.10.2018 в 11:41
Burlak Дата: Понедельник, 29.10.2018, 12:23 | Сообщение № 7
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Не совсем.. через если или и надо именно сделать.. сложно объяснить почему) Никто в компании не поймёт такую формулу (я в том числе), понимаю, что это моя проблема, но через если или и это желательно очень сделать, чтобы презентовать понятно это решение.. это же возможно?
 
Ответить
СообщениеНе совсем.. через если или и надо именно сделать.. сложно объяснить почему) Никто в компании не поймёт такую формулу (я в том числе), понимаю, что это моя проблема, но через если или и это желательно очень сделать, чтобы презентовать понятно это решение.. это же возможно?

Автор - Burlak
Дата добавления - 29.10.2018 в 12:23
Burlak Дата: Понедельник, 29.10.2018, 12:45 | Сообщение № 8
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
И когда цена больше 100, то ничего. Именно пустота "", а не 0.


Сообщение отредактировал Burlak - Понедельник, 29.10.2018, 12:46
 
Ответить
СообщениеИ когда цена больше 100, то ничего. Именно пустота "", а не 0.

Автор - Burlak
Дата добавления - 29.10.2018 в 12:45
_Boroda_ Дата: Понедельник, 29.10.2018, 13:02 | Сообщение № 9
Группа: Модераторы
Ранг: Местный житель
Сообщений: 13502
Репутация: 5526 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так нужно?
Код
=ЕСЛИ(ИЛИ(A2="Группа 1";A2="Группа 2");ЕСЛИ(B2<=10;10;ЕСЛИ(B2<=20;5;ЕСЛИ(B2<=100;2;"")));0)
К сообщению приложен файл: _1-2-2.xls(32.0 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак нужно?
Код
=ЕСЛИ(ИЛИ(A2="Группа 1";A2="Группа 2");ЕСЛИ(B2<=10;10;ЕСЛИ(B2<=20;5;ЕСЛИ(B2<=100;2;"")));0)

Автор - _Boroda_
Дата добавления - 29.10.2018 в 13:02
sboy Дата: Понедельник, 29.10.2018, 13:04 | Сообщение № 10
Группа: Друзья
Ранг: Старожил
Сообщений: 2190
Репутация: 624 ±
Замечаний: 0% ±

Excel 2010
Код
=ЕСЛИ(ИЛИ(A2="Группа 1";A2="Группа 2");ЕСЛИ(B2>20;2;ЕСЛИ(B2>10;5;10));"")
 
Ответить
Сообщение
Код
=ЕСЛИ(ИЛИ(A2="Группа 1";A2="Группа 2");ЕСЛИ(B2>20;2;ЕСЛИ(B2>10;5;10));"")

Автор - sboy
Дата добавления - 29.10.2018 в 13:04
Burlak Дата: Понедельник, 29.10.2018, 14:50 | Сообщение № 11
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Спасибо, я решил проблему)
 
Ответить
СообщениеСпасибо, я решил проблему)

Автор - Burlak
Дата добавления - 29.10.2018 в 14:50
_Boroda_ Дата: Понедельник, 29.10.2018, 14:53 | Сообщение № 12
Группа: Модераторы
Ранг: Местный житель
Сообщений: 13502
Репутация: 5526 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Спасибо, я решил проблему)

То есть наши решения Вам не подошли?
Поделитесь тогда своим


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщение
Спасибо, я решил проблему)

То есть наши решения Вам не подошли?
Поделитесь тогда своим

Автор - _Boroda_
Дата добавления - 29.10.2018 в 14:53
Burlak Дата: Понедельник, 29.10.2018, 16:07 | Сообщение № 13
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Цитата
То есть наши решения Вам не подошли?
Поделитесь тогда своим


Решение sBoy как моё. Почти) С помощью если.
 
Ответить
Сообщение
Цитата
То есть наши решения Вам не подошли?
Поделитесь тогда своим


Решение sBoy как моё. Почти) С помощью если.

Автор - Burlak
Дата добавления - 29.10.2018 в 16:07
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Несколько условий при разных диапазонах чисел (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!