Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Объединение название групп с ключами категории - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Объединение название групп с ключами категории (Формулы/Formulas)
Объединение название групп с ключами категории
akkord87 Дата: Вторник, 30.10.2018, 15:21 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 32
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Здравствуйте. Возможно ли в excel сделать такой пример: объяснить сложно, проще показать на примере :)
Файл с примером прикрепляю, там же и подробное объяснение.
Возможно ли такое реализовать формулами?
Буду благодарен за помощь)
К сообщению приложен файл: 9789527.xlsx(9.9 Kb)
 
Ответить
СообщениеЗдравствуйте. Возможно ли в excel сделать такой пример: объяснить сложно, проще показать на примере :)
Файл с примером прикрепляю, там же и подробное объяснение.
Возможно ли такое реализовать формулами?
Буду благодарен за помощь)

Автор - akkord87
Дата добавления - 30.10.2018 в 15:21
sboy Дата: Вторник, 30.10.2018, 15:53 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 2190
Репутация: 624 ±
Замечаний: 0% ±

Excel 2010
Добрый день.
Такое очень быстро можно сделать с помощью Power Query (бесплатная надстройка для 2010 и 2013 офиса, в 2016 уже встроенный инструмент)
К сообщению приложен файл: 1742030.xlsx(20.1 Kb)
 
Ответить
СообщениеДобрый день.
Такое очень быстро можно сделать с помощью Power Query (бесплатная надстройка для 2010 и 2013 офиса, в 2016 уже встроенный инструмент)

Автор - sboy
Дата добавления - 30.10.2018 в 15:53
akkord87 Дата: Вторник, 30.10.2018, 16:07 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 32
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
А каким образом можно это сделать?))
Стандартными формулами excel этот не реализовать?
 
Ответить
СообщениеА каким образом можно это сделать?))
Стандартными формулами excel этот не реализовать?

Автор - akkord87
Дата добавления - 30.10.2018 в 16:07
sboy Дата: Вторник, 30.10.2018, 16:19 | Сообщение № 4
Группа: Друзья
Ранг: Старожил
Сообщений: 2190
Репутация: 624 ±
Замечаний: 0% ±

Excel 2010
Да можно и стандартными.
для второго вариант совсем не сложно (с доп.столбцом)
Код
=ЕСЛИ(C5<>"";E5&":"&C5;"")
К сообщению приложен файл: 9789527-1-.xlsx(10.4 Kb)


Сообщение отредактировал sboy - Вторник, 30.10.2018, 16:45
 
Ответить
СообщениеДа можно и стандартными.
для второго вариант совсем не сложно (с доп.столбцом)
Код
=ЕСЛИ(C5<>"";E5&":"&C5;"")

Автор - sboy
Дата добавления - 30.10.2018 в 16:19
sboy Дата: Вторник, 30.10.2018, 16:45 | Сообщение № 5
Группа: Друзья
Ранг: Старожил
Сообщений: 2190
Репутация: 624 ±
Замечаний: 0% ±

Excel 2010
для 1 вот так (с тем же доп.столбцом)
формула массива
Код
=ЕСЛИОШИБКА(ИНДЕКС($E$5:$E$27&":"&$C$5:$C$27;НАИМЕНЬШИЙ(ЕСЛИ($C$5:$C$27<>"";СТРОКА($C$5:$C$27)-4);СТРОКА(A1)));"")
К сообщению приложен файл: 3301508.xlsx(10.6 Kb)
 
Ответить
Сообщениедля 1 вот так (с тем же доп.столбцом)
формула массива
Код
=ЕСЛИОШИБКА(ИНДЕКС($E$5:$E$27&":"&$C$5:$C$27;НАИМЕНЬШИЙ(ЕСЛИ($C$5:$C$27<>"";СТРОКА($C$5:$C$27)-4);СТРОКА(A1)));"")

Автор - sboy
Дата добавления - 30.10.2018 в 16:45
akkord87 Дата: Вторник, 30.10.2018, 17:01 | Сообщение № 6
Группа: Пользователи
Ранг: Новичок
Сообщений: 32
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Спасибо большое за помощь, задача решена))


Сообщение отредактировал akkord87 - Вторник, 30.10.2018, 17:01
 
Ответить
СообщениеСпасибо большое за помощь, задача решена))

Автор - akkord87
Дата добавления - 30.10.2018 в 17:01
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Объединение название групп с ключами категории (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!