Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Подсчет количества уникальных значений - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подсчет количества уникальных значений (Формулы/Formulas)
Подсчет количества уникальных значений
Янек Дата: Среда, 31.10.2018, 17:47 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 12
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Добрый день! Помогите, пожалуйста.
В первом столбце номера заказов, во втором - фамилии кладовщиков. В третьем должно отображаться количество кладовщиков для каждого заказа.
Например, если для заказа 1 всего участвовало 4 кладовщика, тов каждой строке столбца №3 должна стоять 4ка

Шото не получается ничего.... :'(
К сообщению приложен файл: 4665344.xlsx(8.5 Kb)


Сообщение отредактировал Янек - Среда, 31.10.2018, 17:54
 
Ответить
СообщениеДобрый день! Помогите, пожалуйста.
В первом столбце номера заказов, во втором - фамилии кладовщиков. В третьем должно отображаться количество кладовщиков для каждого заказа.
Например, если для заказа 1 всего участвовало 4 кладовщика, тов каждой строке столбца №3 должна стоять 4ка

Шото не получается ничего.... :'(

Автор - Янек
Дата добавления - 31.10.2018 в 17:47
_Boroda_ Дата: Среда, 31.10.2018, 18:07 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 13514
Репутация: 5529 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так нужно?
Формулы массива. Вводятся одновременным нажатием Ctrl+Shift+Enter
Код
=СУММ(ЕСЛИ(A$2:A$99=A2;1/СЧЁТЕСЛИМН(A$2:A$99;A2;B$2:B$99;B$2:B$99)))

Код
=СЧЁТ(1/(ПОИСКПОЗ(B$2:B$99&A2;B$1:B$99&A$1:A$99;)=СТРОКА(A$2:A$99)))
К сообщению приложен файл: 4665344_1.xlsx(9.7 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак нужно?
Формулы массива. Вводятся одновременным нажатием Ctrl+Shift+Enter
Код
=СУММ(ЕСЛИ(A$2:A$99=A2;1/СЧЁТЕСЛИМН(A$2:A$99;A2;B$2:B$99;B$2:B$99)))

Код
=СЧЁТ(1/(ПОИСКПОЗ(B$2:B$99&A2;B$1:B$99&A$1:A$99;)=СТРОКА(A$2:A$99)))

Автор - _Boroda_
Дата добавления - 31.10.2018 в 18:07
Янек Дата: Четверг, 01.11.2018, 11:21 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 12
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Излишнее цитирование удалено администрацией - это нарушение п.5j Правил форума

Именно то, что нужно! hands
Спасибо огромное! Крепкого Вам здоровья и хорошего дня!
 
Ответить
СообщениеИзлишнее цитирование удалено администрацией - это нарушение п.5j Правил форума

Именно то, что нужно! hands
Спасибо огромное! Крепкого Вам здоровья и хорошего дня!

Автор - Янек
Дата добавления - 01.11.2018 в 11:21
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подсчет количества уникальных значений (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!