Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Посчитать кол-во уникальных значений в заданном диапазоне - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Посчитать кол-во уникальных значений в заданном диапазоне (Формулы/Formulas)
Посчитать кол-во уникальных значений в заданном диапазоне
kuyann Дата: Воскресенье, 04.11.2018, 14:02 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 16
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Друзья, понимаю что вопрос может звучать достаточно глупо, по у меня уже котелок кипит и не варит, не могу сообразить. Может кто-то сможет подсказать?
На листе 1 исходные данные, есть список заказов, с повторяющимися номерами, даты заказов и фамилии менеджеров.
Какой формулой можно посчитать количество уникальных заказов по каждому менеджеру по каждому дню? Результат должен получится как на листе 2
К сообщению приложен файл: 3019790.xlsx(10.4 Kb)
 
Ответить
СообщениеДрузья, понимаю что вопрос может звучать достаточно глупо, по у меня уже котелок кипит и не варит, не могу сообразить. Может кто-то сможет подсказать?
На листе 1 исходные данные, есть список заказов, с повторяющимися номерами, даты заказов и фамилии менеджеров.
Какой формулой можно посчитать количество уникальных заказов по каждому менеджеру по каждому дню? Результат должен получится как на листе 2

Автор - kuyann
Дата добавления - 04.11.2018 в 14:02
ShAM Дата: Воскресенье, 04.11.2018, 15:06 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 1258
Репутация: 214 ±
Замечаний: 0% ±

Excel 2010
Так?
Код
=СУММПРОИЗВ((Лист1!$B$1:$B$36=C$1)*(Лист1!$C$1:$C$36=$B2)*(Лист1!$A$1:$A$36<>Лист1!$A$2:$A$37))

Нули убрал в параметрах.
К сообщению приложен файл: kuyann.xls(25.5 Kb)
 
Ответить
СообщениеТак?
Код
=СУММПРОИЗВ((Лист1!$B$1:$B$36=C$1)*(Лист1!$C$1:$C$36=$B2)*(Лист1!$A$1:$A$36<>Лист1!$A$2:$A$37))

Нули убрал в параметрах.

Автор - ShAM
Дата добавления - 04.11.2018 в 15:06
krosav4ig Дата: Воскресенье, 04.11.2018, 21:08 | Сообщение № 3
Группа: Друзья
Ранг: Старожил
Сообщений: 1694
Репутация: 698 ±
Замечаний: 0% ±

Excel 2007,2010,2013
на случай, если исходная таблица будет неотсортированниой, массивная формула
Код
=СУММ(ЕСЛИОШИБКА(1/СЧЁТЕСЛИМН(Лист1!$A$1:$A$36;Лист1!$A$1:$A$36;Лист1!$B$1:$B$36;C$1;Лист1!$C$1:$C$36;$B2);))
К сообщению приложен файл: 7405370.xlsx(12.1 Kb)


(_)Õvõ(_)
 
Ответить
Сообщениена случай, если исходная таблица будет неотсортированниой, массивная формула
Код
=СУММ(ЕСЛИОШИБКА(1/СЧЁТЕСЛИМН(Лист1!$A$1:$A$36;Лист1!$A$1:$A$36;Лист1!$B$1:$B$36;C$1;Лист1!$C$1:$C$36;$B2);))

Автор - krosav4ig
Дата добавления - 04.11.2018 в 21:08
kuyann Дата: Суббота, 10.11.2018, 16:33 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 16
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Большое спасибо всем!
 
Ответить
СообщениеБольшое спасибо всем!

Автор - kuyann
Дата добавления - 10.11.2018 в 16:33
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Посчитать кол-во уникальных значений в заданном диапазоне (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!