Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Необходимо подсчитать популярные числа - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Необходимо подсчитать популярные числа (Формулы/Formulas)
Необходимо подсчитать популярные числа
stalber Дата: Понедельник, 05.11.2018, 14:55 | Сообщение № 1
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 195
Репутация: 7 ±
Замечаний: 0% ±

Excel 2007
Добрый день.

Необходимо подсчитать популярные числа из диапазона и сосчитать их.
К сообщению приложен файл: zadacha_0611201.xlsx(9.2 Kb)


Сообщение отредактировал stalber - Понедельник, 05.11.2018, 15:15
 
Ответить
СообщениеДобрый день.

Необходимо подсчитать популярные числа из диапазона и сосчитать их.

Автор - stalber
Дата добавления - 05.11.2018 в 14:55
Pelena Дата: Понедельник, 05.11.2018, 14:59 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 13220
Репутация: 2908 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Название темы должно отражать суть задачи. Если не МОДА, не предлагать?


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеНазвание темы должно отражать суть задачи. Если не МОДА, не предлагать?

Автор - Pelena
Дата добавления - 05.11.2018 в 14:59
stalber Дата: Понедельник, 05.11.2018, 15:15 | Сообщение № 3
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 195
Репутация: 7 ±
Замечаний: 0% ±

Excel 2007
Название темы должно отражать суть задачи. Если не МОДА, не предлагать?

Отредактировал, подойдёт любая формула.
 
Ответить
Сообщение
Название темы должно отражать суть задачи. Если не МОДА, не предлагать?

Отредактировал, подойдёт любая формула.

Автор - stalber
Дата добавления - 05.11.2018 в 15:15
Светлый Дата: Понедельник, 05.11.2018, 23:17 | Сообщение № 4
Группа: Проверенные
Ранг: Ветеран
Сообщений: 706
Репутация: 186 ±
Замечаний: 0% ±

Excel 2010
Добрый вечер!
Массивная:
Код
=ЕСЛИОШИБКА(ИНДЕКС(Ч(СМЕЩ(H$3;ОСТАТ(СТРОКА($8:$31);8);ОТБР(СТРОКА($8:$31)/8)*8-8));ОСТАТ(НАИБОЛЬШИЙ(СТРОКА($1:$25)%%%+ЧАСТОТА((Ч(СМЕЩ(H$3;ОСТАТ(СТРОКА($8:$31);8);ОТБР(СТРОКА($8:$31)/8)*8-8))<>0)*ПОИСКПОЗ(Ч(СМЕЩ(H$3;ОСТАТ(СТРОКА($8:$31);8);ОТБР(СТРОКА($8:$31)/8)*8-8));Ч(СМЕЩ(H$3;ОСТАТ(СТРОКА($8:$31);8);ОТБР(СТРОКА($8:$31)/8)*8-8)););СТРОКА($1:$24));СТРОКА(A2));1)/1%%%);"")
Код
=СУММ(Ч(Ч(СМЕЩ(H$3;ОСТАТ(СТРОКА($8:$31);8);ОТБР(СТРОКА($8:$31)/8)*8-8))=M17))
К сообщению приложен файл: 2125986.xlsx(9.9 Kb)


Программировать проще, чем писать стихи.

Сообщение отредактировал Светлый - Понедельник, 05.11.2018, 23:18
 
Ответить
СообщениеДобрый вечер!
Массивная:
Код
=ЕСЛИОШИБКА(ИНДЕКС(Ч(СМЕЩ(H$3;ОСТАТ(СТРОКА($8:$31);8);ОТБР(СТРОКА($8:$31)/8)*8-8));ОСТАТ(НАИБОЛЬШИЙ(СТРОКА($1:$25)%%%+ЧАСТОТА((Ч(СМЕЩ(H$3;ОСТАТ(СТРОКА($8:$31);8);ОТБР(СТРОКА($8:$31)/8)*8-8))<>0)*ПОИСКПОЗ(Ч(СМЕЩ(H$3;ОСТАТ(СТРОКА($8:$31);8);ОТБР(СТРОКА($8:$31)/8)*8-8));Ч(СМЕЩ(H$3;ОСТАТ(СТРОКА($8:$31);8);ОТБР(СТРОКА($8:$31)/8)*8-8)););СТРОКА($1:$24));СТРОКА(A2));1)/1%%%);"")
Код
=СУММ(Ч(Ч(СМЕЩ(H$3;ОСТАТ(СТРОКА($8:$31);8);ОТБР(СТРОКА($8:$31)/8)*8-8))=M17))

Автор - Светлый
Дата добавления - 05.11.2018 в 23:17
stalber Дата: Понедельник, 05.11.2018, 23:28 | Сообщение № 5
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 195
Репутация: 7 ±
Замечаний: 0% ±

Excel 2007
Данные не верны почему то, при другом примере.
К сообщению приложен файл: oshibka.xlsx(9.7 Kb)
 
Ответить
СообщениеДанные не верны почему то, при другом примере.

Автор - stalber
Дата добавления - 05.11.2018 в 23:28
Светлый Дата: Вторник, 06.11.2018, 10:09 | Сообщение № 6
Группа: Проверенные
Ранг: Ветеран
Сообщений: 706
Репутация: 186 ±
Замечаний: 0% ±

Excel 2010
Из-за функции ЧАСТОТА пришлось немного расширить формулу на строку вверх:
Код
=ЕСЛИОШИБКА(ИНДЕКС(Ч(СМЕЩ(H$2;ОСТАТ(СТРОКА($9:$35);9);ОТБР(СТРОКА($9:$35)/9)*8-8));ОСТАТ(НАИБОЛЬШИЙ(СТРОКА($1:$29)%%%+ЧАСТОТА((Ч(СМЕЩ(H$2;ОСТАТ(СТРОКА($9:$35);9);ОТБР(СТРОКА($9:$35)/9)*8-8))<>0)*ПОИСКПОЗ(Ч(СМЕЩ(H$2;ОСТАТ(СТРОКА($9:$35);9);ОТБР(СТРОКА($9:$35)/9)*8-8));Ч(СМЕЩ(H$2;ОСТАТ(СТРОКА($9:$35);9);ОТБР(СТРОКА($9:$35)/9)*8-8)););СТРОКА($1:$28));СТРОКА(A2));1)/1%%%+1%);"")
Код
=СУММ(Ч(Ч(СМЕЩ(H$2;ОСТАТ(СТРОКА($9:$35);9);ОТБР(СТРОКА($9:$35)/9)*8-8))=M17))
Недостаток формулы в том, что на всём диапазоне количество нулей и пустых д.б. больше количества самого популярного.


Программировать проще, чем писать стихи.
 
Ответить
СообщениеИз-за функции ЧАСТОТА пришлось немного расширить формулу на строку вверх:
Код
=ЕСЛИОШИБКА(ИНДЕКС(Ч(СМЕЩ(H$2;ОСТАТ(СТРОКА($9:$35);9);ОТБР(СТРОКА($9:$35)/9)*8-8));ОСТАТ(НАИБОЛЬШИЙ(СТРОКА($1:$29)%%%+ЧАСТОТА((Ч(СМЕЩ(H$2;ОСТАТ(СТРОКА($9:$35);9);ОТБР(СТРОКА($9:$35)/9)*8-8))<>0)*ПОИСКПОЗ(Ч(СМЕЩ(H$2;ОСТАТ(СТРОКА($9:$35);9);ОТБР(СТРОКА($9:$35)/9)*8-8));Ч(СМЕЩ(H$2;ОСТАТ(СТРОКА($9:$35);9);ОТБР(СТРОКА($9:$35)/9)*8-8)););СТРОКА($1:$28));СТРОКА(A2));1)/1%%%+1%);"")
Код
=СУММ(Ч(Ч(СМЕЩ(H$2;ОСТАТ(СТРОКА($9:$35);9);ОТБР(СТРОКА($9:$35)/9)*8-8))=M17))
Недостаток формулы в том, что на всём диапазоне количество нулей и пустых д.б. больше количества самого популярного.

Автор - Светлый
Дата добавления - 06.11.2018 в 10:09
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Необходимо подсчитать популярные числа (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!