Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Составление формулы среднего значения с условием - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Составление формулы среднего значения с условием (Формулы/Formulas)
Составление формулы среднего значения с условием
Muhla Дата: Среда, 07.11.2018, 13:28 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Помогите, пожалуйста, составить формулу к заданию. В ячейки A1, B1 и C1 помещены три числа. Если модуль разности этих чисел меньше их произведения, то вывести их среднее арифметическое, в противном случае – корень их суммы.


Сообщение отредактировал Muhla - Среда, 07.11.2018, 13:29
 
Ответить
СообщениеПомогите, пожалуйста, составить формулу к заданию. В ячейки A1, B1 и C1 помещены три числа. Если модуль разности этих чисел меньше их произведения, то вывести их среднее арифметическое, в противном случае – корень их суммы.

Автор - Muhla
Дата добавления - 07.11.2018 в 13:28
_Boroda_ Дата: Среда, 07.11.2018, 13:35 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 13502
Репутация: 5526 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Прочитайте вот это и выберите из двух вариантов
http://www.excelworld.ru/forum/2-1593-1
И заодно уж сразу (если не читали, конечно) Правила форума http://www.excelworld.ru/forum/2-20-1


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеПрочитайте вот это и выберите из двух вариантов
http://www.excelworld.ru/forum/2-1593-1
И заодно уж сразу (если не читали, конечно) Правила форума http://www.excelworld.ru/forum/2-20-1

Автор - _Boroda_
Дата добавления - 07.11.2018 в 13:35
Muhla Дата: Среда, 07.11.2018, 13:59 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Прикрепила файл с моими действиями. Пытаюсь ввести формулу Среднее значение с условием, но выдает ошибку Деление на 0. Не понимаю, что делаю не так. И вообще правильный ли у меня ход мыслей. Хотелось бы все указать в одной формуле, а не в разных колонках, но на это у меня не хватает знаний формул, поэтому пытаюсь сделать поэтапно.
К сообщению приложен файл: ___11.xlsx(9.4 Kb)
 
Ответить
СообщениеПрикрепила файл с моими действиями. Пытаюсь ввести формулу Среднее значение с условием, но выдает ошибку Деление на 0. Не понимаю, что делаю не так. И вообще правильный ли у меня ход мыслей. Хотелось бы все указать в одной формуле, а не в разных колонках, но на это у меня не хватает знаний формул, поэтому пытаюсь сделать поэтапно.

Автор - Muhla
Дата добавления - 07.11.2018 в 13:59
_Boroda_ Дата: Среда, 07.11.2018, 14:08 | Сообщение № 4
Группа: Модераторы
Ранг: Местный житель
Сообщений: 13502
Репутация: 5526 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Разность двух чисел - это понятно. А вот как считается разность трех чисел? Ну хорошо, допустим, что а-в-с. Тогда
Код
=ЕСЛИ(ABS(A3-B3-C3)<A3*B3*C3;СРЗНАЧ(A3:C3);КОРЕНЬ(СУММ(A3:C3)))
К сообщению приложен файл: _11_1.xlsx(9.6 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеРазность двух чисел - это понятно. А вот как считается разность трех чисел? Ну хорошо, допустим, что а-в-с. Тогда
Код
=ЕСЛИ(ABS(A3-B3-C3)<A3*B3*C3;СРЗНАЧ(A3:C3);КОРЕНЬ(СУММ(A3:C3)))

Автор - _Boroda_
Дата добавления - 07.11.2018 в 14:08
sboy Дата: Среда, 07.11.2018, 14:08 | Сообщение № 5
Группа: Друзья
Ранг: Старожил
Сообщений: 2190
Репутация: 624 ±
Замечаний: 0% ±

Excel 2010
Добрый день.
Код
=ЕСЛИ(ABS(A3-B3-C3)<A3*B3*C3;СРЗНАЧ(A3:C3);КОРЕНЬ(СУММ(A3:C3)))

корень - это степень 1/2 = 0,5
Код
=ЕСЛИ(ABS(A3-B3-C3)<A3*B3*C3;СРЗНАЧ(A3:C3);СУММ(A3:C3)^0,5)

Или с функцией ПРОИЗВЕД
Код
=ЕСЛИ(ABS(A3-B3-C3)<ПРОИЗВЕД(A3:C3);СРЗНАЧ(A3:C3);КОРЕНЬ(СУММ(A3:C3)))
К сообщению приложен файл: _11.xlsx(9.5 Kb)
 
Ответить
СообщениеДобрый день.
Код
=ЕСЛИ(ABS(A3-B3-C3)<A3*B3*C3;СРЗНАЧ(A3:C3);КОРЕНЬ(СУММ(A3:C3)))

корень - это степень 1/2 = 0,5
Код
=ЕСЛИ(ABS(A3-B3-C3)<A3*B3*C3;СРЗНАЧ(A3:C3);СУММ(A3:C3)^0,5)

Или с функцией ПРОИЗВЕД
Код
=ЕСЛИ(ABS(A3-B3-C3)<ПРОИЗВЕД(A3:C3);СРЗНАЧ(A3:C3);КОРЕНЬ(СУММ(A3:C3)))

Автор - sboy
Дата добавления - 07.11.2018 в 14:08
sboy Дата: Среда, 07.11.2018, 14:11 | Сообщение № 6
Группа: Друзья
Ранг: Старожил
Сообщений: 2190
Репутация: 624 ±
Замечаний: 0% ±

Excel 2010
допустим, что а-в-с

тоже сделал такое допущение, но возможно надо по другому
Код
=ABS(ABS(A3-B3)-C3)
 
Ответить
Сообщение
допустим, что а-в-с

тоже сделал такое допущение, но возможно надо по другому
Код
=ABS(ABS(A3-B3)-C3)

Автор - sboy
Дата добавления - 07.11.2018 в 14:11
Muhla Дата: Среда, 07.11.2018, 14:15 | Сообщение № 7
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Спасибо большое за помощь!
 
Ответить
СообщениеСпасибо большое за помощь!

Автор - Muhla
Дата добавления - 07.11.2018 в 14:15
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Составление формулы среднего значения с условием (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!