Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Медиана для разных кластеров запросов. - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Медиана для разных кластеров запросов. (Формулы/Formulas)
Медиана для разных кластеров запросов.
Raiven Дата: Четверг, 08.11.2018, 09:07 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 1
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Здравствуйте! У меня есть список слов разбитый на кластеры, у каждого слова в кластере есть цифровой показатель комерческости. Мне нужно найти медиану для каждого кластера. Кластеров несколько сотен, как мне составить правильно формулу что бы эксель проходил по колонке кластеры сравнивал значения и при совпадении вычислял медиану всего кластера запросов?
К сообщению приложен файл: 1234.xls(31.0 Kb)
 
Ответить
СообщениеЗдравствуйте! У меня есть список слов разбитый на кластеры, у каждого слова в кластере есть цифровой показатель комерческости. Мне нужно найти медиану для каждого кластера. Кластеров несколько сотен, как мне составить правильно формулу что бы эксель проходил по колонке кластеры сравнивал значения и при совпадении вычислял медиану всего кластера запросов?

Автор - Raiven
Дата добавления - 08.11.2018 в 09:07
sboy Дата: Четверг, 08.11.2018, 09:14 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 2190
Репутация: 624 ±
Замечаний: 0% ±

Excel 2010
Добрый день.
Вашу формулу нужно вводить как формулу массива Ctrl+Shift+Enter
К сообщению приложен файл: 1234-2-.xls(34.5 Kb)
 
Ответить
СообщениеДобрый день.
Вашу формулу нужно вводить как формулу массива Ctrl+Shift+Enter

Автор - sboy
Дата добавления - 08.11.2018 в 09:14
_Boroda_ Дата: Четверг, 08.11.2018, 09:37 | Сообщение № 3
Группа: Модераторы
Ранг: Местный житель
Сообщений: 13502
Репутация: 5526 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Raiven,
1. Очень не советую, особенно если
Кластеров несколько сотен
, писать формулы на целиковые столбцы. Это может довольно сильно замедлить работу. Такие ссылки можно безнаказанно делать только в некоторых функциях - СЧЁТ, ИНДЕКС, СЧЁТЕСЛИ, СУММЕСЛИ (при равенстве диапазонов 1-го и 3-го аргументов), СЧЁТЕСЛИМН, СУММЕСЛИМН, ...
2. Вижу, у Вас кластеры упорядочены? Тогда формулу можно переписать немассивно вот так (она гораздо длиннее, но настолько же шустрее, чем та, что была)
Код
=ЕСЛИ(B2=B1;E1;МЕДИАНА(D2:ИНДЕКС(D2:D99;СЧЁТЕСЛИ(B:B;B2))))

Или, если для каждого кластера нужно только одно значение в первой записи, то
Код
=ЕСЛИ(B2=B1;"";МЕДИАНА(D2:ИНДЕКС(D2:D99;СЧЁТЕСЛИ(B:B;B2))))
К сообщению приложен файл: 1234_1.xls(34.0 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеRaiven,
1. Очень не советую, особенно если
Кластеров несколько сотен
, писать формулы на целиковые столбцы. Это может довольно сильно замедлить работу. Такие ссылки можно безнаказанно делать только в некоторых функциях - СЧЁТ, ИНДЕКС, СЧЁТЕСЛИ, СУММЕСЛИ (при равенстве диапазонов 1-го и 3-го аргументов), СЧЁТЕСЛИМН, СУММЕСЛИМН, ...
2. Вижу, у Вас кластеры упорядочены? Тогда формулу можно переписать немассивно вот так (она гораздо длиннее, но настолько же шустрее, чем та, что была)
Код
=ЕСЛИ(B2=B1;E1;МЕДИАНА(D2:ИНДЕКС(D2:D99;СЧЁТЕСЛИ(B:B;B2))))

Или, если для каждого кластера нужно только одно значение в первой записи, то
Код
=ЕСЛИ(B2=B1;"";МЕДИАНА(D2:ИНДЕКС(D2:D99;СЧЁТЕСЛИ(B:B;B2))))

Автор - _Boroda_
Дата добавления - 08.11.2018 в 09:37
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Медиана для разных кластеров запросов. (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!