Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Вывод данных с одной страницы на другую по названию - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Вывод данных с одной страницы на другую по названию (Формулы/Formulas)
Вывод данных с одной страницы на другую по названию
stalber Дата: Четверг, 08.11.2018, 18:46 | Сообщение № 1
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 195
Репутация: 7 ±
Замечаний: 0% ±

Excel 2007
День добрый, помогите пожалуйста.

В файле есть уже формула, нужно в ней 2 корректировки внести.

Необходимо вывести данные с одной на другую страницу, введя в ячейку название.
К сообщению приложен файл: zadacha_0808090.xlsx(25.4 Kb)
 
Ответить
СообщениеДень добрый, помогите пожалуйста.

В файле есть уже формула, нужно в ней 2 корректировки внести.

Необходимо вывести данные с одной на другую страницу, введя в ячейку название.

Автор - stalber
Дата добавления - 08.11.2018 в 18:46
_Boroda_ Дата: Четверг, 08.11.2018, 19:20 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 13514
Репутация: 5529 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так нужно?
Код
=ЕСЛИОШИБКА(ИНДЕКС(данные!$C:$GGG;;ПОИСКПОЗ($A$1;данные!$C$2:$GGG$2;0)+1)-ИНДЕКС(данные!$C:$GGG;;ПОИСКПОЗ($A$1;данные!$C$2:$GGG$2;0)+2);"")

Код
=ЕСЛИОШИБКА(ИНДЕКС(данные!2:2;ПОИСКПОЗ($A$1;данные!2:2;)+1)-ИНДЕКС(данные!2:2;ПОИСКПОЗ($A$1;данные!2:2;)+2);"")

Код
=СУММПРОИЗВ((Ч(+данные!D2:S2)-Ч(+данные!E2:T2))*($A$1=данные!C2:R2))
К сообщению приложен файл: 5760633.xlsx(27.4 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак нужно?
Код
=ЕСЛИОШИБКА(ИНДЕКС(данные!$C:$GGG;;ПОИСКПОЗ($A$1;данные!$C$2:$GGG$2;0)+1)-ИНДЕКС(данные!$C:$GGG;;ПОИСКПОЗ($A$1;данные!$C$2:$GGG$2;0)+2);"")

Код
=ЕСЛИОШИБКА(ИНДЕКС(данные!2:2;ПОИСКПОЗ($A$1;данные!2:2;)+1)-ИНДЕКС(данные!2:2;ПОИСКПОЗ($A$1;данные!2:2;)+2);"")

Код
=СУММПРОИЗВ((Ч(+данные!D2:S2)-Ч(+данные!E2:T2))*($A$1=данные!C2:R2))

Автор - _Boroda_
Дата добавления - 08.11.2018 в 19:20
stalber Дата: Четверг, 08.11.2018, 19:26 | Сообщение № 3
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 195
Репутация: 7 ±
Замечаний: 0% ±

Excel 2007
Спасибо то что нужно, я правильно понял что 2 формула она универсальней не обязательно диапазон прописывать?
Какая лучше из трёх формул? :-)


Сообщение отредактировал stalber - Четверг, 08.11.2018, 19:28
 
Ответить
СообщениеСпасибо то что нужно, я правильно понял что 2 формула она универсальней не обязательно диапазон прописывать?
Какая лучше из трёх формул? :-)

Автор - stalber
Дата добавления - 08.11.2018 в 19:26
_Boroda_ Дата: Четверг, 08.11.2018, 19:30 | Сообщение № 4
Группа: Модераторы
Ранг: Местный житель
Сообщений: 13514
Репутация: 5529 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Вторая
А ПОИСКПОЗ диапазон все-таки лучше прописать
Код
ПОИСКПОЗ($A$1;данные!A2:AAA2;)


И еще вариант
Код
=ПРОСМОТР(A$1;данные!C2:AA2;данные!D2:AB2-данные!E2:AC2)

И еще
Код
=СУММЕСЛИ(данные!C2:AA2;A$1;данные!D2:AB2)-СУММЕСЛИ(данные!C2:AA2;A$1;данные!E2:AC2)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеВторая
А ПОИСКПОЗ диапазон все-таки лучше прописать
Код
ПОИСКПОЗ($A$1;данные!A2:AAA2;)


И еще вариант
Код
=ПРОСМОТР(A$1;данные!C2:AA2;данные!D2:AB2-данные!E2:AC2)

И еще
Код
=СУММЕСЛИ(данные!C2:AA2;A$1;данные!D2:AB2)-СУММЕСЛИ(данные!C2:AA2;A$1;данные!E2:AC2)

Автор - _Boroda_
Дата добавления - 08.11.2018 в 19:30
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Вывод данных с одной страницы на другую по названию (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!