Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Суммирование диапазона значений по условиям. - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Суммирование диапазона значений по условиям. (Формулы/Formulas)
Суммирование диапазона значений по условиям.
GENEK Дата: Пятница, 16.11.2018, 16:21 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Доброго всем времени суток. В процессе выборки статистических данных из большого массива возник ступор, правильно ли выбрана формула и вообще возможно ли это выполнить?
Вообщем, имеется таблица с большим количеством данных, где ключевыми являются "принятое количество" и дата_ время. Нужна сумма принятого количества за каждые полусутки, которые начинаются с 08:00- 20:00 и 20:00-08:00.

Правильно ли использовать формулу Суммеслимн или же нужен другой способ?

Сразу скажу, в екселе не особо силен, так что прошу отнестись с пониманием.
К сообщению приложен файл: 9332729.xlsx(30.1 Kb)
 
Ответить
СообщениеДоброго всем времени суток. В процессе выборки статистических данных из большого массива возник ступор, правильно ли выбрана формула и вообще возможно ли это выполнить?
Вообщем, имеется таблица с большим количеством данных, где ключевыми являются "принятое количество" и дата_ время. Нужна сумма принятого количества за каждые полусутки, которые начинаются с 08:00- 20:00 и 20:00-08:00.

Правильно ли использовать формулу Суммеслимн или же нужен другой способ?

Сразу скажу, в екселе не особо силен, так что прошу отнестись с пониманием.

Автор - GENEK
Дата добавления - 16.11.2018 в 16:21
Michael_S Дата: Пятница, 16.11.2018, 16:29 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 1884
Репутация: 352 ±
Замечаний: 0% ±

Excel2016
Неправильно. СУММЕСЛИМН здесь не прстроить (во всяком случае без доп. столбцов).
Здесь подошла бы сводная - вам ведь кажые полусутки нужна, а не все в кучу - все что по утрам, одно, по ночам - другое.


ЯД: 41001136675053
WM: R389613894253
 
Ответить
СообщениеНеправильно. СУММЕСЛИМН здесь не прстроить (во всяком случае без доп. столбцов).
Здесь подошла бы сводная - вам ведь кажые полусутки нужна, а не все в кучу - все что по утрам, одно, по ночам - другое.

Автор - Michael_S
Дата добавления - 16.11.2018 в 16:29
_Boroda_ Дата: Пятница, 16.11.2018, 16:32 | Сообщение № 3
Группа: Модераторы
Ранг: Местный житель
Сообщений: 13698
Репутация: 5587 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
GENEK, Нарисуйте в файле несколько необходимых результатов вручную


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеGENEK, Нарисуйте в файле несколько необходимых результатов вручную

Автор - _Boroda_
Дата добавления - 16.11.2018 в 16:32
Gustav Дата: Пятница, 16.11.2018, 16:59 | Сообщение № 4
Группа: Друзья
Ранг: Старожил
Сообщений: 1630
Репутация: 664 ±
Замечаний: 0% ±

начинал с Excel 4.0...
Если правильно понял задание, то можно через СУММПРОИЗВ попробовать. У меня получилось так:
Для диапазона [08:00-20:00[ :
Код
=СУММПРОИЗВ(A2:A244;(ЧАС(B2:B244)>=8)*(ЧАС(B2:B244)<20))

Для диапазона [20:00-08:00[ :
Код
=СУММПРОИЗВ(A2:A244;ЗНАК((ЧАС(B2:B244)<8)+(ЧАС(B2:B244)>=20)))

даже, наверное, конкретно здесь вторую формулу можно и без функции ЗНАК:
Код
=СУММПРОИЗВ(A2:A244;(ЧАС(B2:B244)<8)+(ЧАС(B2:B244)>=20))


Мой tip box - яд 41001663842605

Сообщение отредактировал Gustav - Пятница, 16.11.2018, 17:21
 
Ответить
СообщениеЕсли правильно понял задание, то можно через СУММПРОИЗВ попробовать. У меня получилось так:
Для диапазона [08:00-20:00[ :
Код
=СУММПРОИЗВ(A2:A244;(ЧАС(B2:B244)>=8)*(ЧАС(B2:B244)<20))

Для диапазона [20:00-08:00[ :
Код
=СУММПРОИЗВ(A2:A244;ЗНАК((ЧАС(B2:B244)<8)+(ЧАС(B2:B244)>=20)))

даже, наверное, конкретно здесь вторую формулу можно и без функции ЗНАК:
Код
=СУММПРОИЗВ(A2:A244;(ЧАС(B2:B244)<8)+(ЧАС(B2:B244)>=20))

Автор - Gustav
Дата добавления - 16.11.2018 в 16:59
GENEK Дата: Вторник, 20.11.2018, 16:17 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
_Boroda_, нарисовал в файле приблизительный результат, который хотелось бы получать.
Подумал, что наверное проще будет считать за каждые сутки в интервале с 08:00- 08:00.
К сообщению приложен файл: 5977378.xlsx(30.3 Kb)
 
Ответить
Сообщение_Boroda_, нарисовал в файле приблизительный результат, который хотелось бы получать.
Подумал, что наверное проще будет считать за каждые сутки в интервале с 08:00- 08:00.

Автор - GENEK
Дата добавления - 20.11.2018 в 16:17
GENEK Дата: Вторник, 20.11.2018, 16:25 | Сообщение № 6
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Gustav, по формуле СУММПРОИЗВ подсчет будет итоговый, а нужен что-то типа сводного отчёта.
 
Ответить
СообщениеGustav, по формуле СУММПРОИЗВ подсчет будет итоговый, а нужен что-то типа сводного отчёта.

Автор - GENEK
Дата добавления - 20.11.2018 в 16:25
_Boroda_ Дата: Вторник, 20.11.2018, 16:37 | Сообщение № 7
Группа: Модераторы
Ранг: Местный житель
Сообщений: 13698
Репутация: 5587 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Можно допполе с формулой
Код
=ОТБР(C2-"8:")
И затем сводную таблицу

Формулой тоже можно
Даты
первая ячейка
Код
=ОТБР(C2-"8:")

Остальные
Код
=I7+1

Количество
Код
=СУММЕСЛИМН(A:A;C:C;">="&I7+"8:";C:C;"<"&I7+"32:")
К сообщению приложен файл: 5977378_1.xlsx(46.8 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеМожно допполе с формулой
Код
=ОТБР(C2-"8:")
И затем сводную таблицу

Формулой тоже можно
Даты
первая ячейка
Код
=ОТБР(C2-"8:")

Остальные
Код
=I7+1

Количество
Код
=СУММЕСЛИМН(A:A;C:C;">="&I7+"8:";C:C;"<"&I7+"32:")

Автор - _Boroda_
Дата добавления - 20.11.2018 в 16:37
sboy Дата: Вторник, 20.11.2018, 16:39 | Сообщение № 8
Группа: Друзья
Ранг: Старожил
Сообщений: 2238
Репутация: 634 ±
Замечаний: 0% ±

Excel 2010
GENEK, с 8 до 8 в примере неправильно считает...
если по Вашему примеру судить, то
Здесь подошла бы сводная

с группировкой по дням
К сообщению приложен файл: 7109087.xlsx(43.9 Kb)
 
Ответить
СообщениеGENEK, с 8 до 8 в примере неправильно считает...
если по Вашему примеру судить, то
Здесь подошла бы сводная

с группировкой по дням

Автор - sboy
Дата добавления - 20.11.2018 в 16:39
GENEK Дата: Вторник, 20.11.2018, 17:12 | Сообщение № 9
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
_Boroda_, Спасибо за помощь.
 
Ответить
Сообщение_Boroda_, Спасибо за помощь.

Автор - GENEK
Дата добавления - 20.11.2018 в 17:12
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Суммирование диапазона значений по условиям. (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!