Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Суммирование из необходимого столбца по условию - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Суммирование из необходимого столбца по условию (Формулы/Formulas)
Суммирование из необходимого столбца по условию
FDS1989 Дата: Среда, 21.11.2018, 00:07 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 11
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Доброго времени суток, уважаемые форумчане. Помогите пожалуйста с формулой.
Файл пример во вложении.
Необходимо на листе "Результат" диапазон ячеек D5:G6 заполнить суммами из данных листа "Выгрузка". Диапазон ячеек D4:G4 заполняется автоматически исходя из выпадающего списка в ячейке B2
К сообщению приложен файл: 7151915.xlsx(11.5 Kb)


Сообщение отредактировал FDS1989 - Среда, 21.11.2018, 00:08
 
Ответить
СообщениеДоброго времени суток, уважаемые форумчане. Помогите пожалуйста с формулой.
Файл пример во вложении.
Необходимо на листе "Результат" диапазон ячеек D5:G6 заполнить суммами из данных листа "Выгрузка". Диапазон ячеек D4:G4 заполняется автоматически исходя из выпадающего списка в ячейке B2

Автор - FDS1989
Дата добавления - 21.11.2018 в 00:07
_Boroda_ Дата: Среда, 21.11.2018, 00:26 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 13660
Репутация: 5574 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так нужно?
Код
=СУММПРОИЗВ(($C5=Выгрузка!$B$3:$B$22)*(D$3=Выгрузка!$A$3:$A$22)*(Выгрузка!$C$2:$F$2=D$4)*Выгрузка!$C$3:$F$22)

Код
=СУММЕСЛИМН(ИНДЕКС(Выгрузка!$C:$F;;ПОИСКПОЗ(D$4;Выгрузка!$C$2:$F$2;));Выгрузка!$A:$A;D$3;Выгрузка!$B:$B;$C5)

Вторая шустрее
К сообщению приложен файл: 7151915_1.xlsx(12.0 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак нужно?
Код
=СУММПРОИЗВ(($C5=Выгрузка!$B$3:$B$22)*(D$3=Выгрузка!$A$3:$A$22)*(Выгрузка!$C$2:$F$2=D$4)*Выгрузка!$C$3:$F$22)

Код
=СУММЕСЛИМН(ИНДЕКС(Выгрузка!$C:$F;;ПОИСКПОЗ(D$4;Выгрузка!$C$2:$F$2;));Выгрузка!$A:$A;D$3;Выгрузка!$B:$B;$C5)

Вторая шустрее

Автор - _Boroda_
Дата добавления - 21.11.2018 в 00:26
FDS1989 Дата: Среда, 21.11.2018, 07:17 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 11
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Так нужно?

Да, спасибо огромное
 
Ответить
Сообщение
Так нужно?

Да, спасибо огромное

Автор - FDS1989
Дата добавления - 21.11.2018 в 07:17
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Суммирование из необходимого столбца по условию (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!