Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Суммировать числа по диапазону времени - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Суммировать числа по диапазону времени (Формулы/Formulas)
Суммировать числа по диапазону времени
stalber Дата: Четверг, 29.11.2018, 02:38 | Сообщение № 1
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 208
Репутация: 7 ±
Замечаний: 0% ±

Excel 2007
Доброй ночи, помогите пожалуйста.

Есть колонка с временем, а рядом число. Прописываю диапазон времени и всё что входит в этот диапазон нужно суммировать.
К сообщению приложен файл: zadacha_2911201.xlsx(11.2 Kb)
 
Ответить
СообщениеДоброй ночи, помогите пожалуйста.

Есть колонка с временем, а рядом число. Прописываю диапазон времени и всё что входит в этот диапазон нужно суммировать.

Автор - stalber
Дата добавления - 29.11.2018 в 02:38
TimSha Дата: Четверг, 29.11.2018, 07:29 | Сообщение № 2
Группа: Проверенные
Ранг: Ветеран
Сообщений: 615
Репутация: 94 ±
Замечаний: 0% ±

Excel 2013 Pro +
Как вариант -
Код
=СУММЕСЛИМН($C$2:$C$51;$B$2:$B$51;">="&$I$17;$B$2:$B$51;"<"&$K$17)


"Ctrl+S" - достойное завершение ваших гениальных мыслей!.. ;)
 
Ответить
СообщениеКак вариант -
Код
=СУММЕСЛИМН($C$2:$C$51;$B$2:$B$51;">="&$I$17;$B$2:$B$51;"<"&$K$17)

Автор - TimSha
Дата добавления - 29.11.2018 в 07:29
китин Дата: Четверг, 29.11.2018, 07:31 | Сообщение № 3
Группа: Модераторы
Ранг: Участник клуба
Сообщений: 5155
Репутация: 817 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
Доброе утро!
так?
Код
=СУММПРОИЗВ($C$2:$C$100*($B$2:$B$100>=$I$12)*($B$2:$B$100<=$K$12))

[p.s.]только у в ваших расчетах в первом варианте второе время не включено в расчет, а во втором включено.
К сообщению приложен файл: stalber.xlsx(11.8 Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
СообщениеДоброе утро!
так?
Код
=СУММПРОИЗВ($C$2:$C$100*($B$2:$B$100>=$I$12)*($B$2:$B$100<=$K$12))

[p.s.]только у в ваших расчетах в первом варианте второе время не включено в расчет, а во втором включено.

Автор - китин
Дата добавления - 29.11.2018 в 07:31
_Boroda_ Дата: Четверг, 29.11.2018, 09:14 | Сообщение № 4
Группа: Модераторы
Ранг: Местный житель
Сообщений: 13698
Репутация: 5587 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Еще варианты
Код
=СУММЕСЛИ(B:B;">="&I12;C:C)-СУММЕСЛИ(B:B;">="&K12;C:C)

В файле ячейка С52 непустая, поэтому СУММПРОИЗВ вот так заработает
Код
=СУММПРОИЗВ(C2:C99;(B2:B99>=I12)*(B2:B99<=K12))
К сообщению приложен файл: 8445331.xlsx(12.0 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеЕще варианты
Код
=СУММЕСЛИ(B:B;">="&I12;C:C)-СУММЕСЛИ(B:B;">="&K12;C:C)

В файле ячейка С52 непустая, поэтому СУММПРОИЗВ вот так заработает
Код
=СУММПРОИЗВ(C2:C99;(B2:B99>=I12)*(B2:B99<=K12))

Автор - _Boroda_
Дата добавления - 29.11.2018 в 09:14
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Суммировать числа по диапазону времени (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!