Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Суммировать только числа от >-1000 до <1000 - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Суммировать только числа от >-1000 до <1000 (Формулы/Formulas)
Суммировать только числа от >-1000 до <1000
stalber Дата: Пятница, 30.11.2018, 02:59 | Сообщение № 1
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 208
Репутация: 7 ±
Замечаний: 0% ±

Excel 2007
Доброй ночи, помогите формулой пожалуйста.

В столбце даны числа, необходимо суммировать только числа которые попадают под рамки от -1000 до +1000 всё что выходит за рамки просто игнорируется.
К сообщению приложен файл: summirovatj_dia.xlsx(10.0 Kb)
 
Ответить
СообщениеДоброй ночи, помогите формулой пожалуйста.

В столбце даны числа, необходимо суммировать только числа которые попадают под рамки от -1000 до +1000 всё что выходит за рамки просто игнорируется.

Автор - stalber
Дата добавления - 30.11.2018 в 02:59
amfor Дата: Пятница, 30.11.2018, 06:56 | Сообщение № 2
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 170
Репутация: 50 ±
Замечаний: 0% ±

Excel 2016
Так?
К сообщению приложен файл: 2367137.xlsx(11.0 Kb)


Семь бед - один RESET.
 
Ответить
СообщениеТак?

Автор - amfor
Дата добавления - 30.11.2018 в 06:56
Che79 Дата: Пятница, 30.11.2018, 09:00 | Сообщение № 3
Группа: Проверенные
Ранг: Старожил
Сообщений: 1278
Репутация: 229 ±
Замечаний: 0% ±

Excel 2007, 2013
Еще вариант
Код
=СУММЕСЛИМН(C2:C34;C2:C34;">-1000";C2:C34;"<1000")


Делай нормально и будет нормально!
 
Ответить
СообщениеЕще вариант
Код
=СУММЕСЛИМН(C2:C34;C2:C34;">-1000";C2:C34;"<1000")

Автор - Che79
Дата добавления - 30.11.2018 в 09:00
_Boroda_ Дата: Пятница, 30.11.2018, 09:34 | Сообщение № 4
Группа: Модераторы
Ранг: Местный житель
Сообщений: 13698
Репутация: 5587 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
stalber, эта задача ничем не отличается от предыдущей
http://www.excelworld.ru/forum/2-39972-1
Код
=СУММЕСЛИ(C:C;">"&H7;C:C)-СУММЕСЛИ(C:C;">"&J7;C:C)

Код
=СУММПРОИЗВ(C2:C99;(C2:C99>H7)*(C2:C99<J7))

Код
=СУММЕСЛИМН(C:C;C:C;">"&H7;C:C;"<"&J7)

Немного экзотики
Код
=СУММПРОИЗВ(--ТЕКСТ(C2:C99;"[<="&H7&"]\0;[>="&J7&"]\0;0;\0"))
К сообщению приложен файл: 0485758.xlsx(10.7 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщениеstalber, эта задача ничем не отличается от предыдущей
http://www.excelworld.ru/forum/2-39972-1
Код
=СУММЕСЛИ(C:C;">"&H7;C:C)-СУММЕСЛИ(C:C;">"&J7;C:C)

Код
=СУММПРОИЗВ(C2:C99;(C2:C99>H7)*(C2:C99<J7))

Код
=СУММЕСЛИМН(C:C;C:C;">"&H7;C:C;"<"&J7)

Немного экзотики
Код
=СУММПРОИЗВ(--ТЕКСТ(C2:C99;"[<="&H7&"]\0;[>="&J7&"]\0;0;\0"))

Автор - _Boroda_
Дата добавления - 30.11.2018 в 09:34
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Суммировать только числа от >-1000 до <1000 (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!