Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Выбрать значения по текст. условию из одной таблицы в другую - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Выбрать значения по текст. условию из одной таблицы в другую (Формулы/Formulas)
Выбрать значения по текст. условию из одной таблицы в другую
RMMMM Дата: Пятница, 30.11.2018, 21:41 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 50
Репутация: 1 ±
Замечаний: 0% ±

Excel 2010
Примера нет поскольку пример простой.
На одной закладке данные:
А B
office 10
store 5
toilet 3

На второй закладке значения в столбце А типа:
ET office
material store
female toilet
toilet on second floor
male toilet

Как в столбце B получить значения по условию частичного совпадения текста? Т.е. все строчки содержащие office выдавали 10, все строчки содержащие store выдавали 5 и т.д.
VLOOKUP как то странно работает, по идее должен примерные значения определять, но какие то рандомные значения выходят

PS Файл на всякий случай приложил
К сообщению приложен файл: Book1.xlsx(11.0 Kb)


Сообщение отредактировал RMMMM - Пятница, 30.11.2018, 21:52
 
Ответить
СообщениеПримера нет поскольку пример простой.
На одной закладке данные:
А B
office 10
store 5
toilet 3

На второй закладке значения в столбце А типа:
ET office
material store
female toilet
toilet on second floor
male toilet

Как в столбце B получить значения по условию частичного совпадения текста? Т.е. все строчки содержащие office выдавали 10, все строчки содержащие store выдавали 5 и т.д.
VLOOKUP как то странно работает, по идее должен примерные значения определять, но какие то рандомные значения выходят

PS Файл на всякий случай приложил

Автор - RMMMM
Дата добавления - 30.11.2018 в 21:41
Светлый Дата: Пятница, 30.11.2018, 22:30 | Сообщение № 2
Группа: Проверенные
Ранг: Ветеран
Сообщений: 749
Репутация: 199 ±
Замечаний: 0% ±

Excel 2010
И Вам, здравствуйте!
Массивная формула (Ctrl+Shift+Enter):
Код
=ЕСЛИОШИБКА(ИНДЕКС(Sheet1!B:B;НАИМЕНЬШИЙ(ЕСЛИ(ЕЧИСЛО(ПОИСК(Sheet1!A$1:A$9;A1));СТРОКА($1:$9));1));"")


Программировать проще, чем писать стихи.

Сообщение отредактировал Светлый - Пятница, 30.11.2018, 22:32
 
Ответить
СообщениеИ Вам, здравствуйте!
Массивная формула (Ctrl+Shift+Enter):
Код
=ЕСЛИОШИБКА(ИНДЕКС(Sheet1!B:B;НАИМЕНЬШИЙ(ЕСЛИ(ЕЧИСЛО(ПОИСК(Sheet1!A$1:A$9;A1));СТРОКА($1:$9));1));"")

Автор - Светлый
Дата добавления - 30.11.2018 в 22:30
gling Дата: Пятница, 30.11.2018, 22:33 | Сообщение № 3
Группа: Друзья
Ранг: Старожил
Сообщений: 1826
Репутация: 453 ±
Замечаний: 0% ±

2010
Ещё один вариант массивной
Код
=ИНДЕКС(Sheet1!$B$1:$B$3;ПОИСКПОЗ(1;СЧЁТЕСЛИ(A1;"*"&Sheet1!$A$1:$A$3&"*");))
или скрыть ошибки так
Код
=ЕСЛИОШИБКА(ИНДЕКС(Sheet1!$B$1:$B$3;ПОИСКПОЗ(1;СЧЁТЕСЛИ(A1;"*"&Sheet1!$A$1:$A$3&"*");));"")


ЯД-41001506838083

Сообщение отредактировал gling - Пятница, 30.11.2018, 22:36
 
Ответить
СообщениеЕщё один вариант массивной
Код
=ИНДЕКС(Sheet1!$B$1:$B$3;ПОИСКПОЗ(1;СЧЁТЕСЛИ(A1;"*"&Sheet1!$A$1:$A$3&"*");))
или скрыть ошибки так
Код
=ЕСЛИОШИБКА(ИНДЕКС(Sheet1!$B$1:$B$3;ПОИСКПОЗ(1;СЧЁТЕСЛИ(A1;"*"&Sheet1!$A$1:$A$3&"*");));"")

Автор - gling
Дата добавления - 30.11.2018 в 22:33
RMMMM Дата: Пятница, 30.11.2018, 22:50 | Сообщение № 4
Группа: Пользователи
Ранг: Участник
Сообщений: 50
Репутация: 1 ±
Замечаний: 0% ±

Excel 2010
Светлый, gling, спасибо, все работает
 
Ответить
СообщениеСветлый, gling, спасибо, все работает

Автор - RMMMM
Дата добавления - 30.11.2018 в 22:50
Светлый Дата: Пятница, 30.11.2018, 23:06 | Сообщение № 5
Группа: Проверенные
Ранг: Ветеран
Сообщений: 749
Репутация: 199 ±
Замечаний: 0% ±

Excel 2010
Ещё вариант:
Код
=ЕСЛИОШИБКА(ИНДЕКС(Sheet1!B:B;ПОИСКПОЗ(0=1;ЕОШ(1/(ПОИСК(Sheet1!A$1:A$9;0&A1)-1));));"")
*Или так:
Код
=ЕСЛИОШИБКА(ИНДЕКС(Sheet1!B:B;ПОИСКПОЗ(;-ЕОШ(1/(ПОИСК(Sheet1!A$1:A$9;0&A1)-1));));"")
**Если в пределах имеющихся данных. Без устранения ошибок:
Код
=ИНДЕКС(Sheet1!B:B;ПОИСКПОЗ(;-ЕОШ(ПОИСК(Sheet1!A$1:A$3;A1));))


Программировать проще, чем писать стихи.

Сообщение отредактировал Светлый - Суббота, 01.12.2018, 00:04
 
Ответить
СообщениеЕщё вариант:
Код
=ЕСЛИОШИБКА(ИНДЕКС(Sheet1!B:B;ПОИСКПОЗ(0=1;ЕОШ(1/(ПОИСК(Sheet1!A$1:A$9;0&A1)-1));));"")
*Или так:
Код
=ЕСЛИОШИБКА(ИНДЕКС(Sheet1!B:B;ПОИСКПОЗ(;-ЕОШ(1/(ПОИСК(Sheet1!A$1:A$9;0&A1)-1));));"")
**Если в пределах имеющихся данных. Без устранения ошибок:
Код
=ИНДЕКС(Sheet1!B:B;ПОИСКПОЗ(;-ЕОШ(ПОИСК(Sheet1!A$1:A$3;A1));))

Автор - Светлый
Дата добавления - 30.11.2018 в 23:06
_Boroda_ Дата: Пятница, 30.11.2018, 23:18 | Сообщение № 6
Группа: Модераторы
Ранг: Местный житель
Сообщений: 13681
Репутация: 5580 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Еще вариант (немассивный)
Код
=ПРОСМОТР(;-ПОИСК(Sheet1!A$1:A$3;A1);Sheet1!B$1:B$3)

Для бОльшего массива
Код
=ПРОСМОТР(;-ПОИСК(Sheet1!A$1:A$9;A1)/(Sheet1!A$1:A$9<>"");Sheet1!B$1:B$9)
К сообщению приложен файл: Book1_1.xlsx(11.3 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеЕще вариант (немассивный)
Код
=ПРОСМОТР(;-ПОИСК(Sheet1!A$1:A$3;A1);Sheet1!B$1:B$3)

Для бОльшего массива
Код
=ПРОСМОТР(;-ПОИСК(Sheet1!A$1:A$9;A1)/(Sheet1!A$1:A$9<>"");Sheet1!B$1:B$9)

Автор - _Boroda_
Дата добавления - 30.11.2018 в 23:18
RMMMM Дата: Понедельник, 03.12.2018, 17:55 | Сообщение № 7
Группа: Пользователи
Ранг: Участник
Сообщений: 50
Репутация: 1 ±
Замечаний: 0% ±

Excel 2010
Оказывается вариантов много.
Светлый, _Boroda_, спасибо!
 
Ответить
СообщениеОказывается вариантов много.
Светлый, _Boroda_, спасибо!

Автор - RMMMM
Дата добавления - 03.12.2018 в 17:55
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Выбрать значения по текст. условию из одной таблицы в другую (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!