Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Поиск и подстановка текста мега формулой - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск и подстановка текста мега формулой (Формулы/Formulas)
Поиск и подстановка текста мега формулой
Alva Дата: Среда, 05.12.2018, 16:13 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Нужно фрагмент текста из книги1 найти в книге матрица и подставить в книгу1. Написания текстов отличаются, поэтому ищем только фрагмент который точно совпадает в обоих книгах.

По раздельности формулы работают и дают нужный результат.
Код
=ПСТР(B5;1;ПОИСК("х";B5;1)+3)
- выдает искомый текст
Код
=ПОИСКПОЗ(ПСТР(B5;1;ПОИСК("х";B5;1)+3);ЛЕВБ('[Матрицы Розницы и Щитовики.xlsx]Лист1'!$B$4:$B$96;ДЛСТР(X5));0)
- находит искомый текст в другой книге и возвращает положение искомого текста в другой книге
Код
=ИНДЕКС('[Матрицы Розницы и Щитовики.xlsx]Лист1'!$B$4:$B$96;57)
- подставляет значение по ссылке

А вот когда я все это дела соединяю в мега формулу, результат выдает с ошибкой. Искомый текст не совпадает с возвращаемым.

Код
=ИНДЕКС('[Матрицы Розницы и Щитовики.xlsx]Лист1'!$B$4:$B$96;ПОИСКПОЗ(ПСТР(B5;1;ПОИСК("х";B5;1)+3);ЛЕВБ('[Матрицы Розницы и Щитовики.xlsx]Лист1'!$B$4:$B$96;ДЛСТР(X5)));0)


Как поправить формулу или может альтернативу какую нить предложите?
К сообщению приложен файл: 6926645.xlsx(11.6 Kb) · ___.xlsx(10.9 Kb)


Сообщение отредактировал Alva - Среда, 05.12.2018, 16:40
 
Ответить
СообщениеНужно фрагмент текста из книги1 найти в книге матрица и подставить в книгу1. Написания текстов отличаются, поэтому ищем только фрагмент который точно совпадает в обоих книгах.

По раздельности формулы работают и дают нужный результат.
Код
=ПСТР(B5;1;ПОИСК("х";B5;1)+3)
- выдает искомый текст
Код
=ПОИСКПОЗ(ПСТР(B5;1;ПОИСК("х";B5;1)+3);ЛЕВБ('[Матрицы Розницы и Щитовики.xlsx]Лист1'!$B$4:$B$96;ДЛСТР(X5));0)
- находит искомый текст в другой книге и возвращает положение искомого текста в другой книге
Код
=ИНДЕКС('[Матрицы Розницы и Щитовики.xlsx]Лист1'!$B$4:$B$96;57)
- подставляет значение по ссылке

А вот когда я все это дела соединяю в мега формулу, результат выдает с ошибкой. Искомый текст не совпадает с возвращаемым.

Код
=ИНДЕКС('[Матрицы Розницы и Щитовики.xlsx]Лист1'!$B$4:$B$96;ПОИСКПОЗ(ПСТР(B5;1;ПОИСК("х";B5;1)+3);ЛЕВБ('[Матрицы Розницы и Щитовики.xlsx]Лист1'!$B$4:$B$96;ДЛСТР(X5)));0)


Как поправить формулу или может альтернативу какую нить предложите?

Автор - Alva
Дата добавления - 05.12.2018 в 16:13
Pelena Дата: Среда, 05.12.2018, 18:49 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 13311
Репутация: 2931 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Со скобками немного напутали
Код
=ИНДЕКС('[Матрицы Розницы и Щитовики.xlsx]Лист1'!$B$4:$B$96;ПОИСКПОЗ(ПСТР(B5;1;ПОИСК("х";B5;1)+3);ЛЕВБ('[Матрицы Розницы и Щитовики.xlsx]Лист1'!$B$4:$B$96;ДЛСТР(X5));0))


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеСо скобками немного напутали
Код
=ИНДЕКС('[Матрицы Розницы и Щитовики.xlsx]Лист1'!$B$4:$B$96;ПОИСКПОЗ(ПСТР(B5;1;ПОИСК("х";B5;1)+3);ЛЕВБ('[Матрицы Розницы и Щитовики.xlsx]Лист1'!$B$4:$B$96;ДЛСТР(X5));0))

Автор - Pelena
Дата добавления - 05.12.2018 в 18:49
_Boroda_ Дата: Среда, 05.12.2018, 19:28 | Сообщение № 3
Группа: Модераторы
Ранг: Местный житель
Сообщений: 13698
Репутация: 5587 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Можно чуть упростить и без массивного ввода написать
Код
=ИНДЕКС('[Матрицы Розницы и Щитовики.xlsx]Лист1'!$B$4:$B$96;ПОИСКПОЗ(ПСТР(B5;1;ПОИСК("х";B5;1)+3)&"*";'[Матрицы Розницы и Щитовики.xlsx]Лист1'!$B$4:$B$96;))
К сообщению приложен файл: 6926645_1.xlsx(14.1 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеМожно чуть упростить и без массивного ввода написать
Код
=ИНДЕКС('[Матрицы Розницы и Щитовики.xlsx]Лист1'!$B$4:$B$96;ПОИСКПОЗ(ПСТР(B5;1;ПОИСК("х";B5;1)+3)&"*";'[Матрицы Розницы и Щитовики.xlsx]Лист1'!$B$4:$B$96;))

Автор - _Boroda_
Дата добавления - 05.12.2018 в 19:28
Alva Дата: Четверг, 06.12.2018, 10:46 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
=ИНДЕКС('[Матрицы Розницы и Щитовики.xlsx]Лист1'!$B$4:$B$96;ПОИСКПОЗ(ПСТР(B5;1;ПОИСК("х";B5;1)+3)&"*";'[Матрицы Розницы и Щитовики.xlsx]Лист1'!$B$4:$B$96;))


Сути дела это не меняет - формула не работает и при правильной расстановке скобок. Спасибо
 
Ответить
Сообщение
=ИНДЕКС('[Матрицы Розницы и Щитовики.xlsx]Лист1'!$B$4:$B$96;ПОИСКПОЗ(ПСТР(B5;1;ПОИСК("х";B5;1)+3)&"*";'[Матрицы Розницы и Щитовики.xlsx]Лист1'!$B$4:$B$96;))


Сути дела это не меняет - формула не работает и при правильной расстановке скобок. Спасибо

Автор - Alva
Дата добавления - 06.12.2018 в 10:46
Pelena Дата: Четверг, 06.12.2018, 10:55 | Сообщение № 5
Группа: Админы
Ранг: Местный житель
Сообщений: 13311
Репутация: 2931 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Alva, приложите пример, в котором исправленная формула "не работает"


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеAlva, приложите пример, в котором исправленная формула "не работает"

Автор - Pelena
Дата добавления - 06.12.2018 в 10:55
Alva Дата: Четверг, 06.12.2018, 11:07 | Сообщение № 6
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Можно чуть упростить и без массивного ввода написать
[Перевод / Translate]
=ИНДЕКС('[Матрицы Розницы и Щитовики.xlsx]Лист1'!$B$4:$B$96;ПОИСКПОЗ(ПСТР(B5;1;ПОИСК("х";B5;1)+3)&"*";'[Матрицы Розницы и Щитовики.xlsx]Лист1'!$B$4:$B$96;))

Спасибо. Ваш вариант хорош.
 
Ответить
Сообщение
Можно чуть упростить и без массивного ввода написать
[Перевод / Translate]
=ИНДЕКС('[Матрицы Розницы и Щитовики.xlsx]Лист1'!$B$4:$B$96;ПОИСКПОЗ(ПСТР(B5;1;ПОИСК("х";B5;1)+3)&"*";'[Матрицы Розницы и Щитовики.xlsx]Лист1'!$B$4:$B$96;))

Спасибо. Ваш вариант хорош.

Автор - Alva
Дата добавления - 06.12.2018 в 11:07
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск и подстановка текста мега формулой (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!