Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Сбор данных из разных таблиц - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сбор данных из разных таблиц (Формулы/Formulas)
Сбор данных из разных таблиц
Igor200395 Дата: Понедельник, 10.12.2018, 08:52 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Добрый день. Подскажите мне пожалуйста, как мне решить мою проблему. Я работаю прорабом,
в конце каждого месяца необходимо получить данные с количеством использованного материала.
Я создал таблицу состоящую из 34 пунктов. И расчёт к этой таблице. Одна такая таблица содержит информацию о одной конструкции.
Те материалы которые были затрачены на её изготовление.
Объект который я рассчитываю, жилой дом длинной 100 м. Поэтому стен там очень много. И к каждой стене будет сделана такая таблица.
В общем итоге количество таблиц может дойти до 150-200. Номер таблицы соответствует номеру моей конструкции(стене).
Эти таблицы находятся в одном файле друг под другом. Все материалы в таблице одинаковые, только значения раз.
В начале файла создал аналогичную ОБЩУЮ таблицу с пустыми клетками и рядом создал таблицу №участка(стена). Возможно ли сделать так чтобы поставив в таблице с номерами участков допустим "+" , получить в общей таблице сумму значений необходимых мне участков(стен)?
И как сделать чтобы над таблицей были прописаны участки которые я выбрал, чтобы я мог доказать начальнику, что взял только требуемый объём.
Приложил файл, с пометками.
К сообщению приложен файл: 3633872.xlsx(81.5 Kb)
 
Ответить
СообщениеДобрый день. Подскажите мне пожалуйста, как мне решить мою проблему. Я работаю прорабом,
в конце каждого месяца необходимо получить данные с количеством использованного материала.
Я создал таблицу состоящую из 34 пунктов. И расчёт к этой таблице. Одна такая таблица содержит информацию о одной конструкции.
Те материалы которые были затрачены на её изготовление.
Объект который я рассчитываю, жилой дом длинной 100 м. Поэтому стен там очень много. И к каждой стене будет сделана такая таблица.
В общем итоге количество таблиц может дойти до 150-200. Номер таблицы соответствует номеру моей конструкции(стене).
Эти таблицы находятся в одном файле друг под другом. Все материалы в таблице одинаковые, только значения раз.
В начале файла создал аналогичную ОБЩУЮ таблицу с пустыми клетками и рядом создал таблицу №участка(стена). Возможно ли сделать так чтобы поставив в таблице с номерами участков допустим "+" , получить в общей таблице сумму значений необходимых мне участков(стен)?
И как сделать чтобы над таблицей были прописаны участки которые я выбрал, чтобы я мог доказать начальнику, что взял только требуемый объём.
Приложил файл, с пометками.

Автор - Igor200395
Дата добавления - 10.12.2018 в 08:52
Светлый Дата: Понедельник, 10.12.2018, 10:00 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 1202
Репутация: 309 ±
Замечаний: 0% ±

Excel 2010
Добрый день!
Можно список участков создать через запятую, а + расставятся автоматически. И для упрощения формул лучше писать номер участка не в одной строке, а во всех строках для данного участка. Устроят такие дополнения?


Программировать проще, чем писать стихи.
 
Ответить
СообщениеДобрый день!
Можно список участков создать через запятую, а + расставятся автоматически. И для упрощения формул лучше писать номер участка не в одной строке, а во всех строках для данного участка. Устроят такие дополнения?

Автор - Светлый
Дата добавления - 10.12.2018 в 10:00
sboy Дата: Понедельник, 10.12.2018, 10:04 | Сообщение № 3
Группа: Друзья
Ранг: Участник клуба
Сообщений: 2566
Репутация: 722 ±
Замечаний: 0% ±

Excel 2010
Цитата Светлый, 10.12.2018 в 10:00, в сообщении № 2 ()
лучше писать номер участка не в одной строке, а во всех строках для данного участка

и строить сводную (в фильтре выбираете нужные участки) см. на Листе 2
К сообщению приложен файл: 8068747.xlsx(94.5 Kb)


Яндекс: 410016850021169
 
Ответить
Сообщение
Цитата Светлый, 10.12.2018 в 10:00, в сообщении № 2 ()
лучше писать номер участка не в одной строке, а во всех строках для данного участка

и строить сводную (в фильтре выбираете нужные участки) см. на Листе 2

Автор - sboy
Дата добавления - 10.12.2018 в 10:04
Igor200395 Дата: Понедельник, 10.12.2018, 11:10 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Спасибо! Оба варианта подходят.
По первому варианту, Светлый. Через запятую номера участков было бы отлично, тогда + в таблице мне вообще не нужны.
Второй вариант-sboy, тоже подходит. Единственное не могли бы вы объяснить как добавлять в таблицу ещё участки, чтобы они отображались в сводной таблице на листе 2.
 
Ответить
СообщениеСпасибо! Оба варианта подходят.
По первому варианту, Светлый. Через запятую номера участков было бы отлично, тогда + в таблице мне вообще не нужны.
Второй вариант-sboy, тоже подходит. Единственное не могли бы вы объяснить как добавлять в таблицу ещё участки, чтобы они отображались в сводной таблице на листе 2.

Автор - Igor200395
Дата добавления - 10.12.2018 в 11:10
sboy Дата: Понедельник, 10.12.2018, 11:15 | Сообщение № 5
Группа: Друзья
Ранг: Участник клуба
Сообщений: 2566
Репутация: 722 ±
Замечаний: 0% ±

Excel 2010
как добавлять в таблицу ещё участки

при выделении ячейки в любом поле сводной таблицы, появляются доп. вкладки для сводных таблиц. Выбираете Параметры - Источник Данных и можно изменять диапазон

К сообщению приложен файл: 0768317.jpg(28.2 Kb) · 4426412.jpg(40.2 Kb)


Яндекс: 410016850021169
 
Ответить
Сообщение
как добавлять в таблицу ещё участки

при выделении ячейки в любом поле сводной таблицы, появляются доп. вкладки для сводных таблиц. Выбираете Параметры - Источник Данных и можно изменять диапазон


Автор - sboy
Дата добавления - 10.12.2018 в 11:15
Igor200395 Дата: Понедельник, 10.12.2018, 11:26 | Сообщение № 6
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Огромное вам СПАСИБО!!!! Всё работает!!!
Если что-то будет непонятно можно ли ещё обратиться за помощью?
 
Ответить
СообщениеОгромное вам СПАСИБО!!!! Всё работает!!!
Если что-то будет непонятно можно ли ещё обратиться за помощью?

Автор - Igor200395
Дата добавления - 10.12.2018 в 11:26
sboy Дата: Понедельник, 10.12.2018, 11:36 | Сообщение № 7
Группа: Друзья
Ранг: Участник клуба
Сообщений: 2566
Репутация: 722 ±
Замечаний: 0% ±

Excel 2010
Если что-то будет непонятно

Так форум для этого и создан :)


Яндекс: 410016850021169
 
Ответить
Сообщение
Если что-то будет непонятно

Так форум для этого и создан :)

Автор - sboy
Дата добавления - 10.12.2018 в 11:36
Светлый Дата: Понедельник, 10.12.2018, 13:43 | Сообщение № 8
Группа: Друзья
Ранг: Старожил
Сообщений: 1202
Репутация: 309 ±
Замечаний: 0% ±

Excel 2010
И вариант изначального задания. Массивная формула:
Код
=СУММ(ЕСЛИОШИБКА((C$57:C$900=C8)*(--ПСТР(ПОДСТАВИТЬ(B$5;",";ПОВТОР(" ";99));СТОЛБЕЦ(A:GR)*99-98;99)=A$57:A$900)*D$57:D$900;))
*Или так:
Код
=СУММ(ЕСЛИОШИБКА(Ч(СМЕЩ(D11;ПСТР(ПОДСТАВИТЬ(B$5;",";ПОВТОР(" ";99));СТОЛБЕЦ(A:GR)*99-98;99)*46;));))
**Ещё вариант:
Код
=СУММ(ЕСЛИОШИБКА(Ч(СМЕЩ(D11;(ПОИСК(","&СТОЛБЕЦ(A:GR)&",";","&B$5&",")>0)*СТОЛБЕЦ(A:GR)*46;));))
К сообщению приложен файл: 3633872-3.xlsx(83.6 Kb)


Программировать проще, чем писать стихи.

Сообщение отредактировал Светлый - Понедельник, 10.12.2018, 14:37
 
Ответить
СообщениеИ вариант изначального задания. Массивная формула:
Код
=СУММ(ЕСЛИОШИБКА((C$57:C$900=C8)*(--ПСТР(ПОДСТАВИТЬ(B$5;",";ПОВТОР(" ";99));СТОЛБЕЦ(A:GR)*99-98;99)=A$57:A$900)*D$57:D$900;))
*Или так:
Код
=СУММ(ЕСЛИОШИБКА(Ч(СМЕЩ(D11;ПСТР(ПОДСТАВИТЬ(B$5;",";ПОВТОР(" ";99));СТОЛБЕЦ(A:GR)*99-98;99)*46;));))
**Ещё вариант:
Код
=СУММ(ЕСЛИОШИБКА(Ч(СМЕЩ(D11;(ПОИСК(","&СТОЛБЕЦ(A:GR)&",";","&B$5&",")>0)*СТОЛБЕЦ(A:GR)*46;));))

Автор - Светлый
Дата добавления - 10.12.2018 в 13:43
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сбор данных из разных таблиц (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!