Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/удалить повторяющиеся значения из строки - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » удалить повторяющиеся значения из строки (Формулы/Formulas)
удалить повторяющиеся значения из строки
АЛЕКСАНДР1986 Дата: Вторник, 11.12.2018, 18:30 | Сообщение № 1
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 154
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Всем добрый вечер!
Не подскажите что не правильно пишу в массивной формуле почему то она не удаляет повторяющиеся значения в строке
Код
=еслиошибка(индекс($AI8:$AV8;;поискпоз(;счётесли($AH8:AH8;$AI8:$AV8);0));0)


Сообщение отредактировал АЛЕКСАНДР1986 - Вторник, 11.12.2018, 18:31
 
Ответить
СообщениеВсем добрый вечер!
Не подскажите что не правильно пишу в массивной формуле почему то она не удаляет повторяющиеся значения в строке
Код
=еслиошибка(индекс($AI8:$AV8;;поискпоз(;счётесли($AH8:AH8;$AI8:$AV8);0));0)

Автор - АЛЕКСАНДР1986
Дата добавления - 11.12.2018 в 18:30
Nic70y Дата: Вторник, 11.12.2018, 19:44 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 5188
Репутация: 1125 ±
Замечаний: 0% ±

Excel 2013
без файла не понятно, похоже с $ что-то не то.


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
Сообщениебез файла не понятно, похоже с $ что-то не то.

Автор - Nic70y
Дата добавления - 11.12.2018 в 19:44
_Boroda_ Дата: Вторник, 11.12.2018, 20:11 | Сообщение № 3
Группа: Модераторы
Ранг: Местный житель
Сообщений: 14501
Репутация: 5789 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Возможно, так? Для ввода в АI9 и протягивания вправо
Код
=ЕСЛИОШИБКА(ИНДЕКС($AI8:$AV8;ПОИСКПОЗ(;СЧЁТЕСЛИ($AH9:AH9;$AI8:$AV8);));)

Формула массива, вводится одновременным нажатием Контрл Шифт Ентер
А вообще да,
без файла не понятно


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеВозможно, так? Для ввода в АI9 и протягивания вправо
Код
=ЕСЛИОШИБКА(ИНДЕКС($AI8:$AV8;ПОИСКПОЗ(;СЧЁТЕСЛИ($AH9:AH9;$AI8:$AV8);));)

Формула массива, вводится одновременным нажатием Контрл Шифт Ентер
А вообще да,
без файла не понятно

Автор - _Boroda_
Дата добавления - 11.12.2018 в 20:11
jakim Дата: Вторник, 11.12.2018, 20:22 | Сообщение № 4
Группа: Друзья
Ранг: Ветеран
Сообщений: 885
Репутация: 231 ±
Замечаний: 0% ±

Excel 2010
Смотрите приложение с тремя вариантами формул

Код
=IFERROR(INDEX($A1:$G1;MATCH(TRUE;INDEX((COUNTIF($H1:H1;$A1:$G1)=0);0);0));"")

Код
=IFERROR(INDEX($A8:$G8;MATCH(0;INDEX(COUNTIF($H$8:H8;$A8:$G8);0);0));"")

Код
=IFERROR(AGGREGATE(14;6;$C14:$G14/(COUNTIF($P14:P14;$C14:$G14)=0)/($C14:$G14<>"");1);"")
К сообщению приложен файл: Knyga12.xlsx(10.8 Kb)
 
Ответить
Сообщение
Смотрите приложение с тремя вариантами формул

Код
=IFERROR(INDEX($A1:$G1;MATCH(TRUE;INDEX((COUNTIF($H1:H1;$A1:$G1)=0);0);0));"")

Код
=IFERROR(INDEX($A8:$G8;MATCH(0;INDEX(COUNTIF($H$8:H8;$A8:$G8);0);0));"")

Код
=IFERROR(AGGREGATE(14;6;$C14:$G14/(COUNTIF($P14:P14;$C14:$G14)=0)/($C14:$G14<>"");1);"")

Автор - jakim
Дата добавления - 11.12.2018 в 20:22
Мир MS Excel » Вопросы и решения » Вопросы по Excel » удалить повторяющиеся значения из строки (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!