Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Подсчет значений с привязкой к выпадающему списку - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подсчет значений с привязкой к выпадающему списку (Формулы/Formulas)
Подсчет значений с привязкой к выпадающему списку
2019ella Дата: Среда, 19.12.2018, 09:48 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Уважаемы знатоки, прошу подсказать как задать формулы подсчета по критериям, с привязкой к выпадающему списку манагеров? Файлик приложила.
К сообщению приложен файл: 7391224.xlsx(14.5 Kb)
 
Ответить
СообщениеУважаемы знатоки, прошу подсказать как задать формулы подсчета по критериям, с привязкой к выпадающему списку манагеров? Файлик приложила.

Автор - 2019ella
Дата добавления - 19.12.2018 в 09:48
_Boroda_ Дата: Среда, 19.12.2018, 10:25 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 14517
Репутация: 5791 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так нужно?
Пара вариантов, оба формулы массива, вводятся одновременным нажатием Контрл Шифт Ентер
Код
=СУММ(ЕСЛИ(($B2:$B99=N2)*ЕСЛИ(Ответственный="Все";1;Ответственный=$J2:$J99);1/СЧЁТЕСЛИМН($B:$B;N2;$J:$J;ЕСЛИ(Ответственный="Все";"*";Ответственный);$A:$A;$A2:$A99)))

Код
=СЧЁТ(1/(ПОИСКПОЗ($C2:$C99&N2&ЕСЛИ(Ответственный="Все";"*";Ответственный);$C2:$C99&$B2:$B99&$J2:$J99;)=СТРОКА(A1:A98)))
К сообщению приложен файл: 7391224_1.xlsx(14.1 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак нужно?
Пара вариантов, оба формулы массива, вводятся одновременным нажатием Контрл Шифт Ентер
Код
=СУММ(ЕСЛИ(($B2:$B99=N2)*ЕСЛИ(Ответственный="Все";1;Ответственный=$J2:$J99);1/СЧЁТЕСЛИМН($B:$B;N2;$J:$J;ЕСЛИ(Ответственный="Все";"*";Ответственный);$A:$A;$A2:$A99)))

Код
=СЧЁТ(1/(ПОИСКПОЗ($C2:$C99&N2&ЕСЛИ(Ответственный="Все";"*";Ответственный);$C2:$C99&$B2:$B99&$J2:$J99;)=СТРОКА(A1:A98)))

Автор - _Boroda_
Дата добавления - 19.12.2018 в 10:25
2019ella Дата: Среда, 19.12.2018, 10:38 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Так нужно?

Спасибо за ваше участие, почему то не подсчитывает метрику Уникальных клиентов и сумму реал
 
Ответить
Сообщение
Так нужно?

Спасибо за ваше участие, почему то не подсчитывает метрику Уникальных клиентов и сумму реал

Автор - 2019ella
Дата добавления - 19.12.2018 в 10:38
_Boroda_ Дата: Среда, 19.12.2018, 10:42 | Сообщение № 4
Группа: Модераторы
Ранг: Местный житель
Сообщений: 14517
Репутация: 5791 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Наверное потому, что там я формулы не писал. Я полагал, что Вы это сделаете самостоятельно по приведенному примеру
Держите
К сообщению приложен файл: 7391224_2.xlsx(14.1 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеНаверное потому, что там я формулы не писал. Я полагал, что Вы это сделаете самостоятельно по приведенному примеру
Держите

Автор - _Boroda_
Дата добавления - 19.12.2018 в 10:42
2019ella Дата: Среда, 19.12.2018, 10:45 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Держите

Спасибо большое
 
Ответить
Сообщение
Держите

Спасибо большое

Автор - 2019ella
Дата добавления - 19.12.2018 в 10:45
2019ella Дата: Среда, 19.12.2018, 11:03 | Сообщение № 6
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Пара вариантов

а как добавить еще критерий кроме Манагера ( в виде списка) чтобы учитывал и манагера и проект?
К сообщению приложен файл: 2_.xlsx(15.9 Kb)
 
Ответить
Сообщение
Пара вариантов

а как добавить еще критерий кроме Манагера ( в виде списка) чтобы учитывал и манагера и проект?

Автор - 2019ella
Дата добавления - 19.12.2018 в 11:03
_Boroda_ Дата: Среда, 19.12.2018, 12:10 | Сообщение № 7
Группа: Модераторы
Ранг: Местный житель
Сообщений: 14517
Репутация: 5791 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Все также
Только суммировать эти значения за все месяцы нельзя. Итоговое кол-во уникальных тоже нужно формулой считать (розовым покрасил)
К сообщению приложен файл: 2_1.xlsx(15.4 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеВсе также
Только суммировать эти значения за все месяцы нельзя. Итоговое кол-во уникальных тоже нужно формулой считать (розовым покрасил)

Автор - _Boroda_
Дата добавления - 19.12.2018 в 12:10
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подсчет значений с привязкой к выпадающему списку (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!