Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Суммирование структурных данных - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Суммирование структурных данных (Формулы/Formulas)
Суммирование структурных данных
mikeret Дата: Четверг, 27.12.2018, 11:00 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 31
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Здраствуйте, в приведенном примере есть четкая структура исходных данных. В разделы входят группы, в группы - подгруппы, в подгрупах - непосредственно позиции, по которым имеются данные: цена (не меняется) и количества по периодам.
Помогите написать формулу для подсчета итоговых сумм (цена*количество) для каждых разделов, групп и подгрупп.
К сообщению приложен файл: 7542516.xlsx(11.4 Kb)
 
Ответить
СообщениеЗдраствуйте, в приведенном примере есть четкая структура исходных данных. В разделы входят группы, в группы - подгруппы, в подгрупах - непосредственно позиции, по которым имеются данные: цена (не меняется) и количества по периодам.
Помогите написать формулу для подсчета итоговых сумм (цена*количество) для каждых разделов, групп и подгрупп.

Автор - mikeret
Дата добавления - 27.12.2018 в 11:00
_Boroda_ Дата: Четверг, 27.12.2018, 11:15 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 14864
Репутация: 5881 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так нужно?
Код
=СУММ($E$3:$E$35*F$3:F$35*($B$3:$B$35=$J3)*ЕСЛИ(K3;$C$3:$C$35=$K3;1)*ЕСЛИ(L3;$D$3:$D$35=$L3;1))

Формула массива. Вводится одновременным нажатием Ctrl+Shift+Enter

Исправление, доллары забыл
Код
=СУММ($E$3:$E$35*F$3:F$35*($B$3:$B$35=$J3)*ЕСЛИ($K3;$C$3:$C$35=$K3;1)*ЕСЛИ($L3;$D$3:$D$35=$L3;1))

Файл перевложил
К сообщению приложен файл: 7542516_2.xlsx(11.9 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак нужно?
Код
=СУММ($E$3:$E$35*F$3:F$35*($B$3:$B$35=$J3)*ЕСЛИ(K3;$C$3:$C$35=$K3;1)*ЕСЛИ(L3;$D$3:$D$35=$L3;1))

Формула массива. Вводится одновременным нажатием Ctrl+Shift+Enter

Исправление, доллары забыл
Код
=СУММ($E$3:$E$35*F$3:F$35*($B$3:$B$35=$J3)*ЕСЛИ($K3;$C$3:$C$35=$K3;1)*ЕСЛИ($L3;$D$3:$D$35=$L3;1))

Файл перевложил

Автор - _Boroda_
Дата добавления - 27.12.2018 в 11:15
mikeret Дата: Четверг, 27.12.2018, 11:26 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 31
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
_Boroda_, спасибо, за январь правильно посчитало, но февраль почему-то нет. Подправьте пожалуйста, мне тяжело в этой формуле разобраться
 
Ответить
Сообщение_Boroda_, спасибо, за январь правильно посчитало, но февраль почему-то нет. Подправьте пожалуйста, мне тяжело в этой формуле разобраться

Автор - mikeret
Дата добавления - 27.12.2018 в 11:26
mikeret Дата: Четверг, 27.12.2018, 11:31 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 31
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Отлично,то что нужно, спасибо за помощь
 
Ответить
СообщениеОтлично,то что нужно, спасибо за помощь

Автор - mikeret
Дата добавления - 27.12.2018 в 11:31
_Boroda_ Дата: Четверг, 27.12.2018, 11:40 | Сообщение № 5
Группа: Модераторы
Ранг: Местный житель
Сообщений: 14864
Репутация: 5881 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Или вот попроще, немассивная
Код
=ЕСЛИ($L3;СУММПРОИЗВ($E$3:$E$35*F$3:F$35*($B$3:$B$35=$J3)*($C$3:$C$35=$K3)*($D$3:$D$35=$L3));СУММЕСЛИ($I4:$I35;"* "&ЛЕВБ($I3;ПОИСК(". ";$I3)-1)&"*";P4:P35)/2^($K3=""))
К сообщению приложен файл: 7542516_3.xlsx(13.0 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеИли вот попроще, немассивная
Код
=ЕСЛИ($L3;СУММПРОИЗВ($E$3:$E$35*F$3:F$35*($B$3:$B$35=$J3)*($C$3:$C$35=$K3)*($D$3:$D$35=$L3));СУММЕСЛИ($I4:$I35;"* "&ЛЕВБ($I3;ПОИСК(". ";$I3)-1)&"*";P4:P35)/2^($K3=""))

Автор - _Boroda_
Дата добавления - 27.12.2018 в 11:40
mikeret Дата: Четверг, 27.12.2018, 11:47 | Сообщение № 6
Группа: Пользователи
Ранг: Новичок
Сообщений: 31
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
_Boroda_, ну как попороще :), в формуле массива хоть что-то понять можно, а тут вообще космос. Или она быстрее будет считать, если огромная таблица?
 
Ответить
Сообщение_Boroda_, ну как попороще :), в формуле массива хоть что-то понять можно, а тут вообще космос. Или она быстрее будет считать, если огромная таблица?

Автор - mikeret
Дата добавления - 27.12.2018 в 11:47
_Boroda_ Дата: Четверг, 27.12.2018, 12:00 | Сообщение № 7
Группа: Модераторы
Ранг: Местный житель
Сообщений: 14864
Репутация: 5881 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
По идее да, должна побыстрее работать


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеПо идее да, должна побыстрее работать

Автор - _Boroda_
Дата добавления - 27.12.2018 в 12:00
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Суммирование структурных данных (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!