Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Формула с учетом незаполненных ячеек - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Формула с учетом незаполненных ячеек (Формулы/Formulas)
Формула с учетом незаполненных ячеек
kotena Дата: Пятница, 28.12.2018, 00:58 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 28
Репутация: 2 ±
Замечаний: 0% ±

Excel 2016
Добрый вечер.

Можно ли "усовершенствовать" формулы в столбиках F и G так, чтобы учитывалось, что есть не заполненные ячейки в столбиках C и D соответственно? (файл прилагаю)

Спасибо :unsure:
К сообщению приложен файл: _1.xlsm(13.9 Kb)
 
Ответить
СообщениеДобрый вечер.

Можно ли "усовершенствовать" формулы в столбиках F и G так, чтобы учитывалось, что есть не заполненные ячейки в столбиках C и D соответственно? (файл прилагаю)

Спасибо :unsure:

Автор - kotena
Дата добавления - 28.12.2018 в 00:58
_Boroda_ Дата: Пятница, 28.12.2018, 01:12 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 13928
Репутация: 5635 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так нужно?
Код
=ЕСЛИ(И(E3=0;C3=0);"";СУММ(C$3:C3))

Еще вариант
Код
=ЕСЛИ(E3+C3;СУММ(C$3:C3);"")


* Формулы четко по Вашим формулам, но не совсем ясно причем здесь столбец Е.
К сообщению приложен файл: _1_1.xlsm(14.4 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак нужно?
Код
=ЕСЛИ(И(E3=0;C3=0);"";СУММ(C$3:C3))

Еще вариант
Код
=ЕСЛИ(E3+C3;СУММ(C$3:C3);"")


* Формулы четко по Вашим формулам, но не совсем ясно причем здесь столбец Е.

Автор - _Boroda_
Дата добавления - 28.12.2018 в 01:12
kotena Дата: Пятница, 28.12.2018, 01:25 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 28
Репутация: 2 ±
Замечаний: 0% ±

Excel 2016
* Формулы четко по Вашим формулам, но не совсем ясно причем здесь столбец Е.

спасибо, да, именно так нужно и столбец Е действительно не нужен, забыла удалить... суть Вы правильно поняли, спасибо ещё раз)
 
Ответить
Сообщение
* Формулы четко по Вашим формулам, но не совсем ясно причем здесь столбец Е.

спасибо, да, именно так нужно и столбец Е действительно не нужен, забыла удалить... суть Вы правильно поняли, спасибо ещё раз)

Автор - kotena
Дата добавления - 28.12.2018 в 01:25
kotena Дата: Пятница, 28.12.2018, 19:30 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 28
Репутация: 2 ±
Замечаний: 0% ±

Excel 2016
условие усложнилось:
можно ли "усовершенствовать" формулы в столбиках E и F так, чтобы учитывалось, что есть незаполненные ячейки:
1. для товара1 в столбиках C и G
2. для товара2 в столбиках D и H соответственно?
и
3. если для товара есть приход (G; H), но нету расхода (C; D), чтобы в столбике всего (E; F) не отображался приход (если будет отображение, то это как бы неправильно), как это пытаетcя произойти в F5.
4. по возможности, чтобы при протягивании формулы вниз не "показывался" 0 (т.е. как в исходнике), если - нет, то - нет :)

Буду рада помощи. Спасибо)
К сообщению приложен файл: 1622456.xlsm(14.5 Kb)


Сообщение отредактировал kotena - Пятница, 28.12.2018, 19:42
 
Ответить
Сообщениеусловие усложнилось:
можно ли "усовершенствовать" формулы в столбиках E и F так, чтобы учитывалось, что есть незаполненные ячейки:
1. для товара1 в столбиках C и G
2. для товара2 в столбиках D и H соответственно?
и
3. если для товара есть приход (G; H), но нету расхода (C; D), чтобы в столбике всего (E; F) не отображался приход (если будет отображение, то это как бы неправильно), как это пытаетcя произойти в F5.
4. по возможности, чтобы при протягивании формулы вниз не "показывался" 0 (т.е. как в исходнике), если - нет, то - нет :)

Буду рада помощи. Спасибо)

Автор - kotena
Дата добавления - 28.12.2018 в 19:30
Pelena Дата: Пятница, 28.12.2018, 19:39 | Сообщение № 5
Группа: Админы
Ранг: Местный житель
Сообщений: 13485
Репутация: 2971 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Видимо, речь идёт уже о другом файле?


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеВидимо, речь идёт уже о другом файле?

Автор - Pelena
Дата добавления - 28.12.2018 в 19:39
kotena Дата: Пятница, 28.12.2018, 19:43 | Сообщение № 6
Группа: Пользователи
Ранг: Новичок
Сообщений: 28
Репутация: 2 ±
Замечаний: 0% ±

Excel 2016
Видимо, речь идёт уже о другом файле?

простите, да, вроде бы прикрепляла :)
 
Ответить
Сообщение
Видимо, речь идёт уже о другом файле?

простите, да, вроде бы прикрепляла :)

Автор - kotena
Дата добавления - 28.12.2018 в 19:43
Pelena Дата: Пятница, 28.12.2018, 19:59 | Сообщение № 7
Группа: Админы
Ранг: Местный житель
Сообщений: 13485
Репутация: 2971 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Не уверена, что правильно поняла
Код
=ЕСЛИ(C4=0;"";E$3+СУММ(G$3:G4)-СУММ(C$3:C4))
К сообщению приложен файл: 4285545.xlsm(14.8 Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеНе уверена, что правильно поняла
Код
=ЕСЛИ(C4=0;"";E$3+СУММ(G$3:G4)-СУММ(C$3:C4))

Автор - Pelena
Дата добавления - 28.12.2018 в 19:59
kotena Дата: Пятница, 28.12.2018, 20:10 | Сообщение № 8
Группа: Пользователи
Ранг: Новичок
Сообщений: 28
Репутация: 2 ±
Замечаний: 0% ±

Excel 2016
да, именно то, что нужно было, спасибо)
 
Ответить
Сообщениеда, именно то, что нужно было, спасибо)

Автор - kotena
Дата добавления - 28.12.2018 в 20:10
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Формула с учетом незаполненных ячеек (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!