Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Проверка вводимых значений по условию - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Проверка вводимых значений по условию (Формулы/Formulas)
Проверка вводимых значений по условию
mkotik Дата: Пятница, 04.01.2019, 14:39 | Сообщение № 1
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 101
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Добрый день, Уважаемые Знатоки!
С Наступившим Новым годом!
Как правильно написать формулу, чтобы при выборе значения в Ячейке B3 = "Все", в ячейках D3 и F3 проставлялась "Все"?
Файл прилагаю
К сообщению приложен файл: 5870136.xlsx(36.2 Kb)
 
Ответить
СообщениеДобрый день, Уважаемые Знатоки!
С Наступившим Новым годом!
Как правильно написать формулу, чтобы при выборе значения в Ячейке B3 = "Все", в ячейках D3 и F3 проставлялась "Все"?
Файл прилагаю

Автор - mkotik
Дата добавления - 04.01.2019 в 14:39
vikttur Дата: Пятница, 04.01.2019, 15:02 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 2808
Репутация: 504 ±
Замечаний: 0% ±

Проверка данных позволяет проверять вводимые данные, но не менять данные ячейки.
В одной ячейке проверка данных и формула не уживаются. Тут либо убрать проверку и данные подтягивать только формулой, или наряду с ручным вводом разрешить макросу менять значение
 
Ответить
СообщениеПроверка данных позволяет проверять вводимые данные, но не менять данные ячейки.
В одной ячейке проверка данных и формула не уживаются. Тут либо убрать проверку и данные подтягивать только формулой, или наряду с ручным вводом разрешить макросу менять значение

Автор - vikttur
Дата добавления - 04.01.2019 в 15:02
mkotik Дата: Пятница, 04.01.2019, 15:52 | Сообщение № 3
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 101
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
vikttur, спасибо за оперативность!
Поэтому и задаю вопрос - "Как правильно написать формулой?" даже с убиранием проверки?
 
Ответить
Сообщениеvikttur, спасибо за оперативность!
Поэтому и задаю вопрос - "Как правильно написать формулой?" даже с убиранием проверки?

Автор - mkotik
Дата добавления - 04.01.2019 в 15:52
vikttur Дата: Пятница, 04.01.2019, 17:19 | Сообщение № 4
Группа: Друзья
Ранг: Старожил
Сообщений: 2808
Репутация: 504 ±
Замечаний: 0% ±

Код
=ЕСЛИ(B3="Все";B3;"а здесь что писать?")
 
Ответить
Сообщение
Код
=ЕСЛИ(B3="Все";B3;"а здесь что писать?")

Автор - vikttur
Дата добавления - 04.01.2019 в 17:19
mkotik Дата: Пятница, 04.01.2019, 17:30 | Сообщение № 5
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 101
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
>> "а здесь что писать?"
А сюда надо как-то "подать" диапазон :(
 
Ответить
Сообщение>> "а здесь что писать?"
А сюда надо как-то "подать" диапазон :(

Автор - mkotik
Дата добавления - 04.01.2019 в 17:30
vikttur Дата: Пятница, 04.01.2019, 17:35 | Сообщение № 6
Группа: Друзья
Ранг: Старожил
Сообщений: 2808
Репутация: 504 ±
Замечаний: 0% ±

И? Еще раз: выбрать Вы сами ничего не сможете. Там будет формула.
А вот разрешить формуле выбирать что-либо из диапазона можно. Если, конечно, можно жестко задать условия. Но это уже не по теме.


Сообщение отредактировал vikttur - Пятница, 04.01.2019, 17:37
 
Ответить
СообщениеИ? Еще раз: выбрать Вы сами ничего не сможете. Там будет формула.
А вот разрешить формуле выбирать что-либо из диапазона можно. Если, конечно, можно жестко задать условия. Но это уже не по теме.

Автор - vikttur
Дата добавления - 04.01.2019 в 17:35
Nic70y Дата: Пятница, 04.01.2019, 17:37 | Сообщение № 7
Группа: Друзья
Ранг: Участник клуба
Сообщений: 5054
Репутация: 1086 ±
Замечаний: 0% ±

Excel 2013
[vba]
Код
Private Sub Worksheet_Change(ByVal Target As Range)
    If Not Intersect(Target, Range("b3")) Is Nothing Then
        If [b3] = "Все" Then [d3, f3] = "Все"
    End If
End Sub
[/vba]
ну это формула такая %)
К сообщению приложен файл: 5870136.xlsm(25.9 Kb)


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
Сообщение[vba]
Код
Private Sub Worksheet_Change(ByVal Target As Range)
    If Not Intersect(Target, Range("b3")) Is Nothing Then
        If [b3] = "Все" Then [d3, f3] = "Все"
    End If
End Sub
[/vba]
ну это формула такая %)

Автор - Nic70y
Дата добавления - 04.01.2019 в 17:37
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Проверка вводимых значений по условию (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!