Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Выборка по условию - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Выборка по условию (Формулы/Formulas)
Выборка по условию
Anis625 Дата: Воскресенье, 06.01.2019, 15:57 | Сообщение № 1
Группа: Проверенные
Ранг: Обитатель
Сообщений: 273
Репутация: 3 ±
Замечаний: 0% ±

Excel 2013
Добрый день.

Стандартная процедура - выборка значений по условию. Много раз делал. Все получалось.

Сейчас делаю форму напоминалку дней рождений за 30 дней (1500 строк условное форматирование и ручной фильтр не рассматривается).

Формула не работает. Где ошибся? Подскажите, пожалуйста.
К сообщению приложен файл: __.xlsx(11.9 Kb)
 
Ответить
СообщениеДобрый день.

Стандартная процедура - выборка значений по условию. Много раз делал. Все получалось.

Сейчас делаю форму напоминалку дней рождений за 30 дней (1500 строк условное форматирование и ручной фильтр не рассматривается).

Формула не работает. Где ошибся? Подскажите, пожалуйста.

Автор - Anis625
Дата добавления - 06.01.2019 в 15:57
krosav4ig Дата: Воскресенье, 06.01.2019, 17:19 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 2080
Репутация: 871 ±
Замечаний: 0% ±

Excel 2007,2010,2013
Здравствуйте
Код
=ЕСЛИОШИБКА(ИНДЕКС($B$2:$B$325;НАИМЕНЬШИЙ(ЕСЛИ((ДАТА(ГОД(СЕГОДНЯ());МЕСЯЦ($C$2:$C$325);ДЕНЬ($C$2:$C$325))-СЕГОДНЯ()>=0)*(ДАТА(ГОД(СЕГОДНЯ());МЕСЯЦ($C$2:$C$325);ДЕНЬ($C$2:$C$325))-СЕГОДНЯ()<=30);СТРОКА($B$2:$B$325)-СТРОКА($B$1));A4));"")

Код
=ЕСЛИОШИБКА(ИНДЕКС(B:B;НАИМЕНЬШИЙ(ЕСЛИ((--(ТЕКСТ(C$2:C$325;"[>0]д.М.;")&ГОД(СЕГОДНЯ()))>СЕГОДНЯ())*(C$2:C$325-(ТЕКСТ(СЕГОДНЯ();"д.М.")&ГОД(C$2:C$325))<30);СТРОКА(C$2:C$325));СТРОКА(F1)));"")


email:krosav4ig26@gmail.com WMR R207627035142 WMZ Z821145374535 ЯД 410012026478460
 
Ответить
СообщениеЗдравствуйте
Код
=ЕСЛИОШИБКА(ИНДЕКС($B$2:$B$325;НАИМЕНЬШИЙ(ЕСЛИ((ДАТА(ГОД(СЕГОДНЯ());МЕСЯЦ($C$2:$C$325);ДЕНЬ($C$2:$C$325))-СЕГОДНЯ()>=0)*(ДАТА(ГОД(СЕГОДНЯ());МЕСЯЦ($C$2:$C$325);ДЕНЬ($C$2:$C$325))-СЕГОДНЯ()<=30);СТРОКА($B$2:$B$325)-СТРОКА($B$1));A4));"")

Код
=ЕСЛИОШИБКА(ИНДЕКС(B:B;НАИМЕНЬШИЙ(ЕСЛИ((--(ТЕКСТ(C$2:C$325;"[>0]д.М.;")&ГОД(СЕГОДНЯ()))>СЕГОДНЯ())*(C$2:C$325-(ТЕКСТ(СЕГОДНЯ();"д.М.")&ГОД(C$2:C$325))<30);СТРОКА(C$2:C$325));СТРОКА(F1)));"")

Автор - krosav4ig
Дата добавления - 06.01.2019 в 17:19
Nic70y Дата: Воскресенье, 06.01.2019, 18:23 | Сообщение № 3
Группа: Друзья
Ранг: Участник клуба
Сообщений: 5317
Репутация: 1155 ±
Замечаний: 0% ±

Excel ru:home:13;10;03 work:10
Код
=ЕСЛИОШИБКА(ИНДЕКС(B:B;НАИМЕНЬШИЙ(ЕСЛИ(ОСТАТ((ДАТА(ГОД(СЕГОДНЯ());МЕСЯЦ(C$2:C$16);ДЕНЬ(C$2:C$16))-СЕГОДНЯ())-365;365)<=30;СТРОКА(C$2:C$16));СТРОКА(F1)));"")
наверное


ЯД(poison) 41001841029809
 
Ответить
Сообщение
Код
=ЕСЛИОШИБКА(ИНДЕКС(B:B;НАИМЕНЬШИЙ(ЕСЛИ(ОСТАТ((ДАТА(ГОД(СЕГОДНЯ());МЕСЯЦ(C$2:C$16);ДЕНЬ(C$2:C$16))-СЕГОДНЯ())-365;365)<=30;СТРОКА(C$2:C$16));СТРОКА(F1)));"")
наверное

Автор - Nic70y
Дата добавления - 06.01.2019 в 18:23
jakim Дата: Воскресенье, 06.01.2019, 19:27 | Сообщение № 4
Группа: Друзья
Ранг: Ветеран
Сообщений: 895
Репутация: 232 ±
Замечаний: 0% ±

Excel 2010
Предлагаю формулу

Код
=IFERROR(INDEX(B$2:B$160;AGGREGATE(15;6;ROW($1:$250)/((DATE(YEAR(TODAY());MONTH(C$2:C$160);DAY(C$2:C$160))-TODAY())<30)/(C$2:C$160<>"");ROWS($2:2)));"")
 
Ответить
Сообщение
Предлагаю формулу

Код
=IFERROR(INDEX(B$2:B$160;AGGREGATE(15;6;ROW($1:$250)/((DATE(YEAR(TODAY());MONTH(C$2:C$160);DAY(C$2:C$160))-TODAY())<30)/(C$2:C$160<>"");ROWS($2:2)));"")

Автор - jakim
Дата добавления - 06.01.2019 в 19:27
Anis625 Дата: Воскресенье, 06.01.2019, 20:04 | Сообщение № 5
Группа: Проверенные
Ранг: Обитатель
Сообщений: 273
Репутация: 3 ±
Замечаний: 0% ±

Excel 2013
krosav4ig, Nic70y, jakim,
Ребятаааааа, получилось крууууто.

Понятно, что Ваши варианты формул не работают. Для себя в копилку, потому что многими из них ни разу не пользовался (АГРЕГАТ). Вариант с остатком от деления на 365 тоже вариант, но может подвести в високосный год (может быть неточность на 1 день). Изначально хотел воспользоваться РАЗНДАТ с "YD", но он тоже давал погрешность (с некоторыми датами) на 1 день.

Для себя я так и не понял: почему не срабатывает мой вариант с И(__;__), а вариант krosav4ig с (__)*(__) сработал? Вроде одно и тоже же.
 
Ответить
Сообщениеkrosav4ig, Nic70y, jakim,
Ребятаааааа, получилось крууууто.

Понятно, что Ваши варианты формул не работают. Для себя в копилку, потому что многими из них ни разу не пользовался (АГРЕГАТ). Вариант с остатком от деления на 365 тоже вариант, но может подвести в високосный год (может быть неточность на 1 день). Изначально хотел воспользоваться РАЗНДАТ с "YD", но он тоже давал погрешность (с некоторыми датами) на 1 день.

Для себя я так и не понял: почему не срабатывает мой вариант с И(__;__), а вариант krosav4ig с (__)*(__) сработал? Вроде одно и тоже же.

Автор - Anis625
Дата добавления - 06.01.2019 в 20:04
Pelena Дата: Воскресенье, 06.01.2019, 20:07 | Сообщение № 6
Группа: Админы
Ранг: Местный житель
Сообщений: 14094
Репутация: 3081 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Вроде одно и тоже же

Не совсем. И(__;__) даёт в результате одно значение, а (__)*(__) - массив значений


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
Сообщение
Вроде одно и тоже же

Не совсем. И(__;__) даёт в результате одно значение, а (__)*(__) - массив значений

Автор - Pelena
Дата добавления - 06.01.2019 в 20:07
Anis625 Дата: Воскресенье, 06.01.2019, 20:48 | Сообщение № 7
Группа: Проверенные
Ранг: Обитатель
Сообщений: 273
Репутация: 3 ±
Замечаний: 0% ±

Excel 2013
Спасибо Всем за помощь и новый урок =)
 
Ответить
СообщениеСпасибо Всем за помощь и новый урок =)

Автор - Anis625
Дата добавления - 06.01.2019 в 20:48
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Выборка по условию (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!