Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Сводная таблица (диапазон чисел) - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сводная таблица (диапазон чисел) (Сводные таблицы/Pivot Table)
Сводная таблица (диапазон чисел)
Polonez Дата: Среда, 16.01.2019, 20:56 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Ребят, в общем суть такова. Я провожу сверку бланков строгой отчетности... с бумажного акта и выгрузки базы в Excel, там идет порядковые номера как в акте так и в выгрузке. Но иногда акты приносят с диапазоном номеров т.е. к примеру: с 50114589 по 50114595. Есть 3 столбца (серия, номер и подразделение) где к примеру моя выгрузка. Вопрос, можно ли создать сводную таблицу что бы она показывала (количество номеров в диапазоне, диапазон "с" - "по" и подразделения чьи эти номера? Или только через макрос можно такое сделать ?
 
Ответить
СообщениеРебят, в общем суть такова. Я провожу сверку бланков строгой отчетности... с бумажного акта и выгрузки базы в Excel, там идет порядковые номера как в акте так и в выгрузке. Но иногда акты приносят с диапазоном номеров т.е. к примеру: с 50114589 по 50114595. Есть 3 столбца (серия, номер и подразделение) где к примеру моя выгрузка. Вопрос, можно ли создать сводную таблицу что бы она показывала (количество номеров в диапазоне, диапазон "с" - "по" и подразделения чьи эти номера? Или только через макрос можно такое сделать ?

Автор - Polonez
Дата добавления - 16.01.2019 в 20:56
Nic70y Дата: Среда, 16.01.2019, 21:02 | Сообщение № 2
Группа: Друзья
Ранг: Экселист
Сообщений: 5346
Репутация: 1158 ±
Замечаний: 0% ±

ru13;10;03
Вы бы показали небольшой пример в файле-Excel, что есть и что хотите получить.
из описания мало что понятно.


ЯД(poison) 41001841029809
 
Ответить
СообщениеВы бы показали небольшой пример в файле-Excel, что есть и что хотите получить.
из описания мало что понятно.

Автор - Nic70y
Дата добавления - 16.01.2019 в 21:02
Polonez Дата: Среда, 16.01.2019, 21:11 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Прикладывал файл. Почему то не загрузился
К сообщению приложен файл: 1664698.xlsx(13.3 Kb)
 
Ответить
СообщениеПрикладывал файл. Почему то не загрузился

Автор - Polonez
Дата добавления - 16.01.2019 в 21:11
Nic70y Дата: Среда, 16.01.2019, 21:40 | Сообщение № 4
Группа: Друзья
Ранг: Экселист
Сообщений: 5346
Репутация: 1158 ±
Замечаний: 0% ±

ru13;10;03
Вы не показали какой должен быть результат.
наброски:
Код
=ЕСЛИ(A2=A1;ЕСЛИ(И(B2-1=--B1;B2+1=--B3);"";ЕСЛИ(И(D1="";A2=A1);"-";"")&B2);B2)


забыл --
переписал, файл перезалил
К сообщению приложен файл: 20.xlsx(18.1 Kb)


ЯД(poison) 41001841029809

Сообщение отредактировал Nic70y - Среда, 16.01.2019, 21:45
 
Ответить
СообщениеВы не показали какой должен быть результат.
наброски:
Код
=ЕСЛИ(A2=A1;ЕСЛИ(И(B2-1=--B1;B2+1=--B3);"";ЕСЛИ(И(D1="";A2=A1);"-";"")&B2);B2)


забыл --
переписал, файл перезалил

Автор - Nic70y
Дата добавления - 16.01.2019 в 21:40
Polonez Дата: Среда, 16.01.2019, 21:56 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Такого плана можно сделать в сводной таблице ? Количество, серия, номер и подразделение в сводной таблице получилось, а вот интервалов из числовой последовательности сделать я не знаю и что бы к примеру 1-й номер в интервале тоже считал, а не от 1-го! Помогите пожалуйста очень благодарен буду. :'(
Белгород:
Серия Интервал Количество
МММ 50114589-50114595 7
МММ 50114598 1
ЕП3 169163-169165 3

Санкт-Петербург:
Серия Интервал Количество
ТМ 005839-005845 7
МММ 50114598 1
Д3 082777-082779 3
К сообщению приложен файл: 7883934.xlsx(13.3 Kb)
 
Ответить
СообщениеТакого плана можно сделать в сводной таблице ? Количество, серия, номер и подразделение в сводной таблице получилось, а вот интервалов из числовой последовательности сделать я не знаю и что бы к примеру 1-й номер в интервале тоже считал, а не от 1-го! Помогите пожалуйста очень благодарен буду. :'(
Белгород:
Серия Интервал Количество
МММ 50114589-50114595 7
МММ 50114598 1
ЕП3 169163-169165 3

Санкт-Петербург:
Серия Интервал Количество
ТМ 005839-005845 7
МММ 50114598 1
Д3 082777-082779 3

Автор - Polonez
Дата добавления - 16.01.2019 в 21:56
Polonez Дата: Среда, 16.01.2019, 22:47 | Сообщение № 6
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Nic70y, Спасибо, что то похожие. Подробный результат во вложении на 4 листе.
К сообщению приложен файл: 12345.xlsx(23.6 Kb)
 
Ответить
СообщениеNic70y, Спасибо, что то похожие. Подробный результат во вложении на 4 листе.

Автор - Polonez
Дата добавления - 16.01.2019 в 22:47
sboy Дата: Четверг, 17.01.2019, 09:28 | Сообщение № 7
Группа: Друзья
Ранг: Участник клуба
Сообщений: 2538
Репутация: 717 ±
Замечаний: 0% ±

Excel 2010
Вариант с двумя доп.столбцами и "допилкой" в PQ.
Выгрузка таблицей или подключением к сводной.
Код
=ЕСЛИ(A2=A1;ЕСЛИ((B2-1)=--B1;D1;B2);B2)

Код
=ЕСЛИ(И(A2=A1;D2<>D3);"-"&B2;"")
К сообщению приложен файл: 7798466.xlsx(29.3 Kb)


Яндекс: 410016850021169
 
Ответить
СообщениеВариант с двумя доп.столбцами и "допилкой" в PQ.
Выгрузка таблицей или подключением к сводной.
Код
=ЕСЛИ(A2=A1;ЕСЛИ((B2-1)=--B1;D1;B2);B2)

Код
=ЕСЛИ(И(A2=A1;D2<>D3);"-"&B2;"")

Автор - sboy
Дата добавления - 17.01.2019 в 09:28
Polonez Дата: Четверг, 17.01.2019, 12:53 | Сообщение № 8
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Спасибо огромное. Только вот не могу понять как 2-я таблица создавалась. Пытаюсь разобраться. Особо не понимаю как диапазон в одной ячейке появился и как количество по считали. Подскажите пожалуйста
 
Ответить
СообщениеСпасибо огромное. Только вот не могу понять как 2-я таблица создавалась. Пытаюсь разобраться. Особо не понимаю как диапазон в одной ячейке появился и как количество по считали. Подскажите пожалуйста

Автор - Polonez
Дата добавления - 17.01.2019 в 12:53
sboy Дата: Четверг, 17.01.2019, 13:03 | Сообщение № 9
Группа: Друзья
Ранг: Участник клуба
Сообщений: 2538
Репутация: 717 ±
Замечаний: 0% ±

Excel 2010
в редакторе запросов Power Query.
в 2016 Excel вроде должен находиться на вкладке данные (Показать запросы)


Яндекс: 410016850021169
 
Ответить
Сообщениев редакторе запросов Power Query.
в 2016 Excel вроде должен находиться на вкладке данные (Показать запросы)

Автор - sboy
Дата добавления - 17.01.2019 в 13:03
Polonez Дата: Четверг, 17.01.2019, 19:16 | Сообщение № 10
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
sboy, Спасибо огромное hands Во всем разобрался. Очень выручил и упростил очень долгую и мутную работу.
 
Ответить
Сообщениеsboy, Спасибо огромное hands Во всем разобрался. Очень выручил и упростил очень долгую и мутную работу.

Автор - Polonez
Дата добавления - 17.01.2019 в 19:16
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сводная таблица (диапазон чисел) (Сводные таблицы/Pivot Table)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!