Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Определить кол-во тренингов и дату последнего обучения - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Определить кол-во тренингов и дату последнего обучения (Формулы/Formulas)
Определить кол-во тренингов и дату последнего обучения
katrin12666 Дата: Вторник, 22.01.2019, 08:02 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Все .здравствуйте ! Прошу помочь решить поставленную передо мной задачу! Несколько дней пытаюсь найти в интернете какие-то примеры подобного решения и проверяю всевозможные формулы. пользуюсь Excel на элементарном уровне . Так как учусь на заочном ,то преподаватели особо не затрагивают сложные темы, но задают по полной программе . Надеюсь на понимание и помощь
Условия: необходимо на первой вкладке заполнить
ячейки, выделенные цветом не используя значения. То есть, в них должна быть
сложносоставная формула, которая должна пересчитывать значение, если мы добавим
данные по другим тренингам на следующих вкладках.
В Скорее всего вам
понадобятся Countif, vlookup, max или их русские аналоги.
К сообщению приложен файл: __-_2-1-.xlsx(16.1 Kb)


Сообщение отредактировал Pelena - Вторник, 22.01.2019, 23:42
 
Ответить
СообщениеВсе .здравствуйте ! Прошу помочь решить поставленную передо мной задачу! Несколько дней пытаюсь найти в интернете какие-то примеры подобного решения и проверяю всевозможные формулы. пользуюсь Excel на элементарном уровне . Так как учусь на заочном ,то преподаватели особо не затрагивают сложные темы, но задают по полной программе . Надеюсь на понимание и помощь
Условия: необходимо на первой вкладке заполнить
ячейки, выделенные цветом не используя значения. То есть, в них должна быть
сложносоставная формула, которая должна пересчитывать значение, если мы добавим
данные по другим тренингам на следующих вкладках.
В Скорее всего вам
понадобятся Countif, vlookup, max или их русские аналоги.

Автор - katrin12666
Дата добавления - 22.01.2019 в 08:02
Pelena Дата: Вторник, 22.01.2019, 08:05 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 14233
Репутация: 3110 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
И Вам здравствуйте.
Прочитайте Правила форума, особенно внимательно п.п. 2 и 4


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеИ Вам здравствуйте.
Прочитайте Правила форума, особенно внимательно п.п. 2 и 4

Автор - Pelena
Дата добавления - 22.01.2019 в 08:05
RAN Дата: Вторник, 22.01.2019, 10:17 | Сообщение № 3
Группа: Друзья
Ранг: Участник клуба
Сообщений: 5100
Репутация: 1016 ±
Замечаний: 0% ±

2010
Лен, о чем ты?
(это практическое задание на умение пользоваться Excel
как одной из базовых информационных технологий).
Вам следует самостоятельно найти какие функции использовать.

Тренируйся! :D


Быть или не быть, вот в чем загвоздка!
 
Ответить
СообщениеЛен, о чем ты?
(это практическое задание на умение пользоваться Excel
как одной из базовых информационных технологий).
Вам следует самостоятельно найти какие функции использовать.

Тренируйся! :D

Автор - RAN
Дата добавления - 22.01.2019 в 10:17
Pelena Дата: Вторник, 22.01.2019, 10:23 | Сообщение № 4
Группа: Админы
Ранг: Местный житель
Сообщений: 14233
Репутация: 3110 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Ну, она и ищет... самостоятельно... как может :D


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеНу, она и ищет... самостоятельно... как может :D

Автор - Pelena
Дата добавления - 22.01.2019 в 10:23
katrin12666 Дата: Вторник, 22.01.2019, 13:45 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Pelena, изаините! условия изменены
 
Ответить
СообщениеPelena, изаините! условия изменены

Автор - katrin12666
Дата добавления - 22.01.2019 в 13:45
katrin12666 Дата: Вторник, 22.01.2019, 13:45 | Сообщение № 6
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Pelena, изаините! условия изменены
 
Ответить
СообщениеPelena, изаините! условия изменены

Автор - katrin12666
Дата добавления - 22.01.2019 в 13:45
_Boroda_ Дата: Вторник, 22.01.2019, 14:18 | Сообщение № 7
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15417
Репутация: 6032 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
katrin12666, спрошу Вас как студент (хоть и бывший) студента - Вы читать умеете?

Прочитайте Правила форума, особенно внимательно п.п. 2


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщениеkatrin12666, спрошу Вас как студент (хоть и бывший) студента - Вы читать умеете?

Прочитайте Правила форума, особенно внимательно п.п. 2

Автор - _Boroda_
Дата добавления - 22.01.2019 в 14:18
katrin12666 Дата: Вторник, 22.01.2019, 14:36 | Сообщение № 8
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
_Boroda_, _я исправила название темы
 
Ответить
Сообщение_Boroda_, _я исправила название темы

Автор - katrin12666
Дата добавления - 22.01.2019 в 14:36
krosav4ig Дата: Вторник, 22.01.2019, 23:19 | Сообщение № 9
Группа: Друзья
Ранг: Старожил
Сообщений: 2106
Репутация: 879 ±
Замечаний: 0% ±

Excel 2007,2010,2013
Вам следует самостоятельно найти какие функции использовать.
а я их нашел B)

Используйте на здоровье :)


email:krosav4ig26@gmail.com WMR R207627035142 WMZ Z821145374535 ЯД 410012026478460

Сообщение отредактировал krosav4ig - Вторник, 22.01.2019, 23:21
 
Ответить
Сообщение
Вам следует самостоятельно найти какие функции использовать.
а я их нашел B)

Используйте на здоровье :)

Автор - krosav4ig
Дата добавления - 22.01.2019 в 23:19
Pelena Дата: Вторник, 22.01.2019, 23:43 | Сообщение № 10
Группа: Админы
Ранг: Местный житель
Сообщений: 14233
Репутация: 3110 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Название темы исправлено


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеНазвание темы исправлено

Автор - Pelena
Дата добавления - 22.01.2019 в 23:43
krosav4ig Дата: Вторник, 22.01.2019, 23:57 | Сообщение № 11
Группа: Друзья
Ранг: Старожил
Сообщений: 2106
Репутация: 879 ±
Замечаний: 0% ±

Excel 2007,2010,2013
Не знаю, как вы будете объяснять преподавателю что это такое и почему так, но как-то так %) ...
В диспетчере имен
Код
aa    =ПОЛУЧИТЬ.ЯЧЕЙКУ(66;C2)
Код
bb    =ПОЛУЧИТЬ.РАБОЧУЮ.КНИГУ(4;aa)
Код
cc    =ИНДЕКС(ПОЛУЧИТЬ.РАБОЧУЮ.КНИГУ(1;aa);Ч(ИНДЕКС(СТОЛБЕЦ($B$1:ИНДЕКС($1:$1;bb));)))
Код
dd    =ПОЛУЧИТЬ.ДОКУМЕНТ(9;Т(ИНДЕКС(cc;0)))
Код
ee    =ПОЛУЧИТЬ.ДОКУМЕНТ(10;Т(ИНДЕКС(cc;0)))
Код
ff    =ПОЛУЧИТЬ.ДОКУМЕНТ(11;Т(ИНДЕКС(cc;0)))
Код
gg    =ЕСЛИ({1:1:0};СЖПРОБЕЛЫ(ПСТР(ПОДСТАВИТЬ(ЛЕВБ($B2;ПОИСК(" ";$B2)-1);"/";ПОВТОР(" ";99));{1:99};99)&ПРАВБ($B2;ДЛСТР($B2)+1-ПОИСК(" ";$B2)));ЕСЛИОШИБКА(Т(ПОИСК("/";$B2))&$B2;))
Код
hh    =ИНДЕКС(ОТБР((СТРОКА(C$1:ИНДЕКС(C:C;МАКС(ee-dd+1)*(bb-1)))-1)/МАКС(ee-dd+1))+1;)
Код
ii    =МИН(dd)+ОСТАТ(СТРОКА(C$1:ИНДЕКС(C:C;МАКС(ee-dd+1)*(bb-1)))-1;МАКС(ee-dd+1))
Код
Количество    =СУММ(СЧЁТЕСЛИ(ДВССЫЛ("'"&cc&"'!R"&МИН(dd)&"C"&CC&":R"&МАКС(ee)&"C"&CC;);gg))
Код
ПоследняяДата    =МАКС((Т(ДВССЫЛ("'"&ИНДЕКС(cc;Ч(hh))&"'!R"&ii&"C"&ИНДЕКС(CC;Ч(hh));))=ТРАНСП(gg))*Ч(ДВССЫЛ("'"&ИНДЕКС(cc;Ч(hh))&"'!R"&ii&"C"&ИНДЕКС(CC;Ч(hh))+1;)))

в ячейках формулы
Код
=Количество
и
Код
=ПоследняяДата
К сообщению приложен файл: -2-1-.xlsm(17.4 Kb)


email:krosav4ig26@gmail.com WMR R207627035142 WMZ Z821145374535 ЯД 410012026478460

Сообщение отредактировал krosav4ig - Среда, 23.01.2019, 00:16
 
Ответить
СообщениеНе знаю, как вы будете объяснять преподавателю что это такое и почему так, но как-то так %) ...
В диспетчере имен
Код
aa    =ПОЛУЧИТЬ.ЯЧЕЙКУ(66;C2)
Код
bb    =ПОЛУЧИТЬ.РАБОЧУЮ.КНИГУ(4;aa)
Код
cc    =ИНДЕКС(ПОЛУЧИТЬ.РАБОЧУЮ.КНИГУ(1;aa);Ч(ИНДЕКС(СТОЛБЕЦ($B$1:ИНДЕКС($1:$1;bb));)))
Код
dd    =ПОЛУЧИТЬ.ДОКУМЕНТ(9;Т(ИНДЕКС(cc;0)))
Код
ee    =ПОЛУЧИТЬ.ДОКУМЕНТ(10;Т(ИНДЕКС(cc;0)))
Код
ff    =ПОЛУЧИТЬ.ДОКУМЕНТ(11;Т(ИНДЕКС(cc;0)))
Код
gg    =ЕСЛИ({1:1:0};СЖПРОБЕЛЫ(ПСТР(ПОДСТАВИТЬ(ЛЕВБ($B2;ПОИСК(" ";$B2)-1);"/";ПОВТОР(" ";99));{1:99};99)&ПРАВБ($B2;ДЛСТР($B2)+1-ПОИСК(" ";$B2)));ЕСЛИОШИБКА(Т(ПОИСК("/";$B2))&$B2;))
Код
hh    =ИНДЕКС(ОТБР((СТРОКА(C$1:ИНДЕКС(C:C;МАКС(ee-dd+1)*(bb-1)))-1)/МАКС(ee-dd+1))+1;)
Код
ii    =МИН(dd)+ОСТАТ(СТРОКА(C$1:ИНДЕКС(C:C;МАКС(ee-dd+1)*(bb-1)))-1;МАКС(ee-dd+1))
Код
Количество    =СУММ(СЧЁТЕСЛИ(ДВССЫЛ("'"&cc&"'!R"&МИН(dd)&"C"&CC&":R"&МАКС(ee)&"C"&CC;);gg))
Код
ПоследняяДата    =МАКС((Т(ДВССЫЛ("'"&ИНДЕКС(cc;Ч(hh))&"'!R"&ii&"C"&ИНДЕКС(CC;Ч(hh));))=ТРАНСП(gg))*Ч(ДВССЫЛ("'"&ИНДЕКС(cc;Ч(hh))&"'!R"&ii&"C"&ИНДЕКС(CC;Ч(hh))+1;)))

в ячейках формулы
Код
=Количество
и
Код
=ПоследняяДата

Автор - krosav4ig
Дата добавления - 22.01.2019 в 23:57
katrin12666 Дата: Среда, 23.01.2019, 08:39 | Сообщение № 12
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
krosav4ig, это прямо очень сложно, а через одну формулу это никак не получиться сделать?
 
Ответить
Сообщениеkrosav4ig, это прямо очень сложно, а через одну формулу это никак не получиться сделать?

Автор - katrin12666
Дата добавления - 23.01.2019 в 08:39
_Boroda_ Дата: Среда, 23.01.2019, 09:17 | Сообщение № 13
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15417
Репутация: 6032 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Фразу
если мы добавим
данные по другим тренингам на следующих вкладках
я понял не как "если мы добавим новые листы и данные в них", а как "если мы добавим новые данные в уже существующих листах"
Тогда, предположив, что больще 999 строк не будет заполнено, можно написать так
Код
=СЧЁТЕСЛИ('Прошли обучение летом'!A:A;B2)+СЧЁТЕСЛИ('Прошли обучение зимой'!A:A;B2)

Код
=МАКС(ЕСЛИ('Прошли обучение летом'!A$1:A$999=B2;'Прошли обучение летом'!B$1:B$999);ЕСЛИ('Прошли обучение зимой'!A$1:A$999=B2;'Прошли обучение зимой'!B$1:B$999))

Вторая - формула массива. Вводится одновременным нажатием Ctrl+Shift+Enter. И формат в столбце D "ДД.ММ.ГГГГ;;" (без кавычек)
Можно и иначе написать, я предложил вариант попроще (на мой взгляд)

* Преподаватель спросит (я бы спросил) - почему в СЧЁТЕСЛИ не пишем диапазон на 999 строк, а в ЕСЛИ пишем"? Ответ - потому, что у некоторых функций можно писать диапазоны по полным строкам (столбцам). Из наиболее часто используемых это СЧЁТЕСЛИ, СУММЕСЛИ, СЧЁТЕСЛИМЕ, СУММЕСЛИМН, ИНДЕКС.


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеФразу
если мы добавим
данные по другим тренингам на следующих вкладках
я понял не как "если мы добавим новые листы и данные в них", а как "если мы добавим новые данные в уже существующих листах"
Тогда, предположив, что больще 999 строк не будет заполнено, можно написать так
Код
=СЧЁТЕСЛИ('Прошли обучение летом'!A:A;B2)+СЧЁТЕСЛИ('Прошли обучение зимой'!A:A;B2)

Код
=МАКС(ЕСЛИ('Прошли обучение летом'!A$1:A$999=B2;'Прошли обучение летом'!B$1:B$999);ЕСЛИ('Прошли обучение зимой'!A$1:A$999=B2;'Прошли обучение зимой'!B$1:B$999))

Вторая - формула массива. Вводится одновременным нажатием Ctrl+Shift+Enter. И формат в столбце D "ДД.ММ.ГГГГ;;" (без кавычек)
Можно и иначе написать, я предложил вариант попроще (на мой взгляд)

* Преподаватель спросит (я бы спросил) - почему в СЧЁТЕСЛИ не пишем диапазон на 999 строк, а в ЕСЛИ пишем"? Ответ - потому, что у некоторых функций можно писать диапазоны по полным строкам (столбцам). Из наиболее часто используемых это СЧЁТЕСЛИ, СУММЕСЛИ, СЧЁТЕСЛИМЕ, СУММЕСЛИМН, ИНДЕКС.

Автор - _Boroda_
Дата добавления - 23.01.2019 в 09:17
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Определить кол-во тренингов и дату последнего обучения (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!