Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Какая должна быть формула для подстановки значения ? - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Какая должна быть формула для подстановки значения ? (Формулы/Formulas)
Какая должна быть формула для подстановки значения ?
ASPERA Дата: Среда, 23.01.2019, 11:22 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
В колону с "Поставщик" - нужно подставлять название поставщика с минимальной ценой,
и это протянуть на 600 строчек
К сообщению приложен файл: 0159169.xlsx(17.8 Kb)
 
Ответить
СообщениеВ колону с "Поставщик" - нужно подставлять название поставщика с минимальной ценой,
и это протянуть на 600 строчек

Автор - ASPERA
Дата добавления - 23.01.2019 в 11:22
sboy Дата: Среда, 23.01.2019, 11:29 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 2449
Репутация: 689 ±
Замечаний: 0% ±

Excel 2010
Добрый день.
Вариант
Код
=ИНДЕКС($E$1:$BR$1;ПОИСКПОЗ(D2;$F2:$BR2;))
К сообщению приложен файл: 7527668.xlsx(18.5 Kb)


Яндекс: 410016850021169
 
Ответить
СообщениеДобрый день.
Вариант
Код
=ИНДЕКС($E$1:$BR$1;ПОИСКПОЗ(D2;$F2:$BR2;))

Автор - sboy
Дата добавления - 23.01.2019 в 11:29
Светлый Дата: Среда, 23.01.2019, 11:46 | Сообщение № 3
Группа: Проверенные
Ранг: Старожил
Сообщений: 1010
Репутация: 259 ±
Замечаний: 0% ±

Excel 2010
И Вам добрый день!
Если учесть, что первый поставщик "не как все", то формула:
Код
=ИНДЕКС(F$1:BR$1;ПОИСКПОЗ(D2;F2:BR2;)-(ПОИСКПОЗ(D2;F2:BR2;)>1))
Или добавить столбец.
*И минимальное значение формула массива:
Код
=МИН(Ч(СМЕЩ(C2;;СТРОКА($1:$22)*3)))


Программировать проще, чем писать стихи.

Сообщение отредактировал Светлый - Среда, 23.01.2019, 11:48
 
Ответить
СообщениеИ Вам добрый день!
Если учесть, что первый поставщик "не как все", то формула:
Код
=ИНДЕКС(F$1:BR$1;ПОИСКПОЗ(D2;F2:BR2;)-(ПОИСКПОЗ(D2;F2:BR2;)>1))
Или добавить столбец.
*И минимальное значение формула массива:
Код
=МИН(Ч(СМЕЩ(C2;;СТРОКА($1:$22)*3)))

Автор - Светлый
Дата добавления - 23.01.2019 в 11:46
ASPERA Дата: Среда, 23.01.2019, 13:24 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
СПАСИБО ВСЕМ... :)
 
Ответить
СообщениеСПАСИБО ВСЕМ... :)

Автор - ASPERA
Дата добавления - 23.01.2019 в 13:24
ASPERA Дата: Вторник, 29.01.2019, 11:22 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Опять нужна помощь...нужно создать гиперссылку для ячейки "E2" -чтобы переходить на колонку с указанным значением в этой ячейки...
К сообщению приложен файл: 4022694.xlsx(18.5 Kb)
 
Ответить
СообщениеОпять нужна помощь...нужно создать гиперссылку для ячейки "E2" -чтобы переходить на колонку с указанным значением в этой ячейки...

Автор - ASPERA
Дата добавления - 29.01.2019 в 11:22
ASPERA Дата: Вторник, 29.01.2019, 11:23 | Сообщение № 6
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
и растянуть гиперссулку вниз
%)
 
Ответить
Сообщениеи растянуть гиперссулку вниз
%)

Автор - ASPERA
Дата добавления - 29.01.2019 в 11:23
sboy Дата: Вторник, 29.01.2019, 12:57 | Сообщение № 7
Группа: Друзья
Ранг: Старожил
Сообщений: 2449
Репутация: 689 ±
Замечаний: 0% ±

Excel 2010
гиперссулку

:)
Код
=ГИПЕРССЫЛКА(ПСТР(ЯЧЕЙКА("имяфайла");ПОИСК("[";ЯЧЕЙКА("имяфайла"));99)&"!R1C"&ПОИСКПОЗ(D2;$G2:$BS2;)+5;ИНДЕКС($E$1:$BR$1;ПОИСКПОЗ(D2;$F2:$BR2;)))

[p.s.]столбец один добавил для первого поставщика
К сообщению приложен файл: 3095409.xlsx(18.8 Kb)


Яндекс: 410016850021169
 
Ответить
Сообщение
гиперссулку

:)
Код
=ГИПЕРССЫЛКА(ПСТР(ЯЧЕЙКА("имяфайла");ПОИСК("[";ЯЧЕЙКА("имяфайла"));99)&"!R1C"&ПОИСКПОЗ(D2;$G2:$BS2;)+5;ИНДЕКС($E$1:$BR$1;ПОИСКПОЗ(D2;$F2:$BR2;)))

[p.s.]столбец один добавил для первого поставщика

Автор - sboy
Дата добавления - 29.01.2019 в 12:57
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Какая должна быть формула для подстановки значения ? (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!