Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/формула для заполнения данными из двух горизонтальных таблиц - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » формула для заполнения данными из двух горизонтальных таблиц (Формулы/Formulas)
формула для заполнения данными из двух горизонтальных таблиц
bezproigricha Дата: Среда, 23.01.2019, 16:38 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Добрый день!
Помогите пожалуйста создать одну формулу для заполнения таблицы 3 из двух горизонтальных таблиц 1 и 2,
возможно, используя, критерии (выделены цветом). Первые колонки с данными Табл.3 заполнены простыми равенствами,
когда так делаешь можно запутаться - хотелось бы одну формулу.
Искала на форуме, пробовала из похожих тем, но что-то не получается.....
К сообщению приложен файл: 8365541.xlsx(13.6 Kb)
 
Ответить
СообщениеДобрый день!
Помогите пожалуйста создать одну формулу для заполнения таблицы 3 из двух горизонтальных таблиц 1 и 2,
возможно, используя, критерии (выделены цветом). Первые колонки с данными Табл.3 заполнены простыми равенствами,
когда так делаешь можно запутаться - хотелось бы одну формулу.
Искала на форуме, пробовала из похожих тем, но что-то не получается.....

Автор - bezproigricha
Дата добавления - 23.01.2019 в 16:38
gling Дата: Среда, 23.01.2019, 18:30 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 1954
Репутация: 486 ±
Замечаний: 0% ±

2010
Здравствуйте. Попробуйте ГПР. Для Табл1
Код
=ГПР($B17;$B$2:$H$6;СТОЛБЕЦ(B17);0)
Для Табл2
Код
=ГПР($B17;$B$8:$H$12;СТОЛБЕЦ(B17);0)
Или одна формула для всей Таблицы 3. Только в табл1 и табл2 в столбце А, после буквы А пробел, его надо убрать.
Код
=ИНДЕКС(($B$3:$H$6;$B$9:$H$12);ПОИСКПОЗ(D$16;$A$3:$A$5;0);ПОИСКПОЗ($B17;$B$2:$H$2;0);1+(СТОЛБЕЦ()>7))
К сообщению приложен файл: 9553483.xlsx(14.1 Kb)


ЯД-41001506838083

Сообщение отредактировал gling - Среда, 23.01.2019, 18:44
 
Ответить
СообщениеЗдравствуйте. Попробуйте ГПР. Для Табл1
Код
=ГПР($B17;$B$2:$H$6;СТОЛБЕЦ(B17);0)
Для Табл2
Код
=ГПР($B17;$B$8:$H$12;СТОЛБЕЦ(B17);0)
Или одна формула для всей Таблицы 3. Только в табл1 и табл2 в столбце А, после буквы А пробел, его надо убрать.
Код
=ИНДЕКС(($B$3:$H$6;$B$9:$H$12);ПОИСКПОЗ(D$16;$A$3:$A$5;0);ПОИСКПОЗ($B17;$B$2:$H$2;0);1+(СТОЛБЕЦ()>7))

Автор - gling
Дата добавления - 23.01.2019 в 18:30
Nic70y Дата: Среда, 23.01.2019, 19:09 | Сообщение № 3
Группа: Друзья
Ранг: Экселист
Сообщений: 5431
Репутация: 1186 ±
Замечаний: 0% ±

ru13;10;03
в ячейках A4 и A10 после буквы был пробел, если его убрать, то можно применить такую формулу.
Код
=ЕСЛИОШИБКА(ИНДЕКС($1:$1048576;ПОИСКПОЗ(D$16;ИНДЕКС($A:$A;ПОИСКПОЗ(ГПР("我";$D$15:D$15;1);$A:$A;)):ИНДЕКС($A:$A;ПОИСКПОЗ("Общий итог";ИНДЕКС($A:$A;ПОИСКПОЗ(ГПР("我";$D$15:D$15;1);$A:$A;)):$A$1048576;)+ПОИСКПОЗ(ГПР("我";$D$15:D$15;1);$A:$A;)-1);)+ПОИСКПОЗ(ГПР("我";$D$15:D$15;1);$A:$A;)-1;ПОИСКПОЗ($B17;ИНДЕКС($1:$1048576;ПОИСКПОЗ(ГПР("我";$D$15:D$15;1);$A:$A;)+1;);));"")
она конечно не красива, но зато смешнее других.
К сообщению приложен файл: 3460630.xlsx(14.2 Kb)


ЯД(poison) 41001841029809
 
Ответить
Сообщениев ячейках A4 и A10 после буквы был пробел, если его убрать, то можно применить такую формулу.
Код
=ЕСЛИОШИБКА(ИНДЕКС($1:$1048576;ПОИСКПОЗ(D$16;ИНДЕКС($A:$A;ПОИСКПОЗ(ГПР("我";$D$15:D$15;1);$A:$A;)):ИНДЕКС($A:$A;ПОИСКПОЗ("Общий итог";ИНДЕКС($A:$A;ПОИСКПОЗ(ГПР("我";$D$15:D$15;1);$A:$A;)):$A$1048576;)+ПОИСКПОЗ(ГПР("我";$D$15:D$15;1);$A:$A;)-1);)+ПОИСКПОЗ(ГПР("我";$D$15:D$15;1);$A:$A;)-1;ПОИСКПОЗ($B17;ИНДЕКС($1:$1048576;ПОИСКПОЗ(ГПР("我";$D$15:D$15;1);$A:$A;)+1;);));"")
она конечно не красива, но зато смешнее других.

Автор - Nic70y
Дата добавления - 23.01.2019 в 19:09
bmv98rus Дата: Среда, 23.01.2019, 20:53 | Сообщение № 4
Группа: Проверенные
Ранг: Старожил
Сообщений: 2370
Репутация: 411 ±
Замечаний: 20% ±

Excel 2013/2016
ничего не ищем, бьем прицельно
Код
=INDEX($B:$I;INT((COLUMN()-4)/4)*7+MOD(COLUMN();4)+3;$B17)

но есть чувствительность к расположению элементов, зато быстро :-)


Замечательный медведь, процентов на 20.

Сообщение отредактировал bmv98rus - Среда, 23.01.2019, 21:20
 
Ответить
Сообщениеничего не ищем, бьем прицельно
Код
=INDEX($B:$I;INT((COLUMN()-4)/4)*7+MOD(COLUMN();4)+3;$B17)

но есть чувствительность к расположению элементов, зато быстро :-)

Автор - bmv98rus
Дата добавления - 23.01.2019 в 20:53
bezproigricha Дата: Четверг, 24.01.2019, 09:30 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Доброго времени суток!
Огромное спасибо!
Вы лучшие!
Всех благ вам!
 
Ответить
СообщениеДоброго времени суток!
Огромное спасибо!
Вы лучшие!
Всех благ вам!

Автор - bezproigricha
Дата добавления - 24.01.2019 в 09:30
Мир MS Excel » Вопросы и решения » Вопросы по Excel » формула для заполнения данными из двух горизонтальных таблиц (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!