Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/вычисление при указании наименования из опред. огран. списка - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » вычисление при указании наименования из опред. огран. списка (Формулы/Formulas)
вычисление при указании наименования из опред. огран. списка
badiv Дата: Понедельник, 28.01.2019, 08:53 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 9
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Осуществление вычислений при указании наименования из определенного ограниченного списка

Здравствуйте,

не вижу ошибку, не силен в экселе ...прошу помощи
задача:
всего товаров 15 штук в раскрывающейся ячейке F3 при выборе определенных товаров выполняется формула
пример:
если я выбираю товары в ячейке F3 (файл прикладываю) то есть либо товар1 либо товар9 либо товар 10 либо товар14 то должна выполнится формула 10*AB3+7*T3 и результат записать в ячейке Z3,
если нет то есть из всего списка выбран другой те отличается (от товар1,9,10,12,14) например товар2 то в ячейке Z3 должна записаться прочерк "-"

весь список представлен в ячейке F3 (чтобы не мешался расположен на другом листе) и можно выбрать любое значение из этого списка:
(товар1)
(товар2)
(товар3)
(товар4)
(товар5)
(товар6)
(товар7)
(товар8)
(товар9)
(товар10)
(товар11)
(товар12)
(товар13)
(товар14)
(товар15)

расчет, результат выводится в той же строке в ячейке Z3

проверка: при выборе в F3 либо товар1 либо товар9 либо товар 10 либо товар14 итог в Z3=938,6 иначе результат прочерк
К сообщению приложен файл: 2299182.xlsx(15.4 Kb)
 
Ответить
СообщениеОсуществление вычислений при указании наименования из определенного ограниченного списка

Здравствуйте,

не вижу ошибку, не силен в экселе ...прошу помощи
задача:
всего товаров 15 штук в раскрывающейся ячейке F3 при выборе определенных товаров выполняется формула
пример:
если я выбираю товары в ячейке F3 (файл прикладываю) то есть либо товар1 либо товар9 либо товар 10 либо товар14 то должна выполнится формула 10*AB3+7*T3 и результат записать в ячейке Z3,
если нет то есть из всего списка выбран другой те отличается (от товар1,9,10,12,14) например товар2 то в ячейке Z3 должна записаться прочерк "-"

весь список представлен в ячейке F3 (чтобы не мешался расположен на другом листе) и можно выбрать любое значение из этого списка:
(товар1)
(товар2)
(товар3)
(товар4)
(товар5)
(товар6)
(товар7)
(товар8)
(товар9)
(товар10)
(товар11)
(товар12)
(товар13)
(товар14)
(товар15)

расчет, результат выводится в той же строке в ячейке Z3

проверка: при выборе в F3 либо товар1 либо товар9 либо товар 10 либо товар14 итог в Z3=938,6 иначе результат прочерк

Автор - badiv
Дата добавления - 28.01.2019 в 08:53
китин Дата: Понедельник, 28.01.2019, 08:57 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 5308
Репутация: 834 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
вдруг правильно?
Код
=ЕСЛИ(ИЛИ(F3="(товар1)";F3="(товар9)";F3="(товар10)";F3="(товар12)";F3="(товар14)");10*AB3+7*T3;"-")

со скбками напутал. формулу перевложил
К сообщению приложен файл: badiv.xlsx(15.4 Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщениевдруг правильно?
Код
=ЕСЛИ(ИЛИ(F3="(товар1)";F3="(товар9)";F3="(товар10)";F3="(товар12)";F3="(товар14)");10*AB3+7*T3;"-")

со скбками напутал. формулу перевложил

Автор - китин
Дата добавления - 28.01.2019 в 08:57
vikttur Дата: Понедельник, 28.01.2019, 10:12 | Сообщение № 3
Группа: Друзья
Ранг: Старожил
Сообщений: 2895
Репутация: 519 ±
Замечаний: 0% ±

Код
=ЕСЛИ(ИЛИ(F3={"(товар1)";"(товар9)";"(товар10)";"(товар12)";"(товар14)"});10*AB3+7*T3;"-")
 
Ответить
Сообщение
Код
=ЕСЛИ(ИЛИ(F3={"(товар1)";"(товар9)";"(товар10)";"(товар12)";"(товар14)"});10*AB3+7*T3;"-")

Автор - vikttur
Дата добавления - 28.01.2019 в 10:12
badiv Дата: Понедельник, 28.01.2019, 11:31 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 9
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
спасибо большое, все работает hands
 
Ответить
Сообщениеспасибо большое, все работает hands

Автор - badiv
Дата добавления - 28.01.2019 в 11:31
badiv Дата: Понедельник, 28.01.2019, 11:33 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 9
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
=ЕСЛИ(ИЛИ(F3={"(товар1)";"(товар9)";"(товар10)";"(товар12)";"(товар14)"});10*AB3+7*T3;"-")

и этот вариант работает
спасибо за помощь очень благодарен
 
Ответить
Сообщение
=ЕСЛИ(ИЛИ(F3={"(товар1)";"(товар9)";"(товар10)";"(товар12)";"(товар14)"});10*AB3+7*T3;"-")

и этот вариант работает
спасибо за помощь очень благодарен

Автор - badiv
Дата добавления - 28.01.2019 в 11:33
Мир MS Excel » Вопросы и решения » Вопросы по Excel » вычисление при указании наименования из опред. огран. списка (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!