Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Подставлять значения по определенным параметрам - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подставлять значения по определенным параметрам (Формулы/Formulas)
Подставлять значения по определенным параметрам
zickland Дата: Понедельник, 28.01.2019, 17:10 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 9
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Здравствуйте!
Данные на листе РАСЧЕТ в ячейки (Дата, Время, кол-во) заносятся руками!
В диапазон F3:F32 на листе РАСЧЕТ нужно подставить значение из диапазона D4:D100 листа КУРС, но они должны соответствовать времени и дате!
Если данные внесены до 13:45, то в ячейку F листа РАСЧЕТ должны подставляться данные ячейки D листа КУРС прошлого дня которые выгрузились 18:30!
Если после 13:45, то данные этого дня которые выгрузились сегодня!
К сообщению приложен файл: 1426133.xlsx(21.9 Kb)
 
Ответить
СообщениеЗдравствуйте!
Данные на листе РАСЧЕТ в ячейки (Дата, Время, кол-во) заносятся руками!
В диапазон F3:F32 на листе РАСЧЕТ нужно подставить значение из диапазона D4:D100 листа КУРС, но они должны соответствовать времени и дате!
Если данные внесены до 13:45, то в ячейку F листа РАСЧЕТ должны подставляться данные ячейки D листа КУРС прошлого дня которые выгрузились 18:30!
Если после 13:45, то данные этого дня которые выгрузились сегодня!

Автор - zickland
Дата добавления - 28.01.2019 в 17:10
Nic70y Дата: Понедельник, 28.01.2019, 19:29 | Сообщение № 2
Группа: Друзья
Ранг: Экселист
Сообщений: 5601
Репутация: 1224 ±
Замечаний: 0% ±

ru13;10;03
Код
=ИНДЕКС(КУРС!D:D;ПОИСКПОЗ(D3;КУРС!C:C;-1))
вдруг правильно ©
апдэйт
Код
=--ПОДСТАВИТЬ(ИНДЕКС(КУРС!D:D;ПОИСКПОЗ(D3;КУРС!C:C;-1));".";ПСТР(7/8;2;1))


ЯД(poison) 41001841029809

Сообщение отредактировал Nic70y - Понедельник, 28.01.2019, 19:31
 
Ответить
Сообщение
Код
=ИНДЕКС(КУРС!D:D;ПОИСКПОЗ(D3;КУРС!C:C;-1))
вдруг правильно ©
апдэйт
Код
=--ПОДСТАВИТЬ(ИНДЕКС(КУРС!D:D;ПОИСКПОЗ(D3;КУРС!C:C;-1));".";ПСТР(7/8;2;1))

Автор - Nic70y
Дата добавления - 28.01.2019 в 19:29
zickland Дата: Понедельник, 28.01.2019, 19:51 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 9
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Nic70y, что-то не то! Подставляется самое первое значение во все ячейки!
К сообщению приложен файл: 2519992.xlsx(22.9 Kb)
 
Ответить
СообщениеNic70y, что-то не то! Подставляется самое первое значение во все ячейки!

Автор - zickland
Дата добавления - 28.01.2019 в 19:51
Nic70y Дата: Понедельник, 28.01.2019, 19:55 | Сообщение № 4
Группа: Друзья
Ранг: Экселист
Сообщений: 5601
Репутация: 1224 ±
Замечаний: 0% ±

ru13;10;03
да, не заметил, "формат" времени разный (до 8 строки с датой, далее нет)
Код
=--ПОДСТАВИТЬ(ИНДЕКС(КУРС!D:D;ПОИСКПОЗ(C3+ОСТАТ(D3;1);КУРС!C:C;-1));".";ПСТР(7/8;2;1))


ЯД(poison) 41001841029809
 
Ответить
Сообщениеда, не заметил, "формат" времени разный (до 8 строки с датой, далее нет)
Код
=--ПОДСТАВИТЬ(ИНДЕКС(КУРС!D:D;ПОИСКПОЗ(C3+ОСТАТ(D3;1);КУРС!C:C;-1));".";ПСТР(7/8;2;1))

Автор - Nic70y
Дата добавления - 28.01.2019 в 19:55
zickland Дата: Понедельник, 28.01.2019, 21:57 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 9
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Nic70y, извиняюсь за опечатку! некорректно были заполнены столбцы с датой и временем! Я все исправил!
Но все равно, не совсем то! Данные заполняются без учета времени когда был выгружен курс доллара!
Например 21.01.2019 в 11:50 в ячейке курс доллара должен отображаться курс 66,2416 - это курс прошлого дня (рабочего дня), после 18:30!
22.01.2019 в 14:10 должен отображаться курс 66,5301 - это курс этого дня после 13:45!
Смотреть файл к этому сообщению!
К сообщению приложен файл: 3194618.xlsx(23.9 Kb)
 
Ответить
СообщениеNic70y, извиняюсь за опечатку! некорректно были заполнены столбцы с датой и временем! Я все исправил!
Но все равно, не совсем то! Данные заполняются без учета времени когда был выгружен курс доллара!
Например 21.01.2019 в 11:50 в ячейке курс доллара должен отображаться курс 66,2416 - это курс прошлого дня (рабочего дня), после 18:30!
22.01.2019 в 14:10 должен отображаться курс 66,5301 - это курс этого дня после 13:45!
Смотреть файл к этому сообщению!

Автор - zickland
Дата добавления - 28.01.2019 в 21:57
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подставлять значения по определенным параметрам (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!