Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Таблица,артикул,дата - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Таблица,артикул,дата (Сводные таблицы/Pivot Table)
Таблица,артикул,дата
maribeli Дата: Четверг, 31.01.2019, 10:45 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Здравствуйте! Помогите пожалуйста разобраться.

Есть 2 таблицы со столбцами:
- Таблица1. Столбцы: Артикул.
- Таблица2. Столбцы: Артикул – дата

Необходимо:
- дополнить Таблицу1 столбцом Дата из таблицы 2. Желательно не изменять порядок строк в Таблице1.

Проблема:
У каждого артикула своя дата. Необходимо решение, которое позволит последовательно сравнивать строки по Артикулам и присваивать соответствующую Дату. Количество строк в Таблица1 и в Таблица2 не совпадает, то есть не всем Артикулам Таблицы1 должна быть присвоена Дата.
Пример в таблице эксель прилагаю.

При этом все строки с датами из Таблицы2 должны быть отражены в Таблице1, то есть кол-во ячеек с датами в Таблице1 = кол-ву ячеек с датами в Таблице 2.

Жду помощи, спасибо!
К сообщению приложен файл: vopros_exel.xlsx(22.7 Kb) · vopros_exel_nuz.xlsx(23.6 Kb)
 
Ответить
СообщениеЗдравствуйте! Помогите пожалуйста разобраться.

Есть 2 таблицы со столбцами:
- Таблица1. Столбцы: Артикул.
- Таблица2. Столбцы: Артикул – дата

Необходимо:
- дополнить Таблицу1 столбцом Дата из таблицы 2. Желательно не изменять порядок строк в Таблице1.

Проблема:
У каждого артикула своя дата. Необходимо решение, которое позволит последовательно сравнивать строки по Артикулам и присваивать соответствующую Дату. Количество строк в Таблица1 и в Таблица2 не совпадает, то есть не всем Артикулам Таблицы1 должна быть присвоена Дата.
Пример в таблице эксель прилагаю.

При этом все строки с датами из Таблицы2 должны быть отражены в Таблице1, то есть кол-во ячеек с датами в Таблице1 = кол-ву ячеек с датами в Таблице 2.

Жду помощи, спасибо!

Автор - maribeli
Дата добавления - 31.01.2019 в 10:45
китин Дата: Четверг, 31.01.2019, 11:26 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 5308
Репутация: 834 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
Добрый день.
формула массива
Код
=ЕСЛИОШИБКА(ИНДЕКС(Таблица2!$B$3:$B$364;НАИМЕНЬШИЙ(ЕСЛИ(Таблица2!$A$3:$A$364='Таблица 1'!$A3;СТРОКА(Таблица2!$B$3:$B$364)-2);СЧЁТЕСЛИ($A$3:A3;'Таблица 1'!$A3)));"")
К сообщению приложен файл: maribeli.xlsx(43.8 Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
СообщениеДобрый день.
формула массива
Код
=ЕСЛИОШИБКА(ИНДЕКС(Таблица2!$B$3:$B$364;НАИМЕНЬШИЙ(ЕСЛИ(Таблица2!$A$3:$A$364='Таблица 1'!$A3;СТРОКА(Таблица2!$B$3:$B$364)-2);СЧЁТЕСЛИ($A$3:A3;'Таблица 1'!$A3)));"")

Автор - китин
Дата добавления - 31.01.2019 в 11:26
maribeli Дата: Четверг, 31.01.2019, 16:09 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
китин, спасибо большое!Я бы сама ни за что не справилась. Благодарю за помощь!
 
Ответить
Сообщениекитин, спасибо большое!Я бы сама ни за что не справилась. Благодарю за помощь!

Автор - maribeli
Дата добавления - 31.01.2019 в 16:09
_Boroda_ Дата: Четверг, 31.01.2019, 16:34 | Сообщение № 4
Группа: Модераторы
Ранг: Местный житель
Сообщений: 14084
Репутация: 5684 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Еще массивный вариант
Код
=ЕСЛИОШИБКА(НАИМЕНЬШИЙ((A3=Таблица2!A$5:A$999)*Таблица2!B$5:B$999;СЧЁТЕСЛИ(Таблица2!A$5:A$999;"<>"&A3)+СЧЁТЕСЛИ(A$3:A3;A3));"")
К сообщению приложен файл: 8534950.xlsx(24.1 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеЕще массивный вариант
Код
=ЕСЛИОШИБКА(НАИМЕНЬШИЙ((A3=Таблица2!A$5:A$999)*Таблица2!B$5:B$999;СЧЁТЕСЛИ(Таблица2!A$5:A$999;"<>"&A3)+СЧЁТЕСЛИ(A$3:A3;A3));"")

Автор - _Boroda_
Дата добавления - 31.01.2019 в 16:34
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Таблица,артикул,дата (Сводные таблицы/Pivot Table)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!