Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Можно ли выцепить из ячейки цифры и отдельно их суммировать? - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Можно ли выцепить из ячейки цифры и отдельно их суммировать? (Формулы/Formulas)
Можно ли выцепить из ячейки цифры и отдельно их суммировать?
drezna Дата: Четверг, 31.01.2019, 15:16 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Приветствую....

Долго рассматривал варианты по данной теме, но понял что ничего полезного для моего варианта из этого я не извлеку :-(

Поэтому сразу прям вот конкретный пример...

Исходные данные - ячейки с внесенными в нее цифрами допустим через слэши (хотя тут варианты могут рассматриваться любые - пробелы, перевод строки и т.д.)
В конкретном случае - суммы оплат БЕЗНДС/СНДС (ну или для более продвинутого варианта БЕЗНДС/НДС/СНДС)...
Порядок цифр может быть разным (от рубля до миллионов)... Плюс ко всему будут как целые числа, так и с десятыми...

Необходимо в итоге посчитать из этих ячеек общую сумму БЕЗНДС и общую сумму СНДС

10/12
100/120
1/1,2
1000/1200

При необходимости можно рассматривать другой вариант ввода данных для облегчения задачи
например вместо 100/120 использовать /100/120/ или *100/120* ну и т.д.

В идеале - решить задачу стандартными функциями без использования макросов...

Возможно такое???

Спасибо!
К сообщению приложен файл: 2833571.xlsx(11.8 Kb)


Сообщение отредактировал drezna - Четверг, 31.01.2019, 15:34
 
Ответить
СообщениеПриветствую....

Долго рассматривал варианты по данной теме, но понял что ничего полезного для моего варианта из этого я не извлеку :-(

Поэтому сразу прям вот конкретный пример...

Исходные данные - ячейки с внесенными в нее цифрами допустим через слэши (хотя тут варианты могут рассматриваться любые - пробелы, перевод строки и т.д.)
В конкретном случае - суммы оплат БЕЗНДС/СНДС (ну или для более продвинутого варианта БЕЗНДС/НДС/СНДС)...
Порядок цифр может быть разным (от рубля до миллионов)... Плюс ко всему будут как целые числа, так и с десятыми...

Необходимо в итоге посчитать из этих ячеек общую сумму БЕЗНДС и общую сумму СНДС

10/12
100/120
1/1,2
1000/1200

При необходимости можно рассматривать другой вариант ввода данных для облегчения задачи
например вместо 100/120 использовать /100/120/ или *100/120* ну и т.д.

В идеале - решить задачу стандартными функциями без использования макросов...

Возможно такое???

Спасибо!

Автор - drezna
Дата добавления - 31.01.2019 в 15:16
sboy Дата: Четверг, 31.01.2019, 15:20 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 2538
Репутация: 717 ±
Замечаний: 0% ±

Excel 2010
Добрый день.
Приложите файл-пример со всеми возможными вариациями и результатом, который должен получиться


Яндекс: 410016850021169
 
Ответить
СообщениеДобрый день.
Приложите файл-пример со всеми возможными вариациями и результатом, который должен получиться

Автор - sboy
Дата добавления - 31.01.2019 в 15:20
drezna Дата: Четверг, 31.01.2019, 15:35 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Приложите файл-пример со всеми возможными вариациями и результатом


сорри, конечно файл забыл - исправился....
К сообщению приложен файл: 2866910.xlsx(11.8 Kb)
 
Ответить
Сообщение
Приложите файл-пример со всеми возможными вариациями и результатом


сорри, конечно файл забыл - исправился....

Автор - drezna
Дата добавления - 31.01.2019 в 15:35
_Boroda_ Дата: Четверг, 31.01.2019, 15:40 | Сообщение № 4
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15242
Репутация: 5987 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так нужно?
Код
=СУММПРОИЗВ(--ПСТР(ПОДСТАВИТЬ($I13:$L13;"/";ПОВТОР(" ";99));99*СТОЛБЕЦ(A13)-98;99))

Код
=СУММПРОИЗВ(--ПСТР(ПОДСТАВИТЬ(I$13:I$14;"/";ПОВТОР(" ";99));99*СТРОКА(I1)-98;99))

Подходит и для 1/2/3. Да и для любого 1/2/3/.../n
К сообщению приложен файл: 2866910_1.xlsx(12.0 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак нужно?
Код
=СУММПРОИЗВ(--ПСТР(ПОДСТАВИТЬ($I13:$L13;"/";ПОВТОР(" ";99));99*СТОЛБЕЦ(A13)-98;99))

Код
=СУММПРОИЗВ(--ПСТР(ПОДСТАВИТЬ(I$13:I$14;"/";ПОВТОР(" ";99));99*СТРОКА(I1)-98;99))

Подходит и для 1/2/3. Да и для любого 1/2/3/.../n

Автор - _Boroda_
Дата добавления - 31.01.2019 в 15:40
drezna Дата: Четверг, 31.01.2019, 16:01 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Подходит и для 1/2/3. Да и для любого 1/2/3/.../n


ага.... именно это....
спасибо огромное!!!

тут кстати параллельно подсказали и другой вариант (файл прилагаю)...

Цитата
{=СУММ(--ЛЕВБ(A1:A4;ПОИСК("/";A1:A4)-1))}

Цитата
{=СУММ(--ПСТР(A1:A4;ПОИСК("/";A1:A4)+1;99))}


протестирую оба на возможные глюки...
но Ваш вариант в моем случае мне кажется удобнее из-за универсальности "... для 1/2/3. Да и для любого 1/2/3/.../n..."
К сообщению приложен файл: __.xlsx(10.3 Kb)
 
Ответить
Сообщение
Подходит и для 1/2/3. Да и для любого 1/2/3/.../n


ага.... именно это....
спасибо огромное!!!

тут кстати параллельно подсказали и другой вариант (файл прилагаю)...

Цитата
{=СУММ(--ЛЕВБ(A1:A4;ПОИСК("/";A1:A4)-1))}

Цитата
{=СУММ(--ПСТР(A1:A4;ПОИСК("/";A1:A4)+1;99))}


протестирую оба на возможные глюки...
но Ваш вариант в моем случае мне кажется удобнее из-за универсальности "... для 1/2/3. Да и для любого 1/2/3/.../n..."

Автор - drezna
Дата добавления - 31.01.2019 в 16:01
_Boroda_ Дата: Четверг, 31.01.2019, 16:06 | Сообщение № 6
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15242
Репутация: 5987 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
тут кстати параллельно подсказали

Подсказали где? Если на другом форуме, то перечитайте еще раз пункт 5s Правил форума и сделайте то, про что там говорится. А если не на другом форуме, то это просто в качестве информации

* Да, вижу, на Планете (как минимум, больше не искал). Там тоже нужно ссылку сюда дать (в тамошних Правилах тоже про это написано)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщение
тут кстати параллельно подсказали

Подсказали где? Если на другом форуме, то перечитайте еще раз пункт 5s Правил форума и сделайте то, про что там говорится. А если не на другом форуме, то это просто в качестве информации

* Да, вижу, на Планете (как минимум, больше не искал). Там тоже нужно ссылку сюда дать (в тамошних Правилах тоже про это написано)

Автор - _Boroda_
Дата добавления - 31.01.2019 в 16:06
drezna Дата: Четверг, 31.01.2019, 16:21 | Сообщение № 7
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
перечитайте еще раз пункт 5s Правил форума и сделайте то


перечитал... но... там же:
s - не предоставлять ссылки на другие ресурсы в том случае, если тема была создана Вами не только на форуме сайта "Мир MS Excel"

я же вроде ссылку не давал как раз...

* Да, вижу, на Планете (как минимум, больше не искал). Там тоже нужно ссылку сюда дать (в тамошних Правилах тоже про это написано)


да - там была тема... больше нигде... но Вы же наоборот просите ссылку дать...

не понял честно говоря (соори - я тут новичок)....

так в итоге что надо сделать-то, чтобы не нарушать?
 
Ответить
Сообщение
перечитайте еще раз пункт 5s Правил форума и сделайте то


перечитал... но... там же:
s - не предоставлять ссылки на другие ресурсы в том случае, если тема была создана Вами не только на форуме сайта "Мир MS Excel"

я же вроде ссылку не давал как раз...

* Да, вижу, на Планете (как минимум, больше не искал). Там тоже нужно ссылку сюда дать (в тамошних Правилах тоже про это написано)


да - там была тема... больше нигде... но Вы же наоборот просите ссылку дать...

не понял честно говоря (соори - я тут новичок)....

так в итоге что надо сделать-то, чтобы не нарушать?

Автор - drezna
Дата добавления - 31.01.2019 в 16:21
drezna Дата: Четверг, 31.01.2019, 16:24 | Сообщение № 8
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
перечитал... но... там же:
s - не предоставлять ссылки на другие ресурсы в том случае, если тема была создана Вами не только на форуме сайта "Мир MS Excel"


а.... запутался совсем.... это же ЗАПРЕЩЕНО не предоставлять ссылки....

исправляюсь...

паралелльное решение подсказано на странице
 
Ответить
Сообщение
перечитал... но... там же:
s - не предоставлять ссылки на другие ресурсы в том случае, если тема была создана Вами не только на форуме сайта "Мир MS Excel"


а.... запутался совсем.... это же ЗАПРЕЩЕНО не предоставлять ссылки....

исправляюсь...

паралелльное решение подсказано на странице

Автор - drezna
Дата добавления - 31.01.2019 в 16:24
_Boroda_ Дата: Четверг, 31.01.2019, 16:25 | Сообщение № 9
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15242
Репутация: 5987 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Вот теперь все отлично


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеВот теперь все отлично

Автор - _Boroda_
Дата добавления - 31.01.2019 в 16:25
drezna Дата: Четверг, 31.01.2019, 17:08 | Сообщение № 10
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Подходит и для 1/2/3. Да и для любого 1/2/3/.../n


как только одна из ячеек оказывается пустой (в моем случае это может быть) - расчет ломается...
это получается надо функцией ЕСЛИ играться? или изящнее решение есть?
 
Ответить
Сообщение
Подходит и для 1/2/3. Да и для любого 1/2/3/.../n


как только одна из ячеек оказывается пустой (в моем случае это может быть) - расчет ломается...
это получается надо функцией ЕСЛИ играться? или изящнее решение есть?

Автор - drezna
Дата добавления - 31.01.2019 в 17:08
AlexM Дата: Четверг, 31.01.2019, 18:53 | Сообщение № 11
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3842
Репутация: 969 ±
Замечаний: 0% ±

Excel 2003
расчет ломается

Дополненная протягиваемая формула Александра
Код
=СУММПРОИЗВ(--ПСТР(ПОДСТАВИТЬ(0&I$13:I$14&"/0";"/";ПОВТОР(" ";99));99*СТРОКА(I1)-98;99))
Для сумм до дроби
Код
=СУММПРОИЗВ(--ЛЕВБ(ПОДСТАВИТЬ(0&I13:I14;"/";"     ");5))
и после
Код
=СУММПРОИЗВ(--ПРАВБ(ПОДСТАВИТЬ(0&I13:I14;"/";"     ");5))



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.


Сообщение отредактировал AlexM - Четверг, 31.01.2019, 19:13
 
Ответить
Сообщение
расчет ломается

Дополненная протягиваемая формула Александра
Код
=СУММПРОИЗВ(--ПСТР(ПОДСТАВИТЬ(0&I$13:I$14&"/0";"/";ПОВТОР(" ";99));99*СТРОКА(I1)-98;99))
Для сумм до дроби
Код
=СУММПРОИЗВ(--ЛЕВБ(ПОДСТАВИТЬ(0&I13:I14;"/";"     ");5))
и после
Код
=СУММПРОИЗВ(--ПРАВБ(ПОДСТАВИТЬ(0&I13:I14;"/";"     ");5))

Автор - AlexM
Дата добавления - 31.01.2019 в 18:53
drezna Дата: Пятница, 01.02.2019, 11:17 | Сообщение № 12
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Дополненная протягиваемая формула Александра


ух ты.... ну вот теперь вообще супер!!!! спасибо!!!
 
Ответить
Сообщение
Дополненная протягиваемая формула Александра


ух ты.... ну вот теперь вообще супер!!!! спасибо!!!

Автор - drezna
Дата добавления - 01.02.2019 в 11:17
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Можно ли выцепить из ячейки цифры и отдельно их суммировать? (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!