Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Вытащить разбросанные данные из сложной таблицы - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Вытащить разбросанные данные из сложной таблицы (Формулы/Formulas)
Вытащить разбросанные данные из сложной таблицы
OYakshe Дата: Пятница, 01.02.2019, 11:40 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 14
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Добрый день. Помогите пожалуйста справиться с задачей. Есть иходная таблица с метеоданными. За сутки долны быть сделаны восемь наблюдений. По факту делается одно иногда встречается второе измерение, тогда в стобце минимальная температура(Tn) нужно значение самой низкой температуры, соответственно в столбце максимальная температура (Tx) значение максимальной температуры. Из столбца количество осадко(RRR) требуется значение количество осадков. Мне нужна таблица, где будет дата измерения, минимальная, максимальная температура и количество осадков.
К сообщению приложен файл: 2228576.xlsx(16.2 Kb)
 
Ответить
СообщениеДобрый день. Помогите пожалуйста справиться с задачей. Есть иходная таблица с метеоданными. За сутки долны быть сделаны восемь наблюдений. По факту делается одно иногда встречается второе измерение, тогда в стобце минимальная температура(Tn) нужно значение самой низкой температуры, соответственно в столбце максимальная температура (Tx) значение максимальной температуры. Из столбца количество осадко(RRR) требуется значение количество осадков. Мне нужна таблица, где будет дата измерения, минимальная, максимальная температура и количество осадков.

Автор - OYakshe
Дата добавления - 01.02.2019 в 11:40
китин Дата: Пятница, 01.02.2019, 12:01 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 5308
Репутация: 834 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
Добрый день. так надо? формула массива
Код
=МАКС(ЕСЛИ(ЦЕЛОЕ($A$59)=ЦЕЛОЕ($A$8:$A$55);$O$8:$O$55))
К сообщению приложен файл: OYakshe.xlsx(17.6 Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
СообщениеДобрый день. так надо? формула массива
Код
=МАКС(ЕСЛИ(ЦЕЛОЕ($A$59)=ЦЕЛОЕ($A$8:$A$55);$O$8:$O$55))

Автор - китин
Дата добавления - 01.02.2019 в 12:01
OYakshe Дата: Пятница, 01.02.2019, 12:20 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 14
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
а можете в примере сразу несколько дней заполнить? Остальные даты у меня не получаются :(
 
Ответить
Сообщениеа можете в примере сразу несколько дней заполнить? Остальные даты у меня не получаются :(

Автор - OYakshe
Дата добавления - 01.02.2019 в 12:20
_Boroda_ Дата: Пятница, 01.02.2019, 12:24 | Сообщение № 4
Группа: Модераторы
Ранг: Местный житель
Сообщений: 14089
Репутация: 5686 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Интересно, а зимой в Карасуке снег есть? Не, я-то знаю, что есть, это намек Игорю
Код
=МИН(--ТЕКСТ(ЕСЛИ(ОТБР(A59)=ОТБР(A$8:A$55);O$8:O$55&"");"0,0;-0,0;0;\9\9"))

Код
=МАКС(--ТЕКСТ(ЕСЛИ(ОТБР(A59)=ОТБР(A$8:A$55);P$8:P$55&"");"0,0;-0,0;0;-\9\9"))

Код
=СУММ(ЕСЛИ(ОТБР(A59)=ОТБР(A$8:A$55);X$8:X$55))
К сообщению приложен файл: 2228576_1.xlsx(16.8 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеИнтересно, а зимой в Карасуке снег есть? Не, я-то знаю, что есть, это намек Игорю
Код
=МИН(--ТЕКСТ(ЕСЛИ(ОТБР(A59)=ОТБР(A$8:A$55);O$8:O$55&"");"0,0;-0,0;0;\9\9"))

Код
=МАКС(--ТЕКСТ(ЕСЛИ(ОТБР(A59)=ОТБР(A$8:A$55);P$8:P$55&"");"0,0;-0,0;0;-\9\9"))

Код
=СУММ(ЕСЛИ(ОТБР(A59)=ОТБР(A$8:A$55);X$8:X$55))

Автор - _Boroda_
Дата добавления - 01.02.2019 в 12:24
китин Дата: Пятница, 01.02.2019, 12:28 | Сообщение № 5
Группа: Модераторы
Ранг: Экселист
Сообщений: 5308
Репутация: 834 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
несколько дней заполнить?

легко :D
Код
=МАКС(ЕСЛИ(ЦЕЛОЕ($A59)=ЦЕЛОЕ($A$8:$A$55);$O$8:$O$55))

там надо было по другому диапазоны закрепить
К сообщению приложен файл: _OYakshe_333.xlsx(18.0 Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщение
несколько дней заполнить?

легко :D
Код
=МАКС(ЕСЛИ(ЦЕЛОЕ($A59)=ЦЕЛОЕ($A$8:$A$55);$O$8:$O$55))

там надо было по другому диапазоны закрепить

Автор - китин
Дата добавления - 01.02.2019 в 12:28
OYakshe Дата: Пятница, 01.02.2019, 21:39 | Сообщение № 6
Группа: Пользователи
Ранг: Новичок
Сообщений: 14
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Спасибо Вам огромное, о боги экселя! Очень выручили! :)
 
Ответить
СообщениеСпасибо Вам огромное, о боги экселя! Очень выручили! :)

Автор - OYakshe
Дата добавления - 01.02.2019 в 21:39
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Вытащить разбросанные данные из сложной таблицы (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!