Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Дополнить повторяющиеся строки - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Дополнить повторяющиеся строки (Формулы/Formulas)
Дополнить повторяющиеся строки
JasonD Дата: Воскресенье, 03.02.2019, 18:20 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Имеются 2 экселевских файла

в 1м файле колонки:
email;телефон:имя;страна;город

во 2м файле колонки:
email;адрес;дата_рождения;индекс

Как видите в 1м и 2м файле 1 колонка "email" одинаковая - необходимо для одинаковых емейлов обьединить все колонки

Проще говоря, если в файле емейлы совпали, то дополняем их информацией адрес;дата_рождения;индекс
 
Ответить
СообщениеИмеются 2 экселевских файла

в 1м файле колонки:
email;телефон:имя;страна;город

во 2м файле колонки:
email;адрес;дата_рождения;индекс

Как видите в 1м и 2м файле 1 колонка "email" одинаковая - необходимо для одинаковых емейлов обьединить все колонки

Проще говоря, если в файле емейлы совпали, то дополняем их информацией адрес;дата_рождения;индекс

Автор - JasonD
Дата добавления - 03.02.2019 в 18:20
ASWP Дата: Воскресенье, 03.02.2019, 18:39 | Сообщение № 2
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 183
Репутация: 23 ±
Замечаний: 0% ±

Excel 2007
Как видите в 1м и 2м файле 1 колонка "email" одинаковая - необходимо для одинаковых емейлов обьединить все колонки

Нет, не видим, где файлы с примерами?


я знаю что ничего не знаю, но другие не знают и этого
 
Ответить
Сообщение
Как видите в 1м и 2м файле 1 колонка "email" одинаковая - необходимо для одинаковых емейлов обьединить все колонки

Нет, не видим, где файлы с примерами?

Автор - ASWP
Дата добавления - 03.02.2019 в 18:39
JasonD Дата: Воскресенье, 03.02.2019, 18:50 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Пример прикрепил

email;телефон:имя;страна;город
2 из 4х емейлов совпадают, вот нужно из совпавших емейлов добавить информацию , что бы добавилась информация о клиенту и получилось1 полная строка

email;телефон:имя;страна;город;адрес;дата_рождения;индекс
К сообщению приложен файл: testExcel.xlsx(9.1 Kb)
 
Ответить
СообщениеПример прикрепил

email;телефон:имя;страна;город
2 из 4х емейлов совпадают, вот нужно из совпавших емейлов добавить информацию , что бы добавилась информация о клиенту и получилось1 полная строка

email;телефон:имя;страна;город;адрес;дата_рождения;индекс

Автор - JasonD
Дата добавления - 03.02.2019 в 18:50
Pelena Дата: Воскресенье, 03.02.2019, 18:57 | Сообщение № 4
Группа: Админы
Ранг: Местный житель
Сообщений: 14440
Репутация: 3163 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Код
=ЕСЛИОШИБКА(ВПР($A2;$A$10:$D$11;2;0);"")
К сообщению приложен файл: 2727481.xlsx(10.7 Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
Сообщение
Код
=ЕСЛИОШИБКА(ВПР($A2;$A$10:$D$11;2;0);"")

Автор - Pelena
Дата добавления - 03.02.2019 в 18:57
JasonD Дата: Воскресенье, 03.02.2019, 19:40 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Спасибо, на вашем примере работает, но на своем не могу, уж очень много данных, буду еще разбираться, пока не совсем понимаю, как растянули формулу
 
Ответить
СообщениеСпасибо, на вашем примере работает, но на своем не могу, уж очень много данных, буду еще разбираться, пока не совсем понимаю, как растянули формулу

Автор - JasonD
Дата добавления - 03.02.2019 в 19:40
Pelena Дата: Воскресенье, 03.02.2019, 19:44 | Сообщение № 6
Группа: Админы
Ранг: Местный житель
Сообщений: 14440
Репутация: 3163 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Если столбцов много, то можно так записать, тогда и вправо будет протягиваться
Код
=ЕСЛИОШИБКА(ВПР($A2;$A$10:$D$11;СТОЛБЕЦ(B1);0);"")


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеЕсли столбцов много, то можно так записать, тогда и вправо будет протягиваться
Код
=ЕСЛИОШИБКА(ВПР($A2;$A$10:$D$11;СТОЛБЕЦ(B1);0);"")

Автор - Pelena
Дата добавления - 03.02.2019 в 19:44
JasonD Дата: Воскресенье, 03.02.2019, 19:53 | Сообщение № 7
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
спасибо, буду пробовать
 
Ответить
Сообщениеспасибо, буду пробовать

Автор - JasonD
Дата добавления - 03.02.2019 в 19:53
JasonD Дата: Воскресенье, 03.02.2019, 20:21 | Сообщение № 8
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Сорри за оффтоп, все получилось :) 2 вариант сработал лучше
Pelena, если у вас есть Web Money, то с удовольствием подкинул бы $ на пиво :)
 
Ответить
СообщениеСорри за оффтоп, все получилось :) 2 вариант сработал лучше
Pelena, если у вас есть Web Money, то с удовольствием подкинул бы $ на пиво :)

Автор - JasonD
Дата добавления - 03.02.2019 в 20:21
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Дополнить повторяющиеся строки (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!