Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/посчитать количество рабочих часов - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 2
  • 1
  • 2
  • »
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » посчитать количество рабочих часов (Формулы/Formulas)
посчитать количество рабочих часов
ГАЙВЕР Дата: Среда, 06.02.2019, 13:47 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 37
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Добрый день. Не получается у меня посчитать общее количество часов в графике сменности, помогите.
К сообщению приложен файл: 7864377.xls(72.5 Kb)


Сообщение отредактировал ГАЙВЕР - Среда, 06.02.2019, 13:51
 
Ответить
СообщениеДобрый день. Не получается у меня посчитать общее количество часов в графике сменности, помогите.

Автор - ГАЙВЕР
Дата добавления - 06.02.2019 в 13:47
krosav4ig Дата: Среда, 06.02.2019, 14:20 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 2031
Репутация: 847 ±
Замечаний: 0% ±

Excel 2007,2010,2013
Добрый день.
Массивная формула
Код
=СУММ(ЕСЛИОШИБКА(--ПСТР(ПОДСТАВИТЬ(D8:AH8;"/";"     ");{1:6};5);))
К сообщению приложен файл: 5742850.xls(83.5 Kb)


email:krosav4ig26@gmail.com WMR R207627035142 WMZ Z821145374535 ЯД 410012026478460
 
Ответить
СообщениеДобрый день.
Массивная формула
Код
=СУММ(ЕСЛИОШИБКА(--ПСТР(ПОДСТАВИТЬ(D8:AH8;"/";"     ");{1:6};5);))

Автор - krosav4ig
Дата добавления - 06.02.2019 в 14:20
ГАЙВЕР Дата: Среда, 06.02.2019, 14:23 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 37
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
krosav4ig, Спасибо вам большое!
 
Ответить
Сообщениеkrosav4ig, Спасибо вам большое!

Автор - ГАЙВЕР
Дата добавления - 06.02.2019 в 14:23
ГАЙВЕР Дата: Среда, 06.02.2019, 14:29 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 37
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
У меня в итоге ноль получается. Наверное из за буквенного обозначения не считает(((
 
Ответить
СообщениеУ меня в итоге ноль получается. Наверное из за буквенного обозначения не считает(((

Автор - ГАЙВЕР
Дата добавления - 06.02.2019 в 14:29
_Boroda_ Дата: Среда, 06.02.2019, 14:38 | Сообщение № 5
Группа: Модераторы
Ранг: Местный житель
Сообщений: 14861
Репутация: 5879 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Еще вариант
Код
=СУММ(ЕСЛИОШИБКА(ДЕНЬ(D8:AH8)+МЕСЯЦ(D8:AH8);))-СЧЁТ(D8:AH8)

Формула массива. Вводится одновременным нажатием Ctrl+Shift+Enter
И еще
Код
=СУММ(ТЕКСТ(D8:AH8;"[>24]Д;;0;\0")+ТЕКСТ(D8:AH8;"[>24]М;;\0;\0"))


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеЕще вариант
Код
=СУММ(ЕСЛИОШИБКА(ДЕНЬ(D8:AH8)+МЕСЯЦ(D8:AH8);))-СЧЁТ(D8:AH8)

Формула массива. Вводится одновременным нажатием Ctrl+Shift+Enter
И еще
Код
=СУММ(ТЕКСТ(D8:AH8;"[>24]Д;;0;\0")+ТЕКСТ(D8:AH8;"[>24]М;;\0;\0"))

Автор - _Boroda_
Дата добавления - 06.02.2019 в 14:38
Светлый Дата: Среда, 06.02.2019, 14:41 | Сообщение № 6
Группа: Проверенные
Ранг: Старожил
Сообщений: 1003
Репутация: 258 ±
Замечаний: 0% ±

Excel 2010
Массивная формула:
Код
=СУММ(ЕСЛИ(ЕЧИСЛО(-ЛЕВБ(D8:AH8));--ПСТР(ПОДСТАВИТЬ(D8:AH8&"/0";"/";"     ");{1:5};5)))
*Чуть покороче.
Код
=СУММ(ЕСЛИ(ЕОШ(-ЛЕВБ(D8:AH8));;--ПСТР(ПОДСТАВИТЬ(D8:AH8&"/0";"/";"     ");{1:5};5)))


Программировать проще, чем писать стихи.

Сообщение отредактировал Светлый - Среда, 06.02.2019, 14:45
 
Ответить
СообщениеМассивная формула:
Код
=СУММ(ЕСЛИ(ЕЧИСЛО(-ЛЕВБ(D8:AH8));--ПСТР(ПОДСТАВИТЬ(D8:AH8&"/0";"/";"     ");{1:5};5)))
*Чуть покороче.
Код
=СУММ(ЕСЛИ(ЕОШ(-ЛЕВБ(D8:AH8));;--ПСТР(ПОДСТАВИТЬ(D8:AH8&"/0";"/";"     ");{1:5};5)))

Автор - Светлый
Дата добавления - 06.02.2019 в 14:41
ГАЙВЕР Дата: Среда, 06.02.2019, 14:44 | Сообщение № 7
Группа: Пользователи
Ранг: Новичок
Сообщений: 37
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Я все Вас благодарю!!!!!!!!!!!!!!!!!!!!!! низкий поклон!
 
Ответить
СообщениеЯ все Вас благодарю!!!!!!!!!!!!!!!!!!!!!! низкий поклон!

Автор - ГАЙВЕР
Дата добавления - 06.02.2019 в 14:44
Janed Дата: Четверг, 28.02.2019, 17:11 | Сообщение № 8
Группа: Пользователи
Ранг: Прохожий
Сообщений: 1
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Уважаемые форумчане и знатоки, прошу помощи!
Нашла и почти разобралась в формуле подсчета рабочих часов между двумя датами. Но нужно добавить дополнительное условие: чтобы формула работала с учетом нестандартной рабочей недели с праздниками (например, "понедельник-четверг" или "понедельник-вторник и четверг-пятница"). Рабочая смена во все рабочие дни одна: с 8:00 до 18:00.
Например, в приложенном файле 08.03 должно считаться нерабочим днем и отсчет времени выполнения задачи должен фактически начинаться с 11.03 8:00.
Сложность еще в том, что могут встречаться рабочие субботы. Пока я вижу вариант прописать в отдельный скрытый лист все нерабочие дни в году и использовать этот диапазон в формуле, но не знаю, как это реализовать.
Буду очень признательна за помощь!
К сообщению приложен файл: weekdays.xlsx(13.1 Kb)
 
Ответить
СообщениеУважаемые форумчане и знатоки, прошу помощи!
Нашла и почти разобралась в формуле подсчета рабочих часов между двумя датами. Но нужно добавить дополнительное условие: чтобы формула работала с учетом нестандартной рабочей недели с праздниками (например, "понедельник-четверг" или "понедельник-вторник и четверг-пятница"). Рабочая смена во все рабочие дни одна: с 8:00 до 18:00.
Например, в приложенном файле 08.03 должно считаться нерабочим днем и отсчет времени выполнения задачи должен фактически начинаться с 11.03 8:00.
Сложность еще в том, что могут встречаться рабочие субботы. Пока я вижу вариант прописать в отдельный скрытый лист все нерабочие дни в году и использовать этот диапазон в формуле, но не знаю, как это реализовать.
Буду очень признательна за помощь!

Автор - Janed
Дата добавления - 28.02.2019 в 17:11
ГАЙВЕР Дата: Среда, 13.03.2019, 08:20 | Сообщение № 9
Группа: Пользователи
Ранг: Новичок
Сообщений: 37
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Подскажите пожалуйста. Как почитать я/н
4/2
чтоб в ячейке итого посчиталось 4 (явочные часы)
 
Ответить
СообщениеПодскажите пожалуйста. Как почитать я/н
4/2
чтоб в ячейке итого посчиталось 4 (явочные часы)

Автор - ГАЙВЕР
Дата добавления - 13.03.2019 в 08:20
китин Дата: Среда, 13.03.2019, 09:00 | Сообщение № 10
Группа: Модераторы
Ранг: Экселист
Сообщений: 5444
Репутация: 870 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
Код
=ПСТР(A1;1;ПОИСК("/";A1)-1)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщение
Код
=ПСТР(A1;1;ПОИСК("/";A1)-1)

Автор - китин
Дата добавления - 13.03.2019 в 09:00
ГАЙВЕР Дата: Среда, 13.03.2019, 09:32 | Сообщение № 11
Группа: Пользователи
Ранг: Новичок
Сообщений: 37
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
китин, У меня так не получается, это формула получается для верхней строки...
К сообщению приложен файл: 3697176.xlsx(11.2 Kb)
 
Ответить
Сообщениекитин, У меня так не получается, это формула получается для верхней строки...

Автор - ГАЙВЕР
Дата добавления - 13.03.2019 в 09:32
_Boroda_ Дата: Среда, 13.03.2019, 10:01 | Сообщение № 12
Группа: Модераторы
Ранг: Местный житель
Сообщений: 14861
Репутация: 5879 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Что нужно в какой ячейке получить и почему?
Может так?
Код
=СЧЁТЕСЛИ(E10:S11;"я/н")


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеЧто нужно в какой ячейке получить и почему?
Может так?
Код
=СЧЁТЕСЛИ(E10:S11;"я/н")

Автор - _Boroda_
Дата добавления - 13.03.2019 в 10:01
ГАЙВЕР Дата: Четверг, 14.03.2019, 14:13 | Сообщение № 13
Группа: Пользователи
Ранг: Новичок
Сообщений: 37
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
_Boroda_, У меня выдает 1, не считает количество часов "Я"


Сообщение отредактировал ГАЙВЕР - Четверг, 14.03.2019, 14:17
 
Ответить
Сообщение_Boroda_, У меня выдает 1, не считает количество часов "Я"

Автор - ГАЙВЕР
Дата добавления - 14.03.2019 в 14:13
_Boroda_ Дата: Четверг, 14.03.2019, 14:30 | Сообщение № 14
Группа: Модераторы
Ранг: Местный житель
Сообщений: 14861
Репутация: 5879 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Я понимаю, файл показывать никому нельзя. И вообще это для слабаков. Без проблем. Присылайте мне на почту билет, я готов через 20 минут вылететь к вам и посмотреть в реале ваш файл


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеЯ понимаю, файл показывать никому нельзя. И вообще это для слабаков. Без проблем. Присылайте мне на почту билет, я готов через 20 минут вылететь к вам и посмотреть в реале ваш файл

Автор - _Boroda_
Дата добавления - 14.03.2019 в 14:30
ГАЙВЕР Дата: Четверг, 14.03.2019, 15:35 | Сообщение № 15
Группа: Пользователи
Ранг: Новичок
Сообщений: 37
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
ВОТ ФАЙЛ...
К сообщению приложен файл: 7250783.xlsx(11.4 Kb)
 
Ответить
СообщениеВОТ ФАЙЛ...

Автор - ГАЙВЕР
Дата добавления - 14.03.2019 в 15:35
_Boroda_ Дата: Четверг, 14.03.2019, 16:19 | Сообщение № 16
Группа: Модераторы
Ранг: Местный житель
Сообщений: 14861
Репутация: 5879 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так нужно?
Код
=СУММ(ЕСЛИ(E10:S10="н/я";МЕСЯЦ(E11:S11);ДЕНЬ(E11:S11)))
Формула массива. Вводится одновременным нажатием Ctrl+Shift+Enter
Код
=СУММПРОИЗВ(--ТЕКСТ(E11:S11;СИМВОЛ(196+8*(E10:S10="н/я"))))
обычная формула
К сообщению приложен файл: 7250783_1.xlsx(11.9 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак нужно?
Код
=СУММ(ЕСЛИ(E10:S10="н/я";МЕСЯЦ(E11:S11);ДЕНЬ(E11:S11)))
Формула массива. Вводится одновременным нажатием Ctrl+Shift+Enter
Код
=СУММПРОИЗВ(--ТЕКСТ(E11:S11;СИМВОЛ(196+8*(E10:S10="н/я"))))
обычная формула

Автор - _Boroda_
Дата добавления - 14.03.2019 в 16:19
ГАЙВЕР Дата: Пятница, 15.03.2019, 12:37 | Сообщение № 17
Группа: Пользователи
Ранг: Новичок
Сообщений: 37
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
_Boroda_, СПАСИБО ВАМ ОГРОМНОЕ!!!!!!!
 
Ответить
Сообщение_Boroda_, СПАСИБО ВАМ ОГРОМНОЕ!!!!!!!

Автор - ГАЙВЕР
Дата добавления - 15.03.2019 в 12:37
ГАЙВЕР Дата: Понедельник, 18.03.2019, 06:20 | Сообщение № 18
Группа: Пользователи
Ранг: Новичок
Сообщений: 37
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
_Boroda_, Помогите мне пожалуйста с формулами, у нас в предприятии вводятся электронный учет табелей. Мне нужно автоматизировать с формы табеля Т12 на электронный
К сообщению приложен файл: 4575184.xlsx(11.1 Kb)
 
Ответить
Сообщение_Boroda_, Помогите мне пожалуйста с формулами, у нас в предприятии вводятся электронный учет табелей. Мне нужно автоматизировать с формы табеля Т12 на электронный

Автор - ГАЙВЕР
Дата добавления - 18.03.2019 в 06:20
китин Дата: Понедельник, 18.03.2019, 07:06 | Сообщение № 19
Группа: Модераторы
Ранг: Экселист
Сообщений: 5444
Репутация: 870 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
ГАЙВЕР, а что общего между темой вашего поста и вашим вопросом? не пихайте все вопросы в одну тему пожалуйста.


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
СообщениеГАЙВЕР, а что общего между темой вашего поста и вашим вопросом? не пихайте все вопросы в одну тему пожалуйста.

Автор - китин
Дата добавления - 18.03.2019 в 07:06
ГАЙВЕР Дата: Понедельник, 18.03.2019, 08:13 | Сообщение № 20
Группа: Пользователи
Ранг: Новичок
Сообщений: 37
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
китин, хорошо. Просто темы придумываю, а там ошибки находите(
 
Ответить
Сообщениекитин, хорошо. Просто темы придумываю, а там ошибки находите(

Автор - ГАЙВЕР
Дата добавления - 18.03.2019 в 08:13
Мир MS Excel » Вопросы и решения » Вопросы по Excel » посчитать количество рабочих часов (Формулы/Formulas)
  • Страница 1 из 2
  • 1
  • 2
  • »
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!