Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/прописать формулу с текстовым отображением - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » прописать формулу с текстовым отображением (Формулы/Formulas)
прописать формулу с текстовым отображением
Andrey_svk Дата: Пятница, 08.02.2019, 11:11 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 10
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
В ячейку =инфо (и так в низ по таблице) необходимо вывести информацию (а, б, …. е) если цифры совпадают с ячейкой 14,00 RUB и массивом D4-I4. Применял разные функции, но что то мой мозг не может это сделать. Вот такая вот задачка от знакомой. Структура таблицы такая и не должна быть видоизмененной!!! Думаю такую задачку оценят знатоки Экселя)
К сообщению приложен файл: 6576421.xlsx(11.2 Kb)
 
Ответить
СообщениеВ ячейку =инфо (и так в низ по таблице) необходимо вывести информацию (а, б, …. е) если цифры совпадают с ячейкой 14,00 RUB и массивом D4-I4. Применял разные функции, но что то мой мозг не может это сделать. Вот такая вот задачка от знакомой. Структура таблицы такая и не должна быть видоизмененной!!! Думаю такую задачку оценят знатоки Экселя)

Автор - Andrey_svk
Дата добавления - 08.02.2019 в 11:11
vikttur Дата: Пятница, 08.02.2019, 11:26 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 2921
Репутация: 525 ±
Замечаний: 0% ±

Код
=ИНДЕКС(R2C4:R2C9;ПОИСКПОЗ(RC[-1];RC[2]:RC[7];))

Код
=ИНДЕКС($D$2:$I$2;ПОИСКПОЗ(A4;D4:I4;))
 
Ответить
Сообщение
Код
=ИНДЕКС(R2C4:R2C9;ПОИСКПОЗ(RC[-1];RC[2]:RC[7];))

Код
=ИНДЕКС($D$2:$I$2;ПОИСКПОЗ(A4;D4:I4;))

Автор - vikttur
Дата добавления - 08.02.2019 в 11:26
Andrey_svk Дата: Пятница, 08.02.2019, 11:38 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 10
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Код
=ИНДЕКС(R2C4:R2C9;ПОИСКПОЗ(RC[-1];RC[2]:RC[7];))

Это та да, но если две, три..... и т.д. ячейки показала. Вот в этом и загвоздка. Что б вывела всю текстовую информацию, а не по первому совпадению.
Спасибо vikttur за отзыв)


Сообщение отредактировал Andrey_svk - Пятница, 08.02.2019, 12:37
 
Ответить
Сообщение
Код
=ИНДЕКС(R2C4:R2C9;ПОИСКПОЗ(RC[-1];RC[2]:RC[7];))

Это та да, но если две, три..... и т.д. ячейки показала. Вот в этом и загвоздка. Что б вывела всю текстовую информацию, а не по первому совпадению.
Спасибо vikttur за отзыв)

Автор - Andrey_svk
Дата добавления - 08.02.2019 в 11:38
китин Дата: Пятница, 08.02.2019, 11:46 | Сообщение № 4
Группа: Модераторы
Ранг: Экселист
Сообщений: 5444
Репутация: 870 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
Andrey_svk, оформите формулу тэгами в соответствии с Правилами форума. пояснялка тут


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
СообщениеAndrey_svk, оформите формулу тэгами в соответствии с Правилами форума. пояснялка тут

Автор - китин
Дата добавления - 08.02.2019 в 11:46
sboy Дата: Пятница, 08.02.2019, 13:42 | Сообщение № 5
Группа: Друзья
Ранг: Старожил
Сообщений: 2444
Репутация: 689 ±
Замечаний: 0% ±

Excel 2010
Добрый день.
Лень в пятницу думать, поэтому написал через пользовательскую
[vba]
Код
Function Andrey_svk(d As Double, txt As Range, dgt As Range) As String
    d_arr = dgt.Value
    txt_arr = txt.Value
        For i = 1 To UBound(d_arr, 2)
            If d = d_arr(1, i) Then Andrey_svk = Andrey_svk & txt_arr(1, i) & ","
        Next
    len_f = Len(Andrey_svk)
    If len_f > 0 Then Andrey_svk = Left(Andrey_svk, len_f - 1)
End Function
[/vba]
К сообщению приложен файл: 6576421.xlsm(16.7 Kb)


Яндекс: 410016850021169
 
Ответить
СообщениеДобрый день.
Лень в пятницу думать, поэтому написал через пользовательскую
[vba]
Код
Function Andrey_svk(d As Double, txt As Range, dgt As Range) As String
    d_arr = dgt.Value
    txt_arr = txt.Value
        For i = 1 To UBound(d_arr, 2)
            If d = d_arr(1, i) Then Andrey_svk = Andrey_svk & txt_arr(1, i) & ","
        Next
    len_f = Len(Andrey_svk)
    If len_f > 0 Then Andrey_svk = Left(Andrey_svk, len_f - 1)
End Function
[/vba]

Автор - sboy
Дата добавления - 08.02.2019 в 13:42
bmv98rus Дата: Пятница, 08.02.2019, 14:00 | Сообщение № 6
Группа: Проверенные
Ранг: Старожил
Сообщений: 2023
Репутация: 320 ±
Замечаний: 20% ±

Excel 2013/2016
Лень в пятницу думать
че тут думать, пилить надо
Код
=SUBSTITUTE(TRIM(IF(D4=$A4;D$2;"")&IF(E4=$A4;" "&E$2;"")&IF(F4=$A4;" "&F$2;"")&IF(G4=$A4;" "&G$2;"")&IF(H4=$A4;" "&H$2;"")&IF(I4=$A4;" "&I$2;""));" ";", ")

Естественно для ограниченного числа столбцов и если нет пробелов в значениях шапки.


Замечательный медведь, процентов на 20.
 
Ответить
Сообщение
Лень в пятницу думать
че тут думать, пилить надо
Код
=SUBSTITUTE(TRIM(IF(D4=$A4;D$2;"")&IF(E4=$A4;" "&E$2;"")&IF(F4=$A4;" "&F$2;"")&IF(G4=$A4;" "&G$2;"")&IF(H4=$A4;" "&H$2;"")&IF(I4=$A4;" "&I$2;""));" ";", ")

Естественно для ограниченного числа столбцов и если нет пробелов в значениях шапки.

Автор - bmv98rus
Дата добавления - 08.02.2019 в 14:00
Мир MS Excel » Вопросы и решения » Вопросы по Excel » прописать формулу с текстовым отображением (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!