Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Проверка столбцов на определённое значение - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Проверка столбцов на определённое значение (Формулы/Formulas)
Проверка столбцов на определённое значение
Remelibo Дата: Пятница, 08.02.2019, 22:57 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Приветствую. В Excel не силён и требуется помочь знающих людей с реализацией следующей задачи (желательно в виде формулы, если это возможно):

Имеется тест в котором есть 6 столбцов, обозначающих варианты ответа. Соответственно тестируемый проставляет цифру 1 в столбце, выбирая нужный.
Хотелось бы что бы была проверка (хотя бы визуально было видно), что ответ проставлен только в одном столбце и это именно единичка. Как хотелось бы это реализовать - в пустом столбце справа, что бы было написано красным шрифтом «Выберите один ответ» если а.) Ничего не выбрано, б.) Стоит знак, отличный от единицы. Заранее выражаю огромную благодарность за помощь!

Набросал желаемый результат и прикрепил файл:
К сообщению приложен файл: 0835917.xls(29.0 Kb)


Сообщение отредактировал Remelibo - Пятница, 08.02.2019, 22:58
 
Ответить
СообщениеПриветствую. В Excel не силён и требуется помочь знающих людей с реализацией следующей задачи (желательно в виде формулы, если это возможно):

Имеется тест в котором есть 6 столбцов, обозначающих варианты ответа. Соответственно тестируемый проставляет цифру 1 в столбце, выбирая нужный.
Хотелось бы что бы была проверка (хотя бы визуально было видно), что ответ проставлен только в одном столбце и это именно единичка. Как хотелось бы это реализовать - в пустом столбце справа, что бы было написано красным шрифтом «Выберите один ответ» если а.) Ничего не выбрано, б.) Стоит знак, отличный от единицы. Заранее выражаю огромную благодарность за помощь!

Набросал желаемый результат и прикрепил файл:

Автор - Remelibo
Дата добавления - 08.02.2019 в 22:57
vikttur Дата: Пятница, 08.02.2019, 23:05 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 2921
Репутация: 525 ±
Замечаний: 0% ±

Код
=ЕСЛИ(СЧЁТЕСЛИ(B3:G3;1);"";"Не мухлевать!!!")
 
Ответить
Сообщение
Код
=ЕСЛИ(СЧЁТЕСЛИ(B3:G3;1);"";"Не мухлевать!!!")

Автор - vikttur
Дата добавления - 08.02.2019 в 23:05
Remelibo Дата: Пятница, 08.02.2019, 23:14 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
vikttur, большое спасибо! Выручил! Но не до конца. Данная формула, к сожалению, не учитывает если в разных столбиках проставлено 1 (как на картинке-наброске в Вопросе 2). Соответственно такая картина получается, если в прикреплённый документ (в котором разные цифры-значения для проверки пробил) получается:


Сообщение отредактировал Remelibo - Пятница, 08.02.2019, 23:23
 
Ответить
Сообщениеvikttur, большое спасибо! Выручил! Но не до конца. Данная формула, к сожалению, не учитывает если в разных столбиках проставлено 1 (как на картинке-наброске в Вопросе 2). Соответственно такая картина получается, если в прикреплённый документ (в котором разные цифры-значения для проверки пробил) получается:

Автор - Remelibo
Дата добавления - 08.02.2019 в 23:14
gling Дата: Суббота, 09.02.2019, 00:29 | Сообщение № 4
Группа: Друзья
Ранг: Старожил
Сообщений: 1911
Репутация: 478 ±
Замечаний: 0% ±

2010
Код
=ЕСЛИ(СЧЁТЕСЛИ(B3:G3;1)=1;"";"Нет единичек.")


ЯД-41001506838083

Сообщение отредактировал gling - Суббота, 09.02.2019, 00:31
 
Ответить
Сообщение
Код
=ЕСЛИ(СЧЁТЕСЛИ(B3:G3;1)=1;"";"Нет единичек.")

Автор - gling
Дата добавления - 09.02.2019 в 00:29
Remelibo Дата: Суббота, 09.02.2019, 03:10 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
gling, спасибо. Уже ближе к идеальному решению. В принципе "и так сойдёт", просто повнимательнее буду проверять, не забил ли кто в одну строку какую цифру лишнюю (мало ли), так как Ваша формула не учитывает есть ли другие цифры кроме 1.

Дошёл до ещё лучшего решения поставленной задачи:

Код
=ЕСЛИ(СУММ(B3:G3)=1;" ";"Введите ответ")

Т.е. проверяется, получается ли в сумме из всех указанных ячеек 1 балл и если больше или меньше 1, то будет надпись "Введите ответ" (хех, уж вряд ли встретится 0,5 и 0,5 в двух ячейках). А уж буквы/знаки в целом не критично.


Сообщение отредактировал Remelibo - Суббота, 09.02.2019, 03:10
 
Ответить
Сообщениеgling, спасибо. Уже ближе к идеальному решению. В принципе "и так сойдёт", просто повнимательнее буду проверять, не забил ли кто в одну строку какую цифру лишнюю (мало ли), так как Ваша формула не учитывает есть ли другие цифры кроме 1.

Дошёл до ещё лучшего решения поставленной задачи:

Код
=ЕСЛИ(СУММ(B3:G3)=1;" ";"Введите ответ")

Т.е. проверяется, получается ли в сумме из всех указанных ячеек 1 балл и если больше или меньше 1, то будет надпись "Введите ответ" (хех, уж вряд ли встретится 0,5 и 0,5 в двух ячейках). А уж буквы/знаки в целом не критично.

Автор - Remelibo
Дата добавления - 09.02.2019 в 03:10
Pelena Дата: Суббота, 09.02.2019, 08:32 | Сообщение № 6
Группа: Админы
Ранг: Местный житель
Сообщений: 13866
Репутация: 3041 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
не учитывает есть ли другие цифры кроме 1

Сделайте в этих ячейках Проверку данных, чтобы нельзя было ввести ничего, кроме 1


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
Сообщение
не учитывает есть ли другие цифры кроме 1

Сделайте в этих ячейках Проверку данных, чтобы нельзя было ввести ничего, кроме 1

Автор - Pelena
Дата добавления - 09.02.2019 в 08:32
Светлый Дата: Суббота, 09.02.2019, 10:25 | Сообщение № 7
Группа: Проверенные
Ранг: Старожил
Сообщений: 1003
Репутация: 258 ±
Замечаний: 0% ±

Excel 2010
Вот так:
Код
=ЕСЛИ(B3&C3&D3&E3&F3&G3="1";"";"Введите ответ")


Программировать проще, чем писать стихи.
 
Ответить
СообщениеВот так:
Код
=ЕСЛИ(B3&C3&D3&E3&F3&G3="1";"";"Введите ответ")

Автор - Светлый
Дата добавления - 09.02.2019 в 10:25
vikttur Дата: Суббота, 09.02.2019, 10:44 | Сообщение № 8
Группа: Друзья
Ранг: Участник клуба
Сообщений: 2921
Репутация: 525 ±
Замечаний: 0% ±

Код
=ЕСЛИ(И(СЧЕТЕСЛИ(B3:G3;1)=1;СЧЕТЗ(B3:G3)=1);" ";"Введите ответ")


Но... см. файл. Там вставлены две последние формулы.
Ячейка D5. И такую ошибку учитывать? :)
К сообщению приложен файл: 2138944.xls(34.5 Kb)


Сообщение отредактировал vikttur - Суббота, 09.02.2019, 10:53
 
Ответить
Сообщение
Код
=ЕСЛИ(И(СЧЕТЕСЛИ(B3:G3;1)=1;СЧЕТЗ(B3:G3)=1);" ";"Введите ответ")


Но... см. файл. Там вставлены две последние формулы.
Ячейка D5. И такую ошибку учитывать? :)

Автор - vikttur
Дата добавления - 09.02.2019 в 10:44
Светлый Дата: Суббота, 09.02.2019, 11:15 | Сообщение № 9
Группа: Проверенные
Ранг: Старожил
Сообщений: 1003
Репутация: 258 ±
Замечаний: 0% ±

Excel 2010
А если есть пробелы:
Код
=ЕСЛИ(СЖПРОБЕЛЫ(B3&C3&D3&E3&F3&G3)="1";"";"Введите ответ")


Программировать проще, чем писать стихи.
 
Ответить
СообщениеА если есть пробелы:
Код
=ЕСЛИ(СЖПРОБЕЛЫ(B3&C3&D3&E3&F3&G3)="1";"";"Введите ответ")

Автор - Светлый
Дата добавления - 09.02.2019 в 11:15
vikttur Дата: Суббота, 09.02.2019, 13:18 | Сообщение № 10
Группа: Друзья
Ранг: Участник клуба
Сообщений: 2921
Репутация: 525 ±
Замечаний: 0% ±

А если нужно учитывать наличие непустой ячейки? А если будет введен какой-нибудь СИМВОЛ(160)?
 
Ответить
СообщениеА если нужно учитывать наличие непустой ячейки? А если будет введен какой-нибудь СИМВОЛ(160)?

Автор - vikttur
Дата добавления - 09.02.2019 в 13:18
Remelibo Дата: Воскресенье, 10.02.2019, 00:39 | Сообщение № 11
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Спасибо, посмотрю предложенные варианты днём, только перед сном до ПК добрался. Пока сил хватило только посмотреть что такое "Проверка данных" и как с этим работать - ну да, в целом это довольно неплохой вариант, спасибо - проверка суммы по ячейкам оповещает о лишних однушках и незаполненных ячейках, а проверка данных не даёт ввести что-то кроме заданного числа (1 в моём случае). Ценная информация - в дальнейшем ещё не раз пригодится, а так, конечно, нужно будет уделить Excel'ю время, поразбираться хотя бы в его базовых возможностях, лежащих на поверхности (про ту же "проверку данных" не знал, но я и Excel'ем немного пользуюсь - только как "прижмёт", как сейчас - прохождение преддипломной практики, написание магистерской).
 
Ответить
СообщениеСпасибо, посмотрю предложенные варианты днём, только перед сном до ПК добрался. Пока сил хватило только посмотреть что такое "Проверка данных" и как с этим работать - ну да, в целом это довольно неплохой вариант, спасибо - проверка суммы по ячейкам оповещает о лишних однушках и незаполненных ячейках, а проверка данных не даёт ввести что-то кроме заданного числа (1 в моём случае). Ценная информация - в дальнейшем ещё не раз пригодится, а так, конечно, нужно будет уделить Excel'ю время, поразбираться хотя бы в его базовых возможностях, лежащих на поверхности (про ту же "проверку данных" не знал, но я и Excel'ем немного пользуюсь - только как "прижмёт", как сейчас - прохождение преддипломной практики, написание магистерской).

Автор - Remelibo
Дата добавления - 10.02.2019 в 00:39
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Проверка столбцов на определённое значение (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!