Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Вывод нижних данных, с определённым названием - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Вывод нижних данных, с определённым названием (Формулы/Formulas)
Вывод нижних данных, с определённым названием
stalber Дата: Понедельник, 11.02.2019, 02:42 | Сообщение № 1
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 231
Репутация: 7 ±
Замечаний: 0% ±

Excel 2007
Подскажите пожалуйста формулу.

Имеется формула которая выводит последние данные при условии что число больше 0, если последнее 0 то берётся предыдущее там где не ноль, только теперь нужно добавить к этой формуле ещё дополнительное условие: определённые названия товара.
К сообщению приложен файл: vopros10022019.xlsx(10.9 Kb)
 
Ответить
СообщениеПодскажите пожалуйста формулу.

Имеется формула которая выводит последние данные при условии что число больше 0, если последнее 0 то берётся предыдущее там где не ноль, только теперь нужно добавить к этой формуле ещё дополнительное условие: определённые названия товара.

Автор - stalber
Дата добавления - 11.02.2019 в 02:42
krosav4ig Дата: Понедельник, 11.02.2019, 03:19 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 1851
Репутация: 795 ±
Замечаний: 0% ±

Excel 2007,2010,2013
Массивная монстроформула, слепил на скорую руку
Код
=ЕСЛИОШИБКА(ПРОСМОТР(;-1/(ИНДЕКС(Лист1!2:9999;;НАИМЕНЬШИЙ(ЕСЛИОШИБКА(ЕСЛИ(ПОИСК($J11:$J12&"*";Лист1!$C$2:$AD$2)=1;СТОЛБЕЦ(Лист1!$C$2:$AD$2));"");ОТБР((СТОЛБЕЦ()+4)/7))+ОСТАТ(СТОЛБЕЦ()+4;7))>0);ИНДЕКС(Лист1!2:9999;;НАИМЕНЬШИЙ(ЕСЛИОШИБКА(ЕСЛИ(ПОИСК($J11:$J12&"*";Лист1!$C$2:$AD$2)=1;СТОЛБЕЦ(Лист1!$C$2:$AD$2));"");ОТБР((СТОЛБЕЦ()+4)/7))+ОСТАТ(СТОЛБЕЦ()+4;7)));"")


email:krosav4ig26@gmail.com WMR R207627035142 WMZ Z821145374535 ЯД 410012026478460
 
Ответить
СообщениеМассивная монстроформула, слепил на скорую руку
Код
=ЕСЛИОШИБКА(ПРОСМОТР(;-1/(ИНДЕКС(Лист1!2:9999;;НАИМЕНЬШИЙ(ЕСЛИОШИБКА(ЕСЛИ(ПОИСК($J11:$J12&"*";Лист1!$C$2:$AD$2)=1;СТОЛБЕЦ(Лист1!$C$2:$AD$2));"");ОТБР((СТОЛБЕЦ()+4)/7))+ОСТАТ(СТОЛБЕЦ()+4;7))>0);ИНДЕКС(Лист1!2:9999;;НАИМЕНЬШИЙ(ЕСЛИОШИБКА(ЕСЛИ(ПОИСК($J11:$J12&"*";Лист1!$C$2:$AD$2)=1;СТОЛБЕЦ(Лист1!$C$2:$AD$2));"");ОТБР((СТОЛБЕЦ()+4)/7))+ОСТАТ(СТОЛБЕЦ()+4;7)));"")

Автор - krosav4ig
Дата добавления - 11.02.2019 в 03:19
Светлый Дата: Понедельник, 11.02.2019, 08:47 | Сообщение № 3
Группа: Проверенные
Ранг: Ветеран
Сообщений: 931
Репутация: 227 ±
Замечаний: 0% ±

Excel 2010
слепил на скорую руку
krosav4ig, позволил себе чуть-чуть сократить формулу:
Код
=ЕСЛИОШИБКА(ПРОСМОТР(;-1/(ИНДЕКС(Лист1!2:9999;;НАИМЕНЬШИЙ(ЕСЛИОШИБКА(ЕСЛИ(ПОИСК($J11:$J12;Лист1!$C$2:$AD$2);СТОЛБЕЦ(Лист1!$C$2:$AD$2));99);СТОЛБЕЦ(G6)/7)+ОСТАТ(СТОЛБЕЦ(G6);7))>0);ИНДЕКС(Лист1!2:9999;;НАИМЕНЬШИЙ(ЕСЛИОШИБКА(ЕСЛИ(ПОИСК($J11:$J12;Лист1!$C$2:$AD$2);СТОЛБЕЦ(Лист1!$C$2:$AD$2));99);СТОЛБЕЦ(G6)/7)+ОСТАТ(СТОЛБЕЦ(G6);7)));"")
Хорошая идея.


Программировать проще, чем писать стихи.
 
Ответить
Сообщение
слепил на скорую руку
krosav4ig, позволил себе чуть-чуть сократить формулу:
Код
=ЕСЛИОШИБКА(ПРОСМОТР(;-1/(ИНДЕКС(Лист1!2:9999;;НАИМЕНЬШИЙ(ЕСЛИОШИБКА(ЕСЛИ(ПОИСК($J11:$J12;Лист1!$C$2:$AD$2);СТОЛБЕЦ(Лист1!$C$2:$AD$2));99);СТОЛБЕЦ(G6)/7)+ОСТАТ(СТОЛБЕЦ(G6);7))>0);ИНДЕКС(Лист1!2:9999;;НАИМЕНЬШИЙ(ЕСЛИОШИБКА(ЕСЛИ(ПОИСК($J11:$J12;Лист1!$C$2:$AD$2);СТОЛБЕЦ(Лист1!$C$2:$AD$2));99);СТОЛБЕЦ(G6)/7)+ОСТАТ(СТОЛБЕЦ(G6);7)));"")
Хорошая идея.

Автор - Светлый
Дата добавления - 11.02.2019 в 08:47
Светлый Дата: Понедельник, 11.02.2019, 15:24 | Сообщение № 4
Группа: Проверенные
Ранг: Ветеран
Сообщений: 931
Репутация: 227 ±
Замечаний: 0% ±

Excel 2010
Свою формулу придумал. Массивная:
Код
=ИНДЕКС(Лист1!1:999;LOG(1+СУММ((ИНДЕКС(Лист1!1:999;;ОСТАТ(СТОЛБЕЦ(G14);7)+НАИМЕНЬШИЙ(ЕСЛИ(ЕОШ(ПОИСК($J11:$J12;Лист1!$C2:$AL2));99;СТОЛБЕЦ($C:$AL));СТОЛБЕЦ(G14)/7))>0)*2^СТРОКА(1:999));2);ОСТАТ(СТОЛБЕЦ(G14);7)+НАИМЕНЬШИЙ(ЕСЛИ(ЕОШ(ПОИСК($J11:$J12;Лист1!$C2:$AL2));99;СТОЛБЕЦ($C:$AL));СТОЛБЕЦ(G14)/7))
Есть идея, как сократить, но пока не получается.


Программировать проще, чем писать стихи.
 
Ответить
СообщениеСвою формулу придумал. Массивная:
Код
=ИНДЕКС(Лист1!1:999;LOG(1+СУММ((ИНДЕКС(Лист1!1:999;;ОСТАТ(СТОЛБЕЦ(G14);7)+НАИМЕНЬШИЙ(ЕСЛИ(ЕОШ(ПОИСК($J11:$J12;Лист1!$C2:$AL2));99;СТОЛБЕЦ($C:$AL));СТОЛБЕЦ(G14)/7))>0)*2^СТРОКА(1:999));2);ОСТАТ(СТОЛБЕЦ(G14);7)+НАИМЕНЬШИЙ(ЕСЛИ(ЕОШ(ПОИСК($J11:$J12;Лист1!$C2:$AL2));99;СТОЛБЕЦ($C:$AL));СТОЛБЕЦ(G14)/7))
Есть идея, как сократить, но пока не получается.

Автор - Светлый
Дата добавления - 11.02.2019 в 15:24
stalber Дата: Вторник, 12.02.2019, 03:49 | Сообщение № 5
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 231
Репутация: 7 ±
Замечаний: 0% ±

Excel 2007
А подскажите пожалуйста формулу.
Если формулу привязать не к Лист1, а к Лист2 где уже выведены все данные и из них нужно отобрать нужные.
К сообщению приложен файл: vopros12022019.xlsx(11.1 Kb)
 
Ответить
СообщениеА подскажите пожалуйста формулу.
Если формулу привязать не к Лист1, а к Лист2 где уже выведены все данные и из них нужно отобрать нужные.

Автор - stalber
Дата добавления - 12.02.2019 в 03:49
stalber Дата: Вторник, 12.02.2019, 16:35 | Сообщение № 6
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 231
Репутация: 7 ±
Замечаний: 0% ±

Excel 2007
актуально, сообщение выше, помогите пожалуйста


Сообщение отредактировал stalber - Вторник, 12.02.2019, 17:00
 
Ответить
Сообщениеактуально, сообщение выше, помогите пожалуйста

Автор - stalber
Дата добавления - 12.02.2019 в 16:35
Светлый Дата: Вторник, 12.02.2019, 18:25 | Сообщение № 7
Группа: Проверенные
Ранг: Ветеран
Сообщений: 931
Репутация: 227 ±
Замечаний: 0% ±

Excel 2010
Маленький кусочек предыдущей формулы. Массивная:
Код
=ИНДЕКС(6:6;;ОСТАТ(СТОЛБЕЦ(G14);7)+НАИМЕНЬШИЙ(ЕСЛИ(ЕОШ(ПОИСК($J11:$J12;$C6:$AL6));99;СТОЛБЕЦ($C:$AL));СТОЛБЕЦ(G14)/7))


Программировать проще, чем писать стихи.
 
Ответить
СообщениеМаленький кусочек предыдущей формулы. Массивная:
Код
=ИНДЕКС(6:6;;ОСТАТ(СТОЛБЕЦ(G14);7)+НАИМЕНЬШИЙ(ЕСЛИ(ЕОШ(ПОИСК($J11:$J12;$C6:$AL6));99;СТОЛБЕЦ($C:$AL));СТОЛБЕЦ(G14)/7))

Автор - Светлый
Дата добавления - 12.02.2019 в 18:25
stalber Дата: Вторник, 12.02.2019, 18:29 | Сообщение № 8
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 231
Репутация: 7 ±
Замечаний: 0% ±

Excel 2007
Начал внедрять её и понял всю проблемность массивной формулы, так как мне нужно очень много таких формул больше 500, то в ручную вводить очень много времени займёт.
Подскажите пожалуйста не массивную.
 
Ответить
СообщениеНачал внедрять её и понял всю проблемность массивной формулы, так как мне нужно очень много таких формул больше 500, то в ручную вводить очень много времени займёт.
Подскажите пожалуйста не массивную.

Автор - stalber
Дата добавления - 12.02.2019 в 18:29
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Вывод нижних данных, с определённым названием (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!