Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Сортировка диапазона по возрастанию и пропуском нулей - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сортировка диапазона по возрастанию и пропуском нулей (Формулы/Formulas)
Сортировка диапазона по возрастанию и пропуском нулей
Lizard Дата: Вторник, 12.02.2019, 05:55 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 29
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Доброго времени суток, друзья.
Помогите разобраться.

На листе есть диапазон V5:Y20, заполненный данными.
В столбце Y5:Y20 идут разные числа (все эти числа отличаются друг от друга. Двух одинаковых нет)

Как формулой без дополнительных столбцов и именованных диапазонов - отсортировать диапазон по Возрастанию, перенеся его в O5:P20 ?

В столбце Y5:Y20 - нулевые ячейки нужно игнорировать.
И еще важно, чтобы формулы в ячейках O5:O20 не ссылались на ячейки столбца P5:P20
К сообщению приложен файл: 1831280.xls(30.0 Kb)


Сообщение отредактировал Lizard - Вторник, 12.02.2019, 07:13
 
Ответить
СообщениеДоброго времени суток, друзья.
Помогите разобраться.

На листе есть диапазон V5:Y20, заполненный данными.
В столбце Y5:Y20 идут разные числа (все эти числа отличаются друг от друга. Двух одинаковых нет)

Как формулой без дополнительных столбцов и именованных диапазонов - отсортировать диапазон по Возрастанию, перенеся его в O5:P20 ?

В столбце Y5:Y20 - нулевые ячейки нужно игнорировать.
И еще важно, чтобы формулы в ячейках O5:O20 не ссылались на ячейки столбца P5:P20

Автор - Lizard
Дата добавления - 12.02.2019 в 05:55
ASWP Дата: Вторник, 12.02.2019, 06:50 | Сообщение № 2
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 180
Репутация: 23 ±
Замечаний: 0% ±

Excel 2007
Lizard, Добрый день, не идеальное решение, просто эксперимент :D
К сообщению приложен файл: 1831280-1-.xls(25.5 Kb)


я знаю что ничего не знаю, но другие не знают и этого

Сообщение отредактировал ASWP - Вторник, 12.02.2019, 06:50
 
Ответить
СообщениеLizard, Добрый день, не идеальное решение, просто эксперимент :D

Автор - ASWP
Дата добавления - 12.02.2019 в 06:50
Lizard Дата: Вторник, 12.02.2019, 07:13 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 29
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
ASWP, это что-то совершенно не то.

Нужна формула, а не использование сводной таблицы.
 
Ответить
СообщениеASWP, это что-то совершенно не то.

Нужна формула, а не использование сводной таблицы.

Автор - Lizard
Дата добавления - 12.02.2019 в 07:13
Pelena Дата: Вторник, 12.02.2019, 09:10 | Сообщение № 4
Группа: Админы
Ранг: Местный житель
Сообщений: 13866
Репутация: 3041 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Код
=ЕСЛИОШИБКА(НАИМЕНЬШИЙ($Y$5:$Y$20;СЧЁТЕСЛИ($Y$5:$Y$20;0)+СТРОКА(A1));"")
К сообщению приложен файл: 0248265.xls(31.5 Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
Сообщение
Код
=ЕСЛИОШИБКА(НАИМЕНЬШИЙ($Y$5:$Y$20;СЧЁТЕСЛИ($Y$5:$Y$20;0)+СТРОКА(A1));"")

Автор - Pelena
Дата добавления - 12.02.2019 в 09:10
Lizard Дата: Вторник, 12.02.2019, 11:30 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 29
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Pelena, спасибо.
 
Ответить
СообщениеPelena, спасибо.

Автор - Lizard
Дата добавления - 12.02.2019 в 11:30
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сортировка диапазона по возрастанию и пропуском нулей (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!