Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/копировать определенные строки на другой лист - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » копировать определенные строки на другой лист (Формулы/Formulas)
копировать определенные строки на другой лист
DUMKAs Дата: Пятница, 15.02.2019, 14:16 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Есть список поверок с датами, в нем сделано чтоб просроченные даты поверок подсвечивались красным, непросроченные - зеленым (с выключателем). Задача : как сделать так, чтобы просроченные поверки (подсвеченные красным) автоматически копировались на другой лист и формировали список просроченных поверок. Пример прилагаю. Спасибо.
К сообщению приложен файл: 4679356.xlsx(13.2 Kb)


->DM<-
 
Ответить
СообщениеЕсть список поверок с датами, в нем сделано чтоб просроченные даты поверок подсвечивались красным, непросроченные - зеленым (с выключателем). Задача : как сделать так, чтобы просроченные поверки (подсвеченные красным) автоматически копировались на другой лист и формировали список просроченных поверок. Пример прилагаю. Спасибо.

Автор - DUMKAs
Дата добавления - 15.02.2019 в 14:16
Pelena Дата: Пятница, 15.02.2019, 14:50 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 14342
Репутация: 3134 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
И Вам здравствуйте.
Для №п/п формула массива
Код
=ЕСЛИОШИБКА(НАИМЕНЬШИЙ(ЕСЛИ(ВСЕ!$F$8:$F$17<ВСЕ!$M$3;ВСЕ!$C$8:$C$17);СТРОКА(A1));"")

для остальных
Код
=ЕСЛИОШИБКА(ИНДЕКС(ВСЕ!$D$8:$I$17;$B4;ПОИСКПОЗ(C$2;ВСЕ!$D$7:$I$7;0));"")

Лишние нули можно скрыть форматом или Условным форматированием
К сообщению приложен файл: 2401581.xlsx(15.5 Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеИ Вам здравствуйте.
Для №п/п формула массива
Код
=ЕСЛИОШИБКА(НАИМЕНЬШИЙ(ЕСЛИ(ВСЕ!$F$8:$F$17<ВСЕ!$M$3;ВСЕ!$C$8:$C$17);СТРОКА(A1));"")

для остальных
Код
=ЕСЛИОШИБКА(ИНДЕКС(ВСЕ!$D$8:$I$17;$B4;ПОИСКПОЗ(C$2;ВСЕ!$D$7:$I$7;0));"")

Лишние нули можно скрыть форматом или Условным форматированием

Автор - Pelena
Дата добавления - 15.02.2019 в 14:50
DUMKAs Дата: Пятница, 15.02.2019, 15:24 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
И Вам здравствуйте.
простите, запарился.
Для №п/п формула массива

=ЕСЛИОШИБКА(НАИМЕНЬШИЙ(ЕСЛИ(ВСЕ!$F$8:$F$17<ВСЕ!$M$3;ВСЕ!$C$8:$C$17);СТРОКА(A1));"")

для остальных

=ЕСЛИОШИБКА(ИНДЕКС(ВСЕ!$D$8:$I$17;$B4;ПОИСКПОЗ(C$2;ВСЕ!$D$7:$I$7;0));"")

Лишние нули можно скрыть форматом или Условным форматированием
и спасибо.
Еще бы некоторые пояснения: можно пользоваться каждой формулой по отдельности или только вместе? где отсылка на другой лист?


->DM<-
 
Ответить
Сообщение
И Вам здравствуйте.
простите, запарился.
Для №п/п формула массива

=ЕСЛИОШИБКА(НАИМЕНЬШИЙ(ЕСЛИ(ВСЕ!$F$8:$F$17<ВСЕ!$M$3;ВСЕ!$C$8:$C$17);СТРОКА(A1));"")

для остальных

=ЕСЛИОШИБКА(ИНДЕКС(ВСЕ!$D$8:$I$17;$B4;ПОИСКПОЗ(C$2;ВСЕ!$D$7:$I$7;0));"")

Лишние нули можно скрыть форматом или Условным форматированием
и спасибо.
Еще бы некоторые пояснения: можно пользоваться каждой формулой по отдельности или только вместе? где отсылка на другой лист?

Автор - DUMKAs
Дата добавления - 15.02.2019 в 15:24
Pelena Дата: Пятница, 15.02.2019, 15:49 | Сообщение № 4
Группа: Админы
Ранг: Местный житель
Сообщений: 14342
Репутация: 3134 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
можно пользоваться каждой формулой по отдельности или только вместе?
не поняла вопрос. Первая формула вытягивает порядковые номера с просроченными датами. Вторая формула по каждому такому порядковому номеру вытягивает остальные данные из таблицы.

отсылка на другой лист
ВСЕ!


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
Сообщение
можно пользоваться каждой формулой по отдельности или только вместе?
не поняла вопрос. Первая формула вытягивает порядковые номера с просроченными датами. Вторая формула по каждому такому порядковому номеру вытягивает остальные данные из таблицы.

отсылка на другой лист
ВСЕ!

Автор - Pelena
Дата добавления - 15.02.2019 в 15:49
DUMKAs Дата: Среда, 20.02.2019, 13:24 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Спасибо. буду заниматься! hands


->DM<-
 
Ответить
СообщениеСпасибо. буду заниматься! hands

Автор - DUMKAs
Дата добавления - 20.02.2019 в 13:24
Мир MS Excel » Вопросы и решения » Вопросы по Excel » копировать определенные строки на другой лист (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!