Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Не считается сумма результатов вычисления формул - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Не считается сумма результатов вычисления формул (Формулы/Formulas)
Не считается сумма результатов вычисления формул
rulesss2 Дата: Пятница, 15.02.2019, 15:46 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Здравствуйте. У меня в ячейке Е2 не считается сумма результатов в столбце С. Вроде всё просто, но поиски в интернете оказались безуспешны..
К сообщению приложен файл: _Microsoft_Exce.xlsx(11.3 Kb)
 
Ответить
СообщениеЗдравствуйте. У меня в ячейке Е2 не считается сумма результатов в столбце С. Вроде всё просто, но поиски в интернете оказались безуспешны..

Автор - rulesss2
Дата добавления - 15.02.2019 в 15:46
_Boroda_ Дата: Пятница, 15.02.2019, 15:54 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 14964
Репутация: 5917 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
У Вас там формула выдает результатом текст. Перепишите ее вот так
Код
=--(ЕСЛИ(СЧЁТЕСЛИ(A2;"*HP CB436A*");B2*340;"")&ЕСЛИ(СЧЁТЕСЛИ(A2;"Kyocera M2030dn (заправка)");B2*1000;""))

А лучше вот так
Код
=ЕСЛИ("Kyocera M2030dn (заправка)"=A2;B2*1000;ЕСЛИ(ЕЧИСЛО(ПОИСК("*HP CB436A*";A2));B2*340;""))


СЧЁТЕСЛИ там вообще не нужен
К сообщению приложен файл: 8392615.xlsx(11.6 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеУ Вас там формула выдает результатом текст. Перепишите ее вот так
Код
=--(ЕСЛИ(СЧЁТЕСЛИ(A2;"*HP CB436A*");B2*340;"")&ЕСЛИ(СЧЁТЕСЛИ(A2;"Kyocera M2030dn (заправка)");B2*1000;""))

А лучше вот так
Код
=ЕСЛИ("Kyocera M2030dn (заправка)"=A2;B2*1000;ЕСЛИ(ЕЧИСЛО(ПОИСК("*HP CB436A*";A2));B2*340;""))


СЧЁТЕСЛИ там вообще не нужен

Автор - _Boroda_
Дата добавления - 15.02.2019 в 15:54
sboy Дата: Пятница, 15.02.2019, 15:56 | Сообщение № 3
Группа: Друзья
Ранг: Старожил
Сообщений: 2487
Репутация: 699 ±
Замечаний: 0% ±

Excel 2010
Добрый день.
У вас в результате вычисления в столбце С - текст. функция СУММ() текст игнорирует.
Можете поставить двойное отрицание в начале формулы.
Код
=--(ЕСЛИ(СЧЁТЕСЛИ(A2;"*HP CB436A*");B2*340;"")&ЕСЛИ(СЧЁТЕСЛИ(A2;"Kyocera M2030dn (заправка)");B2*1000;""))

Но я бы ее переделал, уж очень она странная=)


Яндекс: 410016850021169
 
Ответить
СообщениеДобрый день.
У вас в результате вычисления в столбце С - текст. функция СУММ() текст игнорирует.
Можете поставить двойное отрицание в начале формулы.
Код
=--(ЕСЛИ(СЧЁТЕСЛИ(A2;"*HP CB436A*");B2*340;"")&ЕСЛИ(СЧЁТЕСЛИ(A2;"Kyocera M2030dn (заправка)");B2*1000;""))

Но я бы ее переделал, уж очень она странная=)

Автор - sboy
Дата добавления - 15.02.2019 в 15:56
Pelena Дата: Пятница, 15.02.2019, 15:56 | Сообщение № 4
Группа: Админы
Ранг: Местный житель
Сообщений: 14009
Репутация: 3065 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Здравствуйте.
Потому что в формуле получается текст. Можно так изменить
Код
=ЕСЛИ(СЧЁТЕСЛИ(A2;"*HP CB436A*");B2*340;ЕСЛИ(СЧЁТЕСЛИ(A2;"Kyocera M2030dn (заправка)");B2*1000;""))

А лучше сделпть доп. табличку с тарифами и брать с помощью ВПР()
К сообщению приложен файл: 8018990.xlsx(12.0 Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеЗдравствуйте.
Потому что в формуле получается текст. Можно так изменить
Код
=ЕСЛИ(СЧЁТЕСЛИ(A2;"*HP CB436A*");B2*340;ЕСЛИ(СЧЁТЕСЛИ(A2;"Kyocera M2030dn (заправка)");B2*1000;""))

А лучше сделпть доп. табличку с тарифами и брать с помощью ВПР()

Автор - Pelena
Дата добавления - 15.02.2019 в 15:56
rulesss2 Дата: Пятница, 15.02.2019, 16:54 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Всё получилось, всем спасибо за ответы, вчера пол дня убил на поиск решения самостоятельно =)
 
Ответить
СообщениеВсё получилось, всем спасибо за ответы, вчера пол дня убил на поиск решения самостоятельно =)

Автор - rulesss2
Дата добавления - 15.02.2019 в 16:54
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Не считается сумма результатов вычисления формул (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!