Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Создание таблицы на основе сравнений 2х таблиц - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Создание таблицы на основе сравнений 2х таблиц (Формулы/Formulas)
Создание таблицы на основе сравнений 2х таблиц
Zarif Дата: Четверг, 21.02.2019, 08:04 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Необходимо сравнить 2 таблицы, первые 2 параметра создаваемой 3й таблицы берутся из 2й таблицы а 3й параметр берется из 1й таблицы с помощью команды Lookup(). Проблемы возникают если в первой таблице есть строки с одинаковыми значениями 1го параметра (выделено красным). Нужно как то добавить еще сравнение по 2му параметру, но не знаю как(
К сообщению приложен файл: 4027656.xlsx(30.2 Kb)
 
Ответить
СообщениеНеобходимо сравнить 2 таблицы, первые 2 параметра создаваемой 3й таблицы берутся из 2й таблицы а 3й параметр берется из 1й таблицы с помощью команды Lookup(). Проблемы возникают если в первой таблице есть строки с одинаковыми значениями 1го параметра (выделено красным). Нужно как то добавить еще сравнение по 2му параметру, но не знаю как(

Автор - Zarif
Дата добавления - 21.02.2019 в 08:04
Pelena Дата: Четверг, 21.02.2019, 09:08 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 14009
Репутация: 3066 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
И Вам здравствуйте.
Как вариант
Код
=ЕСЛИ(I3<>"";ЕСЛИОШИБКА(ПРОСМОТР(0;-1/(I3=A$3:A$286)/(J3=$B$3:$B$286);C$3:C$286);ПРОСМОТР(I3;$A$3:$A$286;$C$3:$C$286));"")
К сообщению приложен файл: 5770261.xlsx(30.5 Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеИ Вам здравствуйте.
Как вариант
Код
=ЕСЛИ(I3<>"";ЕСЛИОШИБКА(ПРОСМОТР(0;-1/(I3=A$3:A$286)/(J3=$B$3:$B$286);C$3:C$286);ПРОСМОТР(I3;$A$3:$A$286;$C$3:$C$286));"")

Автор - Pelena
Дата добавления - 21.02.2019 в 09:08
_Boroda_ Дата: Четверг, 21.02.2019, 09:16 | Сообщение № 3
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15009
Репутация: 5926 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Сначала попробовал
Код
=ПРОСМОТР(;-1/(I3&J3=A$3:A$99&ОКРУГЛ(B$3:B$99;1));C$3:C$99)
, но так не везде получается
Может, так?
Код
=ЕСЛИ(I3<>"";ЕСЛИ(СЧЁТЕСЛИ(A:A;I3)>1;ПРОСМОТР(;-1/(I3&J3=A$3:A$99&B$3:B$99);C$3:C$99);ВПР(I3;A$3:C$99;3;));"")

А можно еще вот так
Код
=СУММЕСЛИМН(C:C;A:A;I3;B:B;ЕСЛИ(СЧЁТЕСЛИ(A:A;I3)>1;J3;">0"))
К сообщению приложен файл: 4027656_2.xlsx(31.2 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеСначала попробовал
Код
=ПРОСМОТР(;-1/(I3&J3=A$3:A$99&ОКРУГЛ(B$3:B$99;1));C$3:C$99)
, но так не везде получается
Может, так?
Код
=ЕСЛИ(I3<>"";ЕСЛИ(СЧЁТЕСЛИ(A:A;I3)>1;ПРОСМОТР(;-1/(I3&J3=A$3:A$99&B$3:B$99);C$3:C$99);ВПР(I3;A$3:C$99;3;));"")

А можно еще вот так
Код
=СУММЕСЛИМН(C:C;A:A;I3;B:B;ЕСЛИ(СЧЁТЕСЛИ(A:A;I3)>1;J3;">0"))

Автор - _Boroda_
Дата добавления - 21.02.2019 в 09:16
Zarif Дата: Четверг, 21.02.2019, 09:59 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Спасибо, огромное!!! Формула работает, хорошо решает мою задачу!!!
 
Ответить
СообщениеСпасибо, огромное!!! Формула работает, хорошо решает мою задачу!!!

Автор - Zarif
Дата добавления - 21.02.2019 в 09:59
Zarif Дата: Пятница, 22.02.2019, 09:40 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Здравствуйте! Тут появилось еще одно условие, из за того что 2й параметр не всегда одинаковый в первой и второй таблицы.
Можно ли сделать так чтобы дополнительный поиск по 2му параметру было не равенство а поиск по наименьшей разнице между ними?
Пример такого случая приложил.
Как то все запутано получилось)
К сообщению приложен файл: primer_solution.xlsx(32.5 Kb)
 
Ответить
СообщениеЗдравствуйте! Тут появилось еще одно условие, из за того что 2й параметр не всегда одинаковый в первой и второй таблицы.
Можно ли сделать так чтобы дополнительный поиск по 2му параметру было не равенство а поиск по наименьшей разнице между ними?
Пример такого случая приложил.
Как то все запутано получилось)

Автор - Zarif
Дата добавления - 22.02.2019 в 09:40
Pelena Дата: Вторник, 26.02.2019, 14:31 | Сообщение № 6
Группа: Админы
Ранг: Местный житель
Сообщений: 14009
Репутация: 3066 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Попробуйте так, формула массива
Код
=ЕСЛИ(I3<>"";ЕСЛИОШИБКА(ПРОСМОТР(0;-1/(I3=A$3:A$287)/(МИН(ЕСЛИ(I3=$A$3:$A$23;ABS(J3-$B$3:$B$23)))=ЕСЛИ(I3=$A$3:$A$23;ABS(J3-$B$3:$B$23)));C$3:C$287);0);"")
К сообщению приложен файл: 3227556.xlsx(33.5 Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеПопробуйте так, формула массива
Код
=ЕСЛИ(I3<>"";ЕСЛИОШИБКА(ПРОСМОТР(0;-1/(I3=A$3:A$287)/(МИН(ЕСЛИ(I3=$A$3:$A$23;ABS(J3-$B$3:$B$23)))=ЕСЛИ(I3=$A$3:$A$23;ABS(J3-$B$3:$B$23)));C$3:C$287);0);"")

Автор - Pelena
Дата добавления - 26.02.2019 в 14:31
Zarif Дата: Вторник, 26.02.2019, 16:08 | Сообщение № 7
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Спасибо, работает! от меня отправлен презент)
 
Ответить
СообщениеСпасибо, работает! от меня отправлен презент)

Автор - Zarif
Дата добавления - 26.02.2019 в 16:08
Pelena Дата: Вторник, 26.02.2019, 16:25 | Сообщение № 8
Группа: Админы
Ранг: Местный житель
Сообщений: 14009
Репутация: 3066 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
И Вам спасибо)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеИ Вам спасибо)

Автор - Pelena
Дата добавления - 26.02.2019 в 16:25
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Создание таблицы на основе сравнений 2х таблиц (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!