Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Расчёт месяца поставки заказа - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Расчёт месяца поставки заказа (Формулы/Formulas)
Расчёт месяца поставки заказа
AnnaKeiser Дата: Четверг, 21.02.2019, 11:18 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 10
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Добрый день!
Прошу помощи в изучении функции смещ. (подсказали коллеги)
Имеем таблицу с заказами, сроками производства и сроками получения товара, по идее срок получение товара=срок размещения заказа + формула смещ на кол-во месяцев производства. Но формула работает, только есть в левую часть добавить количество пустых столбцов равное количеству месяцев производства, непонятно почему, определила методом тыка.
Прошу показать и объяснить, возможно есть другие пути решения.
Спасибо!
К сообщению приложен файл: 0378636.xlsx(11.1 Kb)


Сообщение отредактировал AnnaKeiser - Пятница, 22.02.2019, 09:28
 
Ответить
СообщениеДобрый день!
Прошу помощи в изучении функции смещ. (подсказали коллеги)
Имеем таблицу с заказами, сроками производства и сроками получения товара, по идее срок получение товара=срок размещения заказа + формула смещ на кол-во месяцев производства. Но формула работает, только есть в левую часть добавить количество пустых столбцов равное количеству месяцев производства, непонятно почему, определила методом тыка.
Прошу показать и объяснить, возможно есть другие пути решения.
Спасибо!

Автор - AnnaKeiser
Дата добавления - 21.02.2019 в 11:18
bmv98rus Дата: Четверг, 21.02.2019, 11:28 | Сообщение № 2
Группа: Проверенные
Ранг: Старожил
Сообщений: 2156
Репутация: 366 ±
Замечаний: 20% ±

Excel 2013/2016
чайники смещаются по правилу
первый параметр - это диапазон с которым работаем (может быть не обязательно одна ячейка)
Второй - это на сколько строк сдвинется этот диапазон (можно использовать и отрицательное смещение
3й - тоже но со столбцами
4й - размер диапазона строк (если не указан, то не меняется)
5й - тоже но столбцов

у вас
Код
=OFFSET(A3;;($Y3*-1))

$Y3 =5
в результат A3 смещается на -5 столбца и указывает на несуществующий столбец

[p.s.]а звезду то я ни не заметил :-)[/p.s.]


Замечательный медведь, процентов на 20.

Сообщение отредактировал bmv98rus - Четверг, 21.02.2019, 11:47
 
Ответить
Сообщениечайники смещаются по правилу
первый параметр - это диапазон с которым работаем (может быть не обязательно одна ячейка)
Второй - это на сколько строк сдвинется этот диапазон (можно использовать и отрицательное смещение
3й - тоже но со столбцами
4й - размер диапазона строк (если не указан, то не меняется)
5й - тоже но столбцов

у вас
Код
=OFFSET(A3;;($Y3*-1))

$Y3 =5
в результат A3 смещается на -5 столбца и указывает на несуществующий столбец

[p.s.]а звезду то я ни не заметил :-)[/p.s.]

Автор - bmv98rus
Дата добавления - 21.02.2019 в 11:28
_Boroda_ Дата: Четверг, 21.02.2019, 11:36 | Сообщение № 3
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15020
Репутация: 5929 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
AnnaKeiser,
- Прочитайте Правила форума
- Исправьте название темы согласно п.2 Правил форума. Вас интересует именно функция СМЕЩ или решение задачи? СМЕЩ там вовсе не обязательно, более того, она вообще нежелательна

bmv98rus, ????? Тем более с ошибкой - не указывает она на Е3


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеAnnaKeiser,
- Прочитайте Правила форума
- Исправьте название темы согласно п.2 Правил форума. Вас интересует именно функция СМЕЩ или решение задачи? СМЕЩ там вовсе не обязательно, более того, она вообще нежелательна

bmv98rus, ????? Тем более с ошибкой - не указывает она на Е3

Автор - _Boroda_
Дата добавления - 21.02.2019 в 11:36
_Boroda_ Дата: Четверг, 21.02.2019, 11:53 | Сообщение № 4
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15020
Репутация: 5929 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Михаил, я не только про звезду, в основном я про нарушение Правил форума


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеМихаил, я не только про звезду, в основном я про нарушение Правил форума

Автор - _Boroda_
Дата добавления - 21.02.2019 в 11:53
bmv98rus Дата: Четверг, 21.02.2019, 11:59 | Сообщение № 5
Группа: Проверенные
Ранг: Старожил
Сообщений: 2156
Репутация: 366 ±
Замечаний: 20% ±

Excel 2013/2016
_Boroda_, Александр, ну спорить с модератором в данном случае не стану :-) с названием это я маху дал, а вот пояснял именно OFFSET , а не то что она тут не к месту.


Замечательный медведь, процентов на 20.
 
Ответить
Сообщение_Boroda_, Александр, ну спорить с модератором в данном случае не стану :-) с названием это я маху дал, а вот пояснял именно OFFSET , а не то что она тут не к месту.

Автор - bmv98rus
Дата добавления - 21.02.2019 в 11:59
_Boroda_ Дата: Четверг, 21.02.2019, 12:11 | Сообщение № 6
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15020
Репутация: 5929 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Да, намеки сегодня не очень проходят. Все приходится самому делать


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеДа, намеки сегодня не очень проходят. Все приходится самому делать

Автор - _Boroda_
Дата добавления - 21.02.2019 в 12:11
AnnaKeiser Дата: Пятница, 22.02.2019, 09:31 | Сообщение № 7
Группа: Пользователи
Ранг: Новичок
Сообщений: 10
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
_Boroda_, Спасибо за указание на ошибку! Вроде всё исправила.
 
Ответить
Сообщение_Boroda_, Спасибо за указание на ошибку! Вроде всё исправила.

Автор - AnnaKeiser
Дата добавления - 22.02.2019 в 09:31
AnnaKeiser Дата: Пятница, 22.02.2019, 09:32 | Сообщение № 8
Группа: Пользователи
Ранг: Новичок
Сообщений: 10
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
bmv98rus, К сожалению не могу прочитать Ваше первое сообщение.
 
Ответить
Сообщениеbmv98rus, К сожалению не могу прочитать Ваше первое сообщение.

Автор - AnnaKeiser
Дата добавления - 22.02.2019 в 09:32
_Boroda_ Дата: Пятница, 22.02.2019, 10:20 | Сообщение № 9
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15020
Репутация: 5929 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Правильно, это я его заблокировал (хорошо еще, что не удалил, как я обычно в подобных случаях делаю :D ) до исправления Вами названия темы. Сейчас разблокирую
И Вы не ответили на вопрос - Вам нужно решить задачу вообще или именно с функцией СМЕЩ? СМЕЩ волатильна, пересчитывается при любом изменении.
Если Вам нужно именно СМЕЩ, то просто пропишите обработчик ошибки
Код
=ЕСЛИОШИБКА(СМЕЩ(A3;;-$Y3);)

Если СМЕЩ ВАм не очень дорога, то предлагаю вот такую формулу
Код
=ЕСЛИОШИБКА(ИНДЕКС($A3:$X3;СТОЛБЕЦ(A3)-$Y3);)
К сообщению приложен файл: 0378636-1-1.xlsx(11.2 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеПравильно, это я его заблокировал (хорошо еще, что не удалил, как я обычно в подобных случаях делаю :D ) до исправления Вами названия темы. Сейчас разблокирую
И Вы не ответили на вопрос - Вам нужно решить задачу вообще или именно с функцией СМЕЩ? СМЕЩ волатильна, пересчитывается при любом изменении.
Если Вам нужно именно СМЕЩ, то просто пропишите обработчик ошибки
Код
=ЕСЛИОШИБКА(СМЕЩ(A3;;-$Y3);)

Если СМЕЩ ВАм не очень дорога, то предлагаю вот такую формулу
Код
=ЕСЛИОШИБКА(ИНДЕКС($A3:$X3;СТОЛБЕЦ(A3)-$Y3);)

Автор - _Boroda_
Дата добавления - 22.02.2019 в 10:20
AnnaKeiser Дата: Пятница, 22.02.2019, 11:18 | Сообщение № 10
Группа: Пользователи
Ранг: Новичок
Сообщений: 10
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
_Boroda_, Спасибо!
Я в excel новичок, поэтому буду изучать все функции, которые вы предложите :)
Я поняла, что в любимом случае, что со смещением, что с индексом нужен обработчик ошибок?
 
Ответить
Сообщение_Boroda_, Спасибо!
Я в excel новичок, поэтому буду изучать все функции, которые вы предложите :)
Я поняла, что в любимом случае, что со смещением, что с индексом нужен обработчик ошибок?

Автор - AnnaKeiser
Дата добавления - 22.02.2019 в 11:18
_Boroda_ Дата: Пятница, 22.02.2019, 13:02 | Сообщение № 11
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15020
Репутация: 5929 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Можно добавить пустой столбец А и вот так написать
Код
=ИНДЕКС(3:3;МАКС(;СТОЛБЕЦ(A3)-$Z3)+1)

Код
=ИНДЕКС(3:3;МАКС(1;СТОЛБЕЦ(B3)-$Z3))
К сообщению приложен файл: 0378636-1-2.xlsx(11.5 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеМожно добавить пустой столбец А и вот так написать
Код
=ИНДЕКС(3:3;МАКС(;СТОЛБЕЦ(A3)-$Z3)+1)

Код
=ИНДЕКС(3:3;МАКС(1;СТОЛБЕЦ(B3)-$Z3))

Автор - _Boroda_
Дата добавления - 22.02.2019 в 13:02
AnnaKeiser Дата: Вторник, 05.03.2019, 12:19 | Сообщение № 12
Группа: Пользователи
Ранг: Новичок
Сообщений: 10
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Спасибо за помощь!
 
Ответить
СообщениеСпасибо за помощь!

Автор - AnnaKeiser
Дата добавления - 05.03.2019 в 12:19
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Расчёт месяца поставки заказа (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!