Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Фильтрация данных на отдельный лист - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Фильтрация данных на отдельный лист (Формулы/Formulas)
Фильтрация данных на отдельный лист
Alex555777 Дата: Четверг, 21.02.2019, 17:48 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Тема http://www.excelworld.ru/forum/2-7026-1 закрыта.

Не могу сделать чтобы данные фильтровались по двум колонкам
В ЕСЛИ добавил И, но не работатет
Код
=ИНДЕКС(Лист1!C$5:C$18;НАИМЕНЬШИЙ(ЕСЛИ(И(Лист1!$E$5:$E$18=возраст;Лист1!$D$5:$D$18=J3);Лист1!$B$5:$B$18);СТРОКА()-3))
К сообщению приложен файл: Filtr4545_1.xls(38.5 Kb)


Сообщение отредактировал Alex555777 - Четверг, 21.02.2019, 17:48
 
Ответить
СообщениеТема http://www.excelworld.ru/forum/2-7026-1 закрыта.

Не могу сделать чтобы данные фильтровались по двум колонкам
В ЕСЛИ добавил И, но не работатет
Код
=ИНДЕКС(Лист1!C$5:C$18;НАИМЕНЬШИЙ(ЕСЛИ(И(Лист1!$E$5:$E$18=возраст;Лист1!$D$5:$D$18=J3);Лист1!$B$5:$B$18);СТРОКА()-3))

Автор - Alex555777
Дата добавления - 21.02.2019 в 17:48
Pelena Дата: Четверг, 21.02.2019, 20:09 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 14087
Репутация: 3080 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Попробуйте так
Код
=ИНДЕКС(Лист1!C$5:C$18;НАИМЕНЬШИЙ(ЕСЛИ((Лист1!$E$5:$E$18=возраст)*(Лист1!$D$5:$D$18=$J$3);Лист1!$B$5:$B$18);СТРОКА()-3))

и должность можно по фамилии найти
К сообщению приложен файл: 7095594.xls(39.0 Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеПопробуйте так
Код
=ИНДЕКС(Лист1!C$5:C$18;НАИМЕНЬШИЙ(ЕСЛИ((Лист1!$E$5:$E$18=возраст)*(Лист1!$D$5:$D$18=$J$3);Лист1!$B$5:$B$18);СТРОКА()-3))

и должность можно по фамилии найти

Автор - Pelena
Дата добавления - 21.02.2019 в 20:09
jakim Дата: Четверг, 21.02.2019, 20:56 | Сообщение № 3
Группа: Друзья
Ранг: Ветеран
Сообщений: 895
Репутация: 232 ±
Замечаний: 0% ±

Excel 2010
Если у Вас Excel 2016, то можно воспользоваться функцией АГРЕГАТ.

Код
=ЕСЛИОШИБКА(ИНДЕКС(Лист1!B$5:B$100;АГРЕГАТ(15;6;СТРОКА($1:$100)/(Лист1!$D$5:$D$100=Лист2!$J$3)/(Лист1!$E$5:$E$100=$I$3);ЧСТРОК($4:4)));"")
К сообщению приложен файл: Filtr4545_1.xlsx(12.5 Kb)
 
Ответить
Сообщение
Если у Вас Excel 2016, то можно воспользоваться функцией АГРЕГАТ.

Код
=ЕСЛИОШИБКА(ИНДЕКС(Лист1!B$5:B$100;АГРЕГАТ(15;6;СТРОКА($1:$100)/(Лист1!$D$5:$D$100=Лист2!$J$3)/(Лист1!$E$5:$E$100=$I$3);ЧСТРОК($4:4)));"")

Автор - jakim
Дата добавления - 21.02.2019 в 20:56
Alex555777 Дата: Пятница, 22.02.2019, 11:18 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Спасибо! На в тестовом файле работает, но не могу правильно перенести на свой файл.
Не пойму что происходит здесь -
Код
АГРЕГАТ(15,6,СТРОКА($1:$1000)/(База!$D$6:$D$1000=B3)/(База!$L$6:$L$1000=C3),ЧСТРОК($4:4)))

Что такое 15, 6, я нашел,
Как работает это не пойму -
Код
СТРОКА($1:$1000)/(База!$D$6:$D$1000=B3)/(База!$L$6:$L$1000=C3)

И это
Код
ЧСТРОК($4:4),

Буду благодарен если объясните или скините ссылки на полезные материалы)


Сообщение отредактировал Alex555777 - Пятница, 22.02.2019, 12:24
 
Ответить
СообщениеСпасибо! На в тестовом файле работает, но не могу правильно перенести на свой файл.
Не пойму что происходит здесь -
Код
АГРЕГАТ(15,6,СТРОКА($1:$1000)/(База!$D$6:$D$1000=B3)/(База!$L$6:$L$1000=C3),ЧСТРОК($4:4)))

Что такое 15, 6, я нашел,
Как работает это не пойму -
Код
СТРОКА($1:$1000)/(База!$D$6:$D$1000=B3)/(База!$L$6:$L$1000=C3)

И это
Код
ЧСТРОК($4:4),

Буду благодарен если объясните или скините ссылки на полезные материалы)

Автор - Alex555777
Дата добавления - 22.02.2019 в 11:18
Pelena Дата: Пятница, 22.02.2019, 11:38 | Сообщение № 5
Группа: Админы
Ранг: Местный житель
Сообщений: 14087
Репутация: 3080 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Alex555777, оформите формулы тегами с помощью кнопки fx в режиме правки поста


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеAlex555777, оформите формулы тегами с помощью кнопки fx в режиме правки поста

Автор - Pelena
Дата добавления - 22.02.2019 в 11:38
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Фильтрация данных на отдельный лист (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!