Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Формула для расчета значений из заданного промежутка - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Формула для расчета значений из заданного промежутка (Формулы/Formulas)
Формула для расчета значений из заданного промежутка
kuzznetss Дата: Понедельник, 25.02.2019, 02:42 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
В приложенном файле -таблица-в ней необходимо вести расчет в столбце F (Оборачиваемость)-предоставлена в часах.
Расчет необходимо вести путем вычитания от большего значения (более позднего прибытия машины) меньшего значения по столбцу Е (время въезда) основываясь на столбец В (Номер машины).
В данный момент для каждой машины значения подбираются персонально и в ручную.
Необходима формула для всей таблицы что бы расчет велся автоматически.
В прикрепленном файле предоставлен небольшой фрагмент всей таблицы-поэтому в столбце F (Оборачиваемость) представлены не все значения в часовом выражении.
Прошу помочь в решении данной проблемы.
К сообщению приложен файл: 5488988.xlsx(12.6 Kb)
 
Ответить
СообщениеВ приложенном файле -таблица-в ней необходимо вести расчет в столбце F (Оборачиваемость)-предоставлена в часах.
Расчет необходимо вести путем вычитания от большего значения (более позднего прибытия машины) меньшего значения по столбцу Е (время въезда) основываясь на столбец В (Номер машины).
В данный момент для каждой машины значения подбираются персонально и в ручную.
Необходима формула для всей таблицы что бы расчет велся автоматически.
В прикрепленном файле предоставлен небольшой фрагмент всей таблицы-поэтому в столбце F (Оборачиваемость) представлены не все значения в часовом выражении.
Прошу помочь в решении данной проблемы.

Автор - kuzznetss
Дата добавления - 25.02.2019 в 02:42
krosav4ig Дата: Понедельник, 25.02.2019, 04:02 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 2031
Репутация: 847 ±
Замечаний: 0% ±

Excel 2007,2010,2013
если все данные отсортированы по дате и времени, то для E3 формула
Код
=D3-ПРОСМОТР(;-1/(B$1:B2=B3);D$1:D$2)

или, для неотсортированных данных
Код
=СУММПРОИЗВ(--ТЕКСТ(D3-МАКС((B$3:B$75=B3)*(D$3:D$75<D3)*D$3:D$75);"[>999]\0"))


email:krosav4ig26@gmail.com WMR R207627035142 WMZ Z821145374535 ЯД 410012026478460
 
Ответить
Сообщениеесли все данные отсортированы по дате и времени, то для E3 формула
Код
=D3-ПРОСМОТР(;-1/(B$1:B2=B3);D$1:D$2)

или, для неотсортированных данных
Код
=СУММПРОИЗВ(--ТЕКСТ(D3-МАКС((B$3:B$75=B3)*(D$3:D$75<D3)*D$3:D$75);"[>999]\0"))

Автор - krosav4ig
Дата добавления - 25.02.2019 в 04:02
kuzznetss Дата: Понедельник, 25.02.2019, 05:44 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
или, для неотсортированных данных

=СУММПРОИЗВ(--ТЕКСТ(D3-МАКС((B$3:B$75=B3)*(D$3:D$75<D3)*D$3:D$75);"[>999]\0"))


спасибо.формулу приспособил для своей таблицы.
единственный вопрос пока что-как работает и для чего нужно выражение "[>999]\0" -объясните подробно пожалуйста-я в экселе очень ниочень
 
Ответить
Сообщение
или, для неотсортированных данных

=СУММПРОИЗВ(--ТЕКСТ(D3-МАКС((B$3:B$75=B3)*(D$3:D$75<D3)*D$3:D$75);"[>999]\0"))


спасибо.формулу приспособил для своей таблицы.
единственный вопрос пока что-как работает и для чего нужно выражение "[>999]\0" -объясните подробно пожалуйста-я в экселе очень ниочень

Автор - kuzznetss
Дата добавления - 25.02.2019 в 05:44
bmv98rus Дата: Вторник, 26.02.2019, 00:03 | Сообщение № 4
Группа: Проверенные
Ранг: Старожил
Сообщений: 2023
Репутация: 320 ±
Замечаний: 20% ±

Excel 2013/2016
я в экселе очень ниочень
судя по этому в другом преуспели. Правила форума стоит читать.


Замечательный медведь, процентов на 20.
 
Ответить
Сообщение
я в экселе очень ниочень
судя по этому в другом преуспели. Правила форума стоит читать.

Автор - bmv98rus
Дата добавления - 26.02.2019 в 00:03
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Формула для расчета значений из заданного промежутка (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!