Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Возврат положений повторяющихся значений в ячейках строки - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Возврат положений повторяющихся значений в ячейках строки (Формулы/Formulas)
Возврат положений повторяющихся значений в ячейках строки
old_farter Дата: Вторник, 26.02.2019, 14:00 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Здравствуйте! Помогите, пожалуйста, решить проблему.
Ситуация в следующем: есть два графика дежурств. При заполнении второго графика (Лист 2), буквой "х" отмечается дата дежурства сотрудника. И я хочу сделать так, чтобы столбец Дата, в первом графике (Лист 1), заполнялся соответствующими датами дежурства этого сотрудника.
Функция
Код
=ПОИСКПОЗ("х";Лист2!C6:AG6;0)
решает проблему только для первого дежурства сотрудника, а вот как продолжить поиск, я найти не могу. В конечном итоге, в столбце Дата (Лист 1) должен быть записан ряд дат через запятую.
Пример для сотрудника 1: 15, 19, 23
На Лист 1 столбец Дата поделен на ячейки потому что потом я буду выделять жирным дату, которая попадает на выходные и праздничные дни, при помощи условного форматирования. Но, если это можно реализовать в одной строке, то буду благодарен и за эту помощь.
Заранее спасибо!
К сообщению приложен файл: GrafikDezhurstv.xls(39.0 Kb)


Сообщение отредактировал old_farter - Вторник, 26.02.2019, 14:17
 
Ответить
СообщениеЗдравствуйте! Помогите, пожалуйста, решить проблему.
Ситуация в следующем: есть два графика дежурств. При заполнении второго графика (Лист 2), буквой "х" отмечается дата дежурства сотрудника. И я хочу сделать так, чтобы столбец Дата, в первом графике (Лист 1), заполнялся соответствующими датами дежурства этого сотрудника.
Функция
Код
=ПОИСКПОЗ("х";Лист2!C6:AG6;0)
решает проблему только для первого дежурства сотрудника, а вот как продолжить поиск, я найти не могу. В конечном итоге, в столбце Дата (Лист 1) должен быть записан ряд дат через запятую.
Пример для сотрудника 1: 15, 19, 23
На Лист 1 столбец Дата поделен на ячейки потому что потом я буду выделять жирным дату, которая попадает на выходные и праздничные дни, при помощи условного форматирования. Но, если это можно реализовать в одной строке, то буду благодарен и за эту помощь.
Заранее спасибо!

Автор - old_farter
Дата добавления - 26.02.2019 в 14:00
_Boroda_ Дата: Вторник, 26.02.2019, 14:20 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15577
Репутация: 6079 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так нужно?
Код
=ЕСЛИОШИБКА(НАИМЕНЬШИЙ(ЕСЛИ(Лист2!C6:AG6="х";Лист2!C$5:AG$5);СТОЛБЕЦ(A5));)

Формула массива. Вводится одновременным нажатием Ctrl+Shift+Enter
Формат ячеек
Д;;

Или немассивная формула
Код
=ЕСЛИОШИБКА(ПОИСКПОЗ("х";Лист2!AI6:ИНДЕКС(Лист2!$C6:AH6;СУММ(B5;1));)+СУММ(B5);)
К сообщению приложен файл: _2003_1.xls(46.5 Kb) · _2003_2.xls(45.5 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак нужно?
Код
=ЕСЛИОШИБКА(НАИМЕНЬШИЙ(ЕСЛИ(Лист2!C6:AG6="х";Лист2!C$5:AG$5);СТОЛБЕЦ(A5));)

Формула массива. Вводится одновременным нажатием Ctrl+Shift+Enter
Формат ячеек
Д;;

Или немассивная формула
Код
=ЕСЛИОШИБКА(ПОИСКПОЗ("х";Лист2!AI6:ИНДЕКС(Лист2!$C6:AH6;СУММ(B5;1));)+СУММ(B5);)

Автор - _Boroda_
Дата добавления - 26.02.2019 в 14:20
old_farter Дата: Вторник, 26.02.2019, 14:25 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
_Boroda_, да, спасибо Вам огромное!
 
Ответить
Сообщение_Boroda_, да, спасибо Вам огромное!

Автор - old_farter
Дата добавления - 26.02.2019 в 14:25
_Boroda_ Дата: Вторник, 26.02.2019, 14:33 | Сообщение № 4
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15577
Репутация: 6079 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Я там добавил еще немассивную формулу, посмотрите


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеЯ там добавил еще немассивную формулу, посмотрите

Автор - _Boroda_
Дата добавления - 26.02.2019 в 14:33
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Возврат положений повторяющихся значений в ячейках строки (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!