Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Как добавить дополнительное условие в функцию СУММПРОИЗВ - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как добавить дополнительное условие в функцию СУММПРОИЗВ (Формулы/Formulas)
Как добавить дополнительное условие в функцию СУММПРОИЗВ
Denis_ Дата: Среда, 27.02.2019, 17:42 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 45
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Подскажите, как добавить в формулы
Код
=СУММПРОИЗВ((--B1:B699995>=H1)*(--B1:B699995<=I1)*(--("Купля"=G1:G699995)))
и
Код
=СУММПРОИЗВ(E1:E699995*(G1:G699995="Купля")*(--B1:B699995<=I1)*(--B1:B699995>=H1))
еще одно условие
Код
*(D>=H2)*(D<=H3)
, чтобы формулы работали корректно. Пример во вложении.
К сообщению приложен файл: 4822193_1.xlsx(14.1 Kb)
 
Ответить
СообщениеПодскажите, как добавить в формулы
Код
=СУММПРОИЗВ((--B1:B699995>=H1)*(--B1:B699995<=I1)*(--("Купля"=G1:G699995)))
и
Код
=СУММПРОИЗВ(E1:E699995*(G1:G699995="Купля")*(--B1:B699995<=I1)*(--B1:B699995>=H1))
еще одно условие
Код
*(D>=H2)*(D<=H3)
, чтобы формулы работали корректно. Пример во вложении.

Автор - Denis_
Дата добавления - 27.02.2019 в 17:42
_Boroda_ Дата: Среда, 27.02.2019, 17:44 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15574
Репутация: 6075 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Лучше не добавлять, а по-другому написать
Код
=СЧЁТЕСЛИМН(B:B;">="&H1;B:B;"<="&I1;G:G;"Купля";D:D;">="&H2;D:D;"<="&H3)

А если именно добавить, то по аналогии.
* Зачем у Вас там везде "--" понатыканы?
К сообщению приложен файл: 8747374_1.xlsx(13.1 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеЛучше не добавлять, а по-другому написать
Код
=СЧЁТЕСЛИМН(B:B;">="&H1;B:B;"<="&I1;G:G;"Купля";D:D;">="&H2;D:D;"<="&H3)

А если именно добавить, то по аналогии.
* Зачем у Вас там везде "--" понатыканы?

Автор - _Boroda_
Дата добавления - 27.02.2019 в 17:44
Denis_ Дата: Среда, 27.02.2019, 18:01 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 45
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
_Boroda_, по поводу "--" не знаю, так посоветовали.

Но предложенный Вами вариант не по считает вторую формулу
Код
=СУММПРОИЗВ(E1:E699995*(G1:G699995="Купля")*(--B1:B699995<=I1)*(--B1:B699995>=H1))
, там же не счет идет, а суммирование.
 
Ответить
Сообщение_Boroda_, по поводу "--" не знаю, так посоветовали.

Но предложенный Вами вариант не по считает вторую формулу
Код
=СУММПРОИЗВ(E1:E699995*(G1:G699995="Купля")*(--B1:B699995<=I1)*(--B1:B699995>=H1))
, там же не счет идет, а суммирование.

Автор - Denis_
Дата добавления - 27.02.2019 в 18:01
bmv98rus Дата: Среда, 27.02.2019, 18:03 | Сообщение № 4
Группа: Проверенные
Ранг: Старожил
Сообщений: 2467
Репутация: 424 ±
Замечаний: 0% ±

Excel 2013/2016
а по-другому написать
Поддерживаю, хотя есть корректировочка.
Именно для *IFS функций лучше ограничить диапазон, вместо целого столбца. Сам удивлен, но она не ограничивает себя используемым диапазоном. На единичном расчете не заметно, но если много, то разница нарастает, а вот привычка использовать весь столбец остается. Сам так делаю :-(

Но предложенный Вами вариант не по считает вторую формулу

а для этого есть SUMIFS


Замечательный Временно просто медведь , процентов на 20.

Сообщение отредактировал bmv98rus - Среда, 27.02.2019, 18:05
 
Ответить
Сообщение
а по-другому написать
Поддерживаю, хотя есть корректировочка.
Именно для *IFS функций лучше ограничить диапазон, вместо целого столбца. Сам удивлен, но она не ограничивает себя используемым диапазоном. На единичном расчете не заметно, но если много, то разница нарастает, а вот привычка использовать весь столбец остается. Сам так делаю :-(

Но предложенный Вами вариант не по считает вторую формулу

а для этого есть SUMIFS

Автор - bmv98rus
Дата добавления - 27.02.2019 в 18:03
_Boroda_ Дата: Среда, 27.02.2019, 19:09 | Сообщение № 5
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15574
Репутация: 6075 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
предложенный Вами вариант не по считает вторую формулу ... там же не счет идет, а суммирование

А я ее и не считал. Сделайте, как я и писал,
по аналогии
. Если для счета есть функция СЧЁТЕСЛИМН, то для суммы, как нетрудно догадаться, функция СУММЕСЛИМН (тем более, что выше Михаил уже дал подсказку)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщение
предложенный Вами вариант не по считает вторую формулу ... там же не счет идет, а суммирование

А я ее и не считал. Сделайте, как я и писал,
по аналогии
. Если для счета есть функция СЧЁТЕСЛИМН, то для суммы, как нетрудно догадаться, функция СУММЕСЛИМН (тем более, что выше Михаил уже дал подсказку)

Автор - _Boroda_
Дата добавления - 27.02.2019 в 19:09
Denis_ Дата: Четверг, 28.02.2019, 11:13 | Сообщение № 6
Группа: Пользователи
Ранг: Новичок
Сообщений: 45
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
_Boroda_, добрый день!

Сделал, как Вы говорили. Формула все условия считает корректно, кроме условия по времени:
Код
=СУММЕСЛИМН(E1:E10;B1:B10;"<="&I1;B1:B10;">="&H1)

Для удобства анализа выделил условие по времени отдельно.
Файл с примером во вложении. Посмотрите пожалуйста.
К сообщению приложен файл: 1291738.xlsx(10.9 Kb)


Сообщение отредактировал Denis_ - Четверг, 28.02.2019, 11:14
 
Ответить
Сообщение_Boroda_, добрый день!

Сделал, как Вы говорили. Формула все условия считает корректно, кроме условия по времени:
Код
=СУММЕСЛИМН(E1:E10;B1:B10;"<="&I1;B1:B10;">="&H1)

Для удобства анализа выделил условие по времени отдельно.
Файл с примером во вложении. Посмотрите пожалуйста.

Автор - Denis_
Дата добавления - 28.02.2019 в 11:13
_Boroda_ Дата: Четверг, 28.02.2019, 11:45 | Сообщение № 7
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15574
Репутация: 6075 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Проблема округления Excel спецификация IEEE 754 https://u.to/Cx-LFA
Предположу, что таблица откуда-то (из какой-то базы) выгружена, правильно?
В таблице 17:00:00 = 0,708333333333334, а в ячейке I1 = 0,708333333333333
Лечилка вручную - выделить столбец В - Данные - Текст по столбцам - ОК
Лечилка формулой
Код
=СУММЕСЛИМН(E1:E10;B1:B10;"<"&I1+"0:0:1";B1:B10;">"&H1-"0:0:1")
К сообщению приложен файл: 1291738_1.xlsx(9.7 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеПроблема округления Excel спецификация IEEE 754 https://u.to/Cx-LFA
Предположу, что таблица откуда-то (из какой-то базы) выгружена, правильно?
В таблице 17:00:00 = 0,708333333333334, а в ячейке I1 = 0,708333333333333
Лечилка вручную - выделить столбец В - Данные - Текст по столбцам - ОК
Лечилка формулой
Код
=СУММЕСЛИМН(E1:E10;B1:B10;"<"&I1+"0:0:1";B1:B10;">"&H1-"0:0:1")

Автор - _Boroda_
Дата добавления - 28.02.2019 в 11:45
Denis_ Дата: Четверг, 28.02.2019, 12:21 | Сообщение № 8
Группа: Пользователи
Ранг: Новичок
Сообщений: 45
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
_Boroda_, да, база выгружена с другого программного обеспечения. Может поэтому использование символа "--" решало вопрос, а может функция
Код
=СУММПРОИЗВ()

В общем Ваше решение исправило ситуацию. Огромное спасибо.
 
Ответить
Сообщение_Boroda_, да, база выгружена с другого программного обеспечения. Может поэтому использование символа "--" решало вопрос, а может функция
Код
=СУММПРОИЗВ()

В общем Ваше решение исправило ситуацию. Огромное спасибо.

Автор - Denis_
Дата добавления - 28.02.2019 в 12:21
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как добавить дополнительное условие в функцию СУММПРОИЗВ (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!