Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Подсчёт количества отработанных часов в графике работы - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подсчёт количества отработанных часов в графике работы (Формулы/Formulas)
Подсчёт количества отработанных часов в графике работы
tvyur Дата: Среда, 06.03.2019, 08:30 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 9
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Доброе утро.

Уважаемые участники форума, помогите пожалуйста прописать формулу для подсчёта количества отработанных часов в графике работы. Дело в том, что когда я забиваю время с минутами формула начинает ругаться, и выдаёт ЗНАЧ. Файл прилагаю.
К сообщению приложен файл: 111.xlsx(41.1 Kb)


tvyur

Сообщение отредактировал tvyur - Среда, 06.03.2019, 08:37
 
Ответить
СообщениеДоброе утро.

Уважаемые участники форума, помогите пожалуйста прописать формулу для подсчёта количества отработанных часов в графике работы. Дело в том, что когда я забиваю время с минутами формула начинает ругаться, и выдаёт ЗНАЧ. Файл прилагаю.

Автор - tvyur
Дата добавления - 06.03.2019 в 08:30
Michael_S Дата: Среда, 06.03.2019, 08:36 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 1891
Репутация: 353 ±
Замечаний: 0% ±

Excel2016
tvyur, что значит запись: 9/7,30?
-что вы хотите получить из формулы День(9/7,30)?


ЯД: 41001136675053
WM: R389613894253
 
Ответить
Сообщениеtvyur, что значит запись: 9/7,30?
-что вы хотите получить из формулы День(9/7,30)?

Автор - Michael_S
Дата добавления - 06.03.2019 в 08:36
tvyur Дата: Среда, 06.03.2019, 08:39 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 9
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
доброе утро. в ячейке количество часов за месяц должно стоять 79 ч. 30 мин.

9/7,30 - это 9 часов отработано за смену, из них 7,30 - ночных часов.

и неверно выводит колв- во ночных часов.
К сообщению приложен файл: 8593687.xlsx(41.1 Kb)


tvyur

Сообщение отредактировал tvyur - Среда, 06.03.2019, 08:52
 
Ответить
Сообщениедоброе утро. в ячейке количество часов за месяц должно стоять 79 ч. 30 мин.

9/7,30 - это 9 часов отработано за смену, из них 7,30 - ночных часов.

и неверно выводит колв- во ночных часов.

Автор - tvyur
Дата добавления - 06.03.2019 в 08:39
_Boroda_ Дата: Среда, 06.03.2019, 09:08 | Сообщение № 4
Группа: Модераторы
Ранг: Местный житель
Сообщений: 14486
Репутация: 5788 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так нужно?
Код
=СУММПРОИЗВ(--ЛЕВБ(E13:AI13&0;ПОИСК("/";E13:AI13&" /")-1))

ДЕНЬ, который я Вам в прошлый раз предложил, подходит для целых чисел, второе из которых не больше 12. А у Вас дробные, поэтому приходится извращаться
Код
=СУММПРОИЗВ(--ЛЕВБ(ПОДСТАВИТЬ(E13:AI13&0;"/";"    ");5))


Ночные
Код
=СУММПРОИЗВ(--ПРАВБ(ПОДСТАВИТЬ(E13:AI13&0;"/";"    ");5))


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак нужно?
Код
=СУММПРОИЗВ(--ЛЕВБ(E13:AI13&0;ПОИСК("/";E13:AI13&" /")-1))

ДЕНЬ, который я Вам в прошлый раз предложил, подходит для целых чисел, второе из которых не больше 12. А у Вас дробные, поэтому приходится извращаться
Код
=СУММПРОИЗВ(--ЛЕВБ(ПОДСТАВИТЬ(E13:AI13&0;"/";"    ");5))


Ночные
Код
=СУММПРОИЗВ(--ПРАВБ(ПОДСТАВИТЬ(E13:AI13&0;"/";"    ");5))

Автор - _Boroda_
Дата добавления - 06.03.2019 в 09:08
китин Дата: Среда, 06.03.2019, 09:12 | Сообщение № 5
Группа: Модераторы
Ранг: Экселист
Сообщений: 5370
Репутация: 866 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
формула массива
Код
=СУММ(--ЕСЛИОШИБКА(ПСТР($E13:$AI13;1;ПОИСК("/";$E13:$AI13)-1);0))
К сообщению приложен файл: _8593687.xlsx(37.8 Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщениеформула массива
Код
=СУММ(--ЕСЛИОШИБКА(ПСТР($E13:$AI13;1;ПОИСК("/";$E13:$AI13)-1);0))

Автор - китин
Дата добавления - 06.03.2019 в 09:12
Michael_S Дата: Среда, 06.03.2019, 09:12 | Сообщение № 6
Группа: Друзья
Ранг: Старожил
Сообщений: 1891
Репутация: 353 ±
Замечаний: 0% ±

Excel2016
общее:
Код
=СУММ(ЕСЛИОШИБКА(--ЛЕВСИМВ(E13:AI13;ПОИСК("/";E13:AI13)-1);0))

ночные:
Код
СУММ(ЕСЛИОШИБКА(--ПСТР(E13:AI13;ПОИСК("/";E13:AI13)+1;5);0))

Обе формулы массива.


ЯД: 41001136675053
WM: R389613894253
 
Ответить
Сообщениеобщее:
Код
=СУММ(ЕСЛИОШИБКА(--ЛЕВСИМВ(E13:AI13;ПОИСК("/";E13:AI13)-1);0))

ночные:
Код
СУММ(ЕСЛИОШИБКА(--ПСТР(E13:AI13;ПОИСК("/";E13:AI13)+1;5);0))

Обе формулы массива.

Автор - Michael_S
Дата добавления - 06.03.2019 в 09:12
Pelena Дата: Среда, 06.03.2019, 09:14 | Сообщение № 7
Группа: Админы
Ранг: Местный житель
Сообщений: 13782
Репутация: 3027 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
И ночные часы у Вас не совсем правильно подсчитываются
Так точнее
Код
=СУММПРОИЗВ(--(0&ПСТР(E13:AI13;ПОИСК("/";E13:AI13&"/")+1;4)))
К сообщению приложен файл: 2073197.xlsx(36.9 Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеИ ночные часы у Вас не совсем правильно подсчитываются
Так точнее
Код
=СУММПРОИЗВ(--(0&ПСТР(E13:AI13;ПОИСК("/";E13:AI13&"/")+1;4)))

Автор - Pelena
Дата добавления - 06.03.2019 в 09:14
tvyur Дата: Среда, 06.03.2019, 09:26 | Сообщение № 8
Группа: Пользователи
Ранг: Прохожий
Сообщений: 9
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
_Boroda_, Большое спасибо, всё работает. И другим участникам тоже спасибо за помощь. hands hands hands


tvyur
 
Ответить
Сообщение_Boroda_, Большое спасибо, всё работает. И другим участникам тоже спасибо за помощь. hands hands hands

Автор - tvyur
Дата добавления - 06.03.2019 в 09:26
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подсчёт количества отработанных часов в графике работы (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!